Closed Bug 533680 Opened 12 years ago Closed 12 years ago

No way to turn off autodetection of mail account settings

Categories

(Thunderbird :: Account Manager, defect)

x86
Windows XP
defect
Not set
major

Tracking

(thunderbird3.1 wontfix)

RESOLVED WONTFIX
Tracking Status
thunderbird3.1 --- wontfix

People

(Reporter: olaf, Unassigned)

References

()

Details

(Whiteboard: [gs])

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7
Build Identifier: 




Reproducible: Always

Steps to Reproduce:
Try to setup mail account (either as first startup afer install, or from "Account Settings"
Actual Results:  
Presently it starts autodetection and only after it started I have an option to cancel it and setup it manually.
When I try to put corrcet settings in "Incoming" and "Outgoing" fields, they keep overwritten every 2 seconds or so, as the autodetection tries to determine correct settings. OK. It stopped trying after several minutes, so I was able to put the correct settings.
Additionally when I enter "Manual" setup then I get POP3 server type and there is no place to change it to IMAP.

Expected Results:  
It should ask if user wants to autodetect or to do it manually.
It should be possible in manual setup to set correct account type (IMAP/POP)

In my company it gives totally wrong results, as we have separate set of servers (both smtp and pop/imap) for internal and external use.
It took me three attempts to setup it correctly, including deleting "Thunderbird" directory from "Application Data".
Now I have a recipe for my users :) 
1. Start Thunderbird
2. don't import anything
3. enter your data
4. click continue
5. click stop
6. wait 5 minutes, don't touch anything
7. Enter correct settings
In my opinion it is totally crazy. Instead of two simply text entries I have an autodetection machine that gives no benefit and only problems.
updated version information
Version: unspecified → 3.0
Regarding overwritting "Incoming" and "Outgoing" entries there is a timing issue.
If I click "start" and next "stop" very quickly, one after another, then I have this problem. If I wait 1-2 seconds and click "stop", then it stops autodetection and doesn't overwrite these fields.
Component: General → Account Manager
QA Contact: general → account-manager
Please read the mozilla messaging board!
Question: How do I set up POP3 accounts on the lastest version on Thunderbird?
All the people there are thinking this is the bug reporting system, but it is'nt!
It is a strange procedure to find this bug report system and it is also strange to work with it.
This is a part of my entries:
If there is an IMAP-server available then you cannot change to the POP3-server.
Why has the provider an IMAP-server?
1. as a normal service.
2. only for a special user group - perhaps the paying group.
3. for testing reasons.
4. for internal use.
There is a way to create a POP3 account, but this is no solution for a normal user:
1. Close the internet connection.
I have no problem to do this because I can do it in my firewall - blocking all or just Thunderbird.
2. after this step it is possible to create the the POP3 account with your procedure.

A normal user perhaps has no right to stop the network connection or it is to complicated for him.

I think, thousands of people have thrown Thunderbird in the trash because of this little bug. Most of them have no interest to make a report - or they give up with your complicated and slow procedure.
I've seen this problem too.  I don't think it's that we can't stop the autodetection, just that if an autodetection response comes back a little late, we don't ignore it.  ;)

But either way, there's definitely a bug here, that I feel I should look into.

pomponius, is there a server that you can reproduce this on, that I could use to test with?  I don't need to have a real account on it, I just need to be able to hit the server for the autodetection.

Thanks,
Blake.
Assignee: nobody → bwinton
Status: UNCONFIRMED → ASSIGNED
blocking-thunderbird3.0: --- → ?
Ever confirmed: true
FYI.
It can be said that this bug was produced by Bug 515479. Bug 515479 removed "Account Wizzard" of Tb2 from Tb3. AFAIK, request for "come back of Tb2's Account Wizzard" was wontfix'ed.
I have a problem that sounds similar.

1. I have a Verizon FIOS account under res06rdr@gte.net
2. This account provides MSN Premium, including email eg user@msn.com
3. My wife has a dependent account at Verizon (res1sar0@verizon.net) which is not active.
4. My wife does use the account palmerbf@msn.com under Verizon provided MSN Premium.
5. I was trying to set up a palmerbf@msn on a separate netbook running W7.
6. If I specify in TBD the user palmerbf, the automatic system finds MSN incoming and outgoing servers rather than Verizon,
7. If I specify the username res1sar0, then Mozilla can't set up the account palmerbf@msn.com

This may be an implementation beyond the capability of TBD.
I've seen similar things with this as well. I think we should try and fix this on 3.0.x if possible. Blake ping me next week and I'll see if I can come up with some test cases.
blocking-thunderbird3.0: ? → needed
I think this will be solved with Brian's patch for bug 534588.
(In reply to comment #8)
> I think this will be solved with Brian's patch for bug 534588.

Not if the reporter expected:
> Expected Results:  
> It should ask if user wants to autodetect or to do it manually.
> It should be possible in manual setup to set correct account type (IMAP/POP)

There are many cases where "AutoConfigure" is misconfiguring things, and -- in extreme cases -- breaking more than mail; see:  http://getsatisfaction.com/mozilla_messaging/topics/mail_account_setup_wizard_server_probes_too_aggressively.

This Bug Report should probably be changed to an "Enhancement Request" to add a "Manual"/"AutoConfigure" choice -- although it could be argued that ANY misconfiguration by "Autoconfigure" is a bug...
Flags: blocking-thunderbird3.1?
Flags: blocking-thunderbird3.1?
Nominated for blocking 3.1 (should have done it last week i.e. January 11, but I missed it). It's a painful thing for users.
Flags: blocking-thunderbird3.1?
This should probably be marked as a Duplicate of Bug 518411, or -- since there are more relevant comments here -- Bug 518411 should be marked as a Duplicate of this bug.
Attempting to add a new account to my system, and stopping this crazy auto-setup Wizard caused two complete crashes and shut-downs of TB with the error reporting system popping up - I sent the error reports in, of course. This system is so bad it is inconceivable to imagine how it got past testing and into a release version - it must be removed forthwith, and preferably consigned to the bit-bin.
(In reply to comment #12)
> Attempting to add a new account to my system, and stopping this crazy
> auto-setup Wizard caused two complete crashes and shut-downs of TB with the
> error reporting system popping up - I sent the error reports in, of course.

Can you give us the crashIDS (http://kb.mozillazine.org/Breakpad) ?

> This system is so bad it is inconceivable to imagine how it got past testing
> and into a release version - it must be removed forthwith, and preferably
> consigned to the bit-bin.

Please consider joining our volunteer based testing effort and subscribe to https://mail.mozilla.org/listinfo/thunderbird-testers our mailing list.
We've had enough complaints about this that I think some improvement should block 3.1. Bryan, Blake, do you agree?
blocking-thunderbird3.1: --- → rc1+
Flags: blocking-thunderbird3.1?
Moving back to beta2, because I suspect this bug is going to require strings.
blocking-thunderbird3.1: rc1+ → beta2+
Compare bug 549045. The technical part (being able to abort) is probably fixed by bug 549040.
Yes, indeed, I think I have fixed this today in bug 549040. The calls to cancel() are there (as far as I can see). Now they should actually prevent the results to keep coming. Bug 549040 is not 3.0.x fudder, though.
Roland, there seem to be quite a few different perspectives in various comments on this bug about what it refers to, to the point where I'm having a hard time understanding exactly what it would take to resolve it.  Since you've probably read more comments than anyone about this, can you summarize what the exact pain points here are?  Is this really a single bug, or are there multiple?
Assignee: bwinton → roland
Whiteboard: [gs] → [gs][needs definition]
Current expectation is that this is likely to be fixed by some combination of the solution to bug 531088 and the other bug that I can't find at the moment that makes the "cancel" button actually work.  Keeping this as a blocker so that we remember to re-read and ensure ourselves that this ends up in a reasonable state before we ship b2.
Assignee: roland → bwinton
Whiteboard: [gs][needs definition] → [gs][probably fixed by bug 532590]
In general, I think this bug is covered by some combination of bug 532590 (which is a blocker), along with bug 531088 and bug 534588 (which are not).  Because I believe those bugs are already have their blocking flags correctly set/unset, and because this bug is really amorphous, having it on the blocker list is not actually changing the state of what we're going to ship, and is actually making the list harder to manage, so I'm going to remove it from the list.
Assignee: bwinton → nobody
Blocks: 532590, 531088, 534588
blocking-thunderbird3.1: beta2+ → ---
Whiteboard: [gs][probably fixed by bug 532590] → [gs]
dmose, this is mostly covered by bug 549045.
Bug 532590 and bug 531088 do nothing to for this.
No longer blocks: 531088, 532590, 534588
Depends on: 549045, 534588
> When I try to put corrcet settings in "Incoming" and "Outgoing" fields, they
> keep overwritten every 2 seconds or so, as the autodetection tries to determine
> correct settings. OK. It stopped trying after several minutes, so I was able to
> put the correct settings.

Yes, this is exactly fixed by bug 549045.
(In reply to comment #21)
> dmose, this is mostly covered by bug 549045.

Some of the complaints with the wizard are addressed by 549045, but not the main request: The ability to NOT do an auto-configure (and, therefore, not bombard your company's firewall with "probes" on disallowed ports such that your IP address is then placed on a "deny" list).

From the original problem description (see above):
> Expected Results:  
> It should ask if user wants to autodetect or to do it manually.

None of the other bug reports mentioned as providing "solutions" do, in fact, provide the capability to disable auto-detection.
> The ability to NOT do an auto-configure

That would be WONTFIX.

I've seen people ask for exactly that, very passionately, only to admit later that they would have configured non-SSL servers for their ISP when we found SSL servers. Even with advanced users, we should have a shot first.

As for companies, if you're bothered by that, you can either just place an XML file on your web server (see <https://developer.mozilla.org/en/Thunderbird/Autoconfiguration#Small_company>), or - with bug 549045 - you can hit "Stop" or "Manual edit" immediately after clicking "Continue". The 3 config file lookups we make (not guessing) typically take 2-3 seconds, enough time for you to cancel before we go into guessing, if that bothers you.

The *current* wizard is horrible, and I understand why you complain and demand a way to stop the detection. I believe that bug 549045 makes it work proper enough that this one http lookup which you need to cancel is good enough.

In other words, either you are just one guy in your company, and then this one time when we make the requests doesn't make. Or your company uses Thunderbird in a bigger scale, and then it's trivial for you to make autoconfig just work (by placing one XML file on your server or in your Thunderbird installation) instead of disabling it.

> It should ask if ...

One of the ideas is that we ask as little as theoretically possible.
(In reply to comment #24)
> > The ability to NOT do an auto-configure
> 
> That would be WONTFIX.

Then this bug should be closed with that "Resolution" (ha!), since the ability to not do an auto-configure is what the reporter requested in the "Expected Results".
OK, WONTFIX

But as said, most of the current pain will be resolved with bug 549045. With that, it will be very easy to stop autodetection early on.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → WONTFIX
I'm not actually convinced that the functionality described in comment 23 is a WONTFIX, but I don't think anything related to this particular bug itself is likely to be a useful way to drive it forward.  If someone wants to file a new bug describing that, and only that, use case, I'd be ok with that. Other use cases are welcome as well, but they, too, should have their own, individual bugs, lest they end up like this one.
(In reply to comment #24)
> > The ability to NOT do an auto-configure
> 
> That would be WONTFIX.
> 
> I've seen people ask for exactly that, very passionately, only to admit later
> that they would have configured non-SSL servers for their ISP when we found SSL
> servers. Even with advanced users, we should have a shot first.

Well, please consider that not all admins work in hospital for mental disorders ;)
Excuse me, but I get frustrated when people know "better" for other people.

> 
> As for companies, if you're bothered by that, you can either just place an XML
> file on your web server (see
> <https://developer.mozilla.org/en/Thunderbird/Autoconfiguration#Small_company>),

Thanks, it is OK for me.

> (...)
> > It should ask if ...
> 
> One of the ideas is that we ask as little as theoretically possible.
I don't know if this idea is 100% right :)
The problem is not too many questions, but if they are the right questions.

What is wrong in two buttons: "Configure my mail account automatically" and "I want to configure my mail account manually"?
blocking-thunderbird3.0: needed → ---
Duplicate of this bug: 568160
Although I know nobody's looking at this anymore, I think the following comment on Get Satisfaction is pertinent:
http://getsatisfaction.com/mozilla_messaging/topics/automated_configuration_feature_sucks#reply_3012039
Nobody is looking any more, but Google still is.

It is always, 100%, every single time wrong when a program is
coded up to override user wishes, based on a presumption that
the program knows better.  Bzzt.  Bad try.  Please take a course
on user interface engineering.  Thank you.
Mr. Korb, please try again without insulting. Thanks.
When we override user wishes, that's a bug, and we have a fix that's mentioned above.
There's a workaround for 3.1, documented here:
http://support.mozillamessaging.com/en-US/kb/FAQ+Changing+IMAP+to+POP
You need to log in before you can comment on or make changes to this bug.