Closed Bug 533695 Opened 10 years ago Closed 10 years ago

New mail folder icon is identical to standard folder icon with default theme on Windows XP

Categories

(Thunderbird :: Folder and Message Lists, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

(thunderbird3.1 beta2-fixed, blocking-thunderbird3.0 -)

RESOLVED FIXED
Thunderbird 3.1b2
Tracking Status
thunderbird3.1 --- beta2-fixed
blocking-thunderbird3.0 --- -

People

(Reporter: lasdka88+mozbugs, Assigned: andreasn)

References

Details

(Keywords: access, Whiteboard: [UXprio])

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0)

I upgraded to Thunderbird v3.0 today. I used the migration assistant tab to specify that I did NOT want to use smart folders.

When I get new mail, the account icon (eg: Local Folders) gets a star, but the sub-folder into which the mail is filtered doesn't. Previously all folders which received new mail got a 'new mail' starred icon until they were accessed.

Now there's no easy way of finding where the new mail went. Very frustrating!

Reproducible: Always

Steps to Reproduce:
1. Set up a filter to filter some incoming mail into a subfolder.
2. Send some mail that will get filtered.

Actual Results:  
When the mail is received the message count for the folder into which it is filtered increases but there is no indication that the folder hasn't yet been accessed since the new mail arrived.

Expected Results:  
The folder icon should have changed to indicate that the folder has not been accessed since the new mail arrived. Otherwise, a user coming back to their email cannot tell into which folders the new mail went.

This feature has become broken between the last Thunderbird 2 release and the Thunderbird 3.0 release.

This is particularly problematic for users like myself with many subfolders (over 50), since having to check each folder individually to see if it was the one that received the new mail is completely impractical.

I think that not being able to tell which folder your mail went into is a pretty major problem for an email client, so I have marked it as such.
Are you using imap or pop3? This works fine here, though folders with new messages are colored blue, not with a star, in the default theme.
The folder color actually depends on the desktop theme, see bug 523972.
David :Bienvenu. I'm using both POP3 and IMAP.

rsx11m. I can confirm that this is a problem with the default theme.

I just downloaded and installed a different theme (walnut, https://addons.mozilla.org/en-US/thunderbird/addon/1495) and folders with new items are now clearly distinguishable by an arrow on the folder icon.

I switched back to the default theme, sent myself a few emails and the problem reappeared. The icon for folders containing new items in the default theme is  is apparently indistinguishable from those containing no new items.
See Also: → 523972
Summary: Folders don't get stars when new mail arrives → New mail folder icon is identical to standard folder icon with default theme on Windows XP
Paul could attache here a screenshot of the issue using above "Add an attachment" link?
This image demonstrates the bug. A new mail has arrived, as can be seen from the star on the local folders icon. However, we can't tell where it is. Inbox, Drafts, or 0-folder-icon-test.
Having searched through all the folders, we finally find the new main tucked away in the 0-folder-icon-test folder. Now we can see that in part 1 this folder should have had been starred (or otherwise modified) to indicate that it contained a new mail. This would have prevented me from having to search through all folders to find it.
Sorry for the typos in the comment provided with attachment 417456 [details]. It should have read:

Having searched through all the folders, we finally find the new mail tucked
away in the 0-folder-icon-test folder. Now we can see that in part 1 this
folder should have been starred (or otherwise modified) to indicate that it
contained new mail. This would have prevented me from having to search
through all folders to find it.
That's indeed the same issue as in bug 523972, for your specific Desktop Theme (which appears to be Windows Classic rather than the XP default theme from what I can tell) it is black vs. black, which doesn't help much in distinguishing new mail folders from others with unread messages.

See the following articles on how to modify that color with "userChrome.css":
> http://kb.mozillazine.org/Thunderbird_3.0_-_New_Features_and_Changes/Themes#Folder_Pane
> http://kb.mozillazine.org/UserChrome.css

This should do as a workaround until bug 523972 is fixed.
That's correct about 'Windows Classic'. I changed the style on my XP install some time ago and forgot about it.

I tried the workaround suggested in the first link you provided but this didn't work for me. It's possible that the portable version of Thunderbird that I am using expects the userChrome.css file in a different location. I'll experiment more later.

I am not sure that this is the same as bug 523972, because I was really commenting on the lack of a star on the folder icon, rather than there being no change in colour.

I understand now from the links you provided that the new-mail star on the folder icons was been removed from the latest version of Thunderbird. It seems inconsistent that now new mail is sometimes represented by a star (like on the account folder) and sometimes represented by a change in colour (sub-folders). It also seems odd that a working feature - a star icon, has been replaced by a broken one, colour variants - which not only causes problems when colours en up being the same like I have reported - but which could cause problems for colour-blind users even if the colours are different.

"If it isn't broken, why break it?" springs to my mind.
let's use this bug for the "folders with new" indication issue.
Assignee: nobody → clarkbw
Status: UNCONFIRMED → NEW
blocking-thunderbird3.0: --- → ?
Ever confirmed: true
Duplicate of this bug: 534188
blocking-thunderbird3.0: ? → needed
Duplicate of this bug: 532100
Keywords: access
Whiteboard: [UXprio]
About the access keyword: an icon is needed for people having difficulty discriminating colors (be it dark blue vs black or not).
Using specific folder images instead of text colors.
Attachment #433330 - Flags: ui-review?(clarkbw)
Comment on attachment 433330 [details] [diff] [review]
patch to fix the issue

sure, looks fine.
Attachment #433330 - Flags: ui-review?(clarkbw) → ui-review+
Keywords: checkin-needed
ugh, I'm not awake today. I need code review first. :(
Keywords: checkin-needed
Attachment #433330 - Flags: review?(philringnalda)
Attachment #433330 - Flags: review?(philringnalda) → review+
Checked in: http://hg.mozilla.org/comm-central/rev/32adc634eb7c
Assignee: clarkbw → nisses.mail
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.1b2
Duplicate of this bug: 555604
Depends on: 562934
I see there is a patch to fix this issue. How do I install the pactch or where do I place the file? I am kinda new to this level of the program.
Now that 3.1 is almost out, I've also decided that we shouldn't really be changing default themes/actions in stable branches, therefore not blocking a 3.0 release on this - users can pick up the fix in 3.1.
blocking-thunderbird3.0: needed → -
You need to log in before you can comment on or make changes to this bug.