If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

change keyboard shortcut to send message (CTRL+ENTER could be disabled or replaced)

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED INVALID
8 years ago
3 years ago

People

(Reporter: furia, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; WOW64; Trident/4.0; SLCC1; .NET CLR 2.0.50727; FDM; InfoPath.1; .NET CLR 3.5.30729; MS-RTC LM 8; .NET CLR 3.0.30729; OfficeLiveConnector.1.4; OfficeLivePatch.1.3)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20091214 Eudora/3.0b4

I'm used to use CTRL+ENTER to break lines under Word and other editors. 
However, under Eudora, it sends the (almost always uncompleted) Message!

There should have a way to disable this shortcut or to replace it by another (such as ALT+S in other editors).

Thanks.

Reproducible: Always

Steps to Reproduce:
1. Type CTRL+N to create new message
2. Type CTRL+ENTER

Actual Results:  
The message is sent, which is dangerous for uncomplete messages, or a message box is displayed: "Are you sure you are ready to send this message", which is annoying. 

Expected Results:  
Enter a new line inside the message

If BUGs 57805 and 228015 (related to keyboard shortcuts) are resolved, then this BUG could also be resolved.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0
Alt-S to send is bug 324882; I don't know if there's any existing specific bug to turn off the keyboard shortcut for sending, or even just to disable Ctrl-Enter.

I suggest morphing this bug slightly to be the latter: pref to disable using Ctrl-Enter to send, or something like that.
(In reply to comment #0)
> I'm used to use CTRL+ENTER to break lines under Word and other editors. 
> However, under Eudora, it sends the (almost always uncompleted) Message!

Strange. My MS Word on WinXP has had Ctrl+Enter for page break ever since. Is it OS-dependent?

> Expected Results:  
> Enter a new line inside the message

Not on Windows (as above).

> If BUG 57805 and bug 228015 (related to keyboard shortcuts) were resolved, then this BUG would also be resolved.
Depends on: 57805
OS: Windows Vista → All
Hardware: x86_64 → All
Blocks: 713979
Per my comment 2, I think this bug is invalid: Expected result for Ctrl+Enter is NOT a new line, that should be Shift+Enter. So I'm failing to see the potential for user error, why would users press Ctrl+Enter at all?

We could implement a pref to disable Ctrl+Enter, but that's going down a dangerous route because we'll end up pref-ing all shortcuts which is not sustainable. The real solution for that is Bug 57805.
Given the lack of comments, votes, duplicates here, this doesn't seem to be an issue for users, so if it weren't invalid, it's probably wontfix.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.