Mozilla should warn user on file|quit

VERIFIED DUPLICATE of bug 51584

Status

()

Core
XPCOM
P3
major
VERIFIED DUPLICATE of bug 51584
18 years ago
18 years ago

People

(Reporter: Jesse Ruderman, Assigned: Ray Whitmer)

Tracking

({dataloss})

Trunk
x86
Windows 98
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Mozilla should warn the user on file|quit before closing everything, because 
it's too easy to get confused about the menu items or just accidentally hit the 
wrong one.

I think this applies to Windows and Linux but not to Mac.  See
http://developer.kde.org/documentation/standards/kde/style/basics/windows.html.

Related:

bug 28385 "downloading dialog" should warn on file|quit
bug 41264 "send as html?" dialog in mail should block file|quit
bug 44602 need internal notification on file|quit (?)
byg 48360 manage bookmarks window shouldn't have file|quit.
(Reporter)

Comment 1

18 years ago
Mostfreq based on:
bug 17014 move "close" on file menu near "quit"
bug 39057 change "quit" to "quit all" or "close all" (9 dups)
bug 39639 quitting mailnews causes browser to quit as well

Nominating for rtm, because this is a common source of data loss and is 
extremely annoying.  Also adding dataloss keyword.

Btw, I wouldn't mind if bug 17014 was fixed as well.  Having "close" next 
to "open" may make sense for compose mail and editor, but not for Navigator and 
the main Mail window.
Keywords: dataloss, mostfreq, rtm

Comment 2

18 years ago
XPCOM? What does this have to do with XPCOM??


*** This bug has been marked as a duplicate of 51584 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.