Better End User Documentation

RESOLVED INVALID

Status

P3
normal
RESOLVED INVALID
18 years ago
12 years ago

People

(Reporter: zach, Unassigned)

Tracking

({meta})

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
At the moment, there is no documentation for the average user. I would be 
willing to write a draft for this, and even own some to keep it up to date. I'll 
attach docs to this bug as I write them.
(Reporter)

Comment 1

18 years ago
can we do a draft for M19?
Target Milestone: --- → M19

Comment 2

18 years ago
Zach, we've developed docs for the Netscape commercial builds. We're trying to
get PR3 out the door. We could just check in the docs to the mozilla tree, maybe
next week. Seems like that could serve as a basis for mozilla docs. Else, there
will be a lot of duplication of effort.

The Netscape docs would have to cleaned up---"Netscape" and references to
"Instant Messenger" would have to be removed. And there would be other clean
up,in addition to any new content that could be added specifically for mozilla.

What sort of docs were you proposing? Format? And accessed at the site or
installed locally?
(Reporter)

Comment 3

18 years ago
Wow. Fast responce. I was thinking of a local docs page accessed from 
the help menu. That would link to all documentation hosted from 
mozilla.org. That way, the actuall docs could be changed without forceing 
everyone to upgrade. As for the type of docs, I am refering to the kind of 
stuff that you find in a printed manual for software (features, menu items 
and what they do...) If we are going to start from the NS docs, all the better, 
it will make things easier. I would be happy to help with making them 
work, but I don't have cvs/website access. I am in the middle of making 
the local file right now. I'll attach it for comment soon.
(Reporter)

Comment 4

18 years ago
I have access to gila, now and I have some more time too. Can we check 
the NS docs in and then work on de NSing them to fit mozilla. Once this is 
done we could get one of the code folks to implement a command in the 
help menu to point to some place on the mozilla.org site.
(Reporter)

Comment 5

18 years ago
from my post to n.p.m.documentation:

I filed bug http://bugzilla.mozilla.org/show_bug.cgi?id=54561 a little while 
ago because "we need some user docs". At present, there are no docs for 
the users that use mozilla. rudman@netscape.com's comments suggest 
that the NS docs could be checked into gila and then could be de-NS'd for 
use with Mozilla (no discussion of AIM, documentation on chatzilla...) Is 
this going to happen? I would like to be able to work on this, as we should 
have something for .9 at the latest, but .6 would be much better. 

A product must have some documentation for the users, even one as 
simple as a browser, to document the interesting features that make 
things easier to do and make Mozilla Mozilla.

Comment 6

18 years ago
Zach, reassign to me if you like. I have been working on some user docs, and I'll 
put them up on the Web for review (together with style guide, and
platform-specific style sheets) when they're in a reasonable state of 
completeness.

I can not disagree more strongly with the idea that user docs consist of local 
links to Net-bound documentation. Online documentation is no good in three cases:
(1) the user is not connected to the internet (e.g. if they use Mozilla to browse
    a CD or an Intranet);
(2) the user is using the docs to try and work out why Mozilla isn't connecting
    to the Net at all;
(3) someone is trying to figure out how to use an old version of Mozilla in a
    decade or so when the links have broken.
(Reporter)

Comment 7

18 years ago
mpt: Put them up!
Assignee: zach → mpt

Comment 8

18 years ago
Resetting target milestone from M19 which is meaningless by now. Correct me if
I'm wrong.
Target Milestone: M19 → ---
(Reporter)

Comment 9

18 years ago
We have the NS help checked in now, should we mark this FIXED and 
work on de-netscapeing and working on the docs that we already have?
(Reporter)

Comment 10

18 years ago
Created attachment 30677 [details] [diff] [review]
Patch to junk aim from the help, it's a start. Another patch comming in a sec.
(Reporter)

Comment 11

18 years ago
forget the other patch for now, but pelase checkin the aim patch, we don't 
need that help.
(Reporter)

Comment 12

18 years ago
Created attachment 31511 [details] [diff] [review]
Also, remove the aim docs from the jar.mn file patch
(Reporter)

Comment 13

18 years ago
CC'ing Ian Oeschger on this bug to help get the patches landed.

Comment 14

16 years ago
Ok, I feel bad about this, since I said in comment 6 that I'd write some docs. 
But I'm doing things in order of effect on Mozilla's usability at the moment. 
And since Nobody Reads the Help(TM), writing user docs isn't that important, so 
I probably won't get to it for about three or four years (based on the current 
rate of improvement in Mozilla's UI).

In the meantime, unless the user help content improves dramatically in the near 
future, I think it would be a good idea to remove (or at least hide) the help 
function completely. Currently Mozilla's help system seems considerably more 
embarrassing than useful; and while the presence of a help browser might be 
expected to spur people to write useful help to put in it, that hasn't happened 
over the past couple of years.

--> default owner
Assignee: mpt → rudman

Comment 15

16 years ago
*** Bug 168861 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
"We need some user docs" is too vague a bug statement

*** This bug has been marked as a duplicate of 46917 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 17

16 years ago
I've changed my mind. reopening
Status: RESOLVED → REOPENED
Depends on: 46917, 89898
Keywords: meta
Resolution: DUPLICATE → ---
Summary: We need some user docs → Better End User Documentation

Updated

16 years ago
Depends on: 139810, 146434

Updated

16 years ago
No longer depends on: 146434

Updated

16 years ago
Depends on: 149567, 150262, 170240, 187393

Updated

16 years ago
Depends on: 146434
No longer depends on: 89898, 149567, 150262, 170240, 187393

Updated

16 years ago
No longer depends on: 146434

Updated

16 years ago
No longer depends on: 139810

Updated

16 years ago
Depends on: 187446

Updated

16 years ago
Depends on: 133060

Updated

16 years ago
Depends on: 120459

Comment 18

15 years ago
taking over some of Rudman's bugs
Assignee: rudman → stolenclover
Status: REOPENED → NEW

Comment 19

15 years ago
We need to take rudman out of the QA contact field. We also need to decide
whether or not to wait until Mozilla is split into FB/TB, etc. User docs for the
bloat version will be a LARGE task to say the least. It doesn't make sense to do
so if the bloat (monolithic) Seamonkey is to be deprecated.

Comment 20

15 years ago
This was my thought all along, but the documentation is still needed for, say,
companies that standadize on the suite - they will need documentation.  I still
think that FB/TB docs should be of a higher priority (This reminds me: I need to
work some more on TB docs) than Seamonkey docs.  

I don't know... Just my thoughts.

Comment 21

15 years ago
> We need to take rudman out of the QA contact field. We also need to decide

Daniel is default QA for all help components, so changing to him.

> so if the bloat (monolithic) Seamonkey is to be deprecated.

Seamonkey will never be fully deprecated. The Seamonkey docs do need a rewrite
badly, but nobody has the time to do it.

Firebird Help docs and Help Viewer are done for the most part. Thunderbird
doesn't have a working help viewer yet. Help docs for Thunderbird are at
http://mozdev.org/bugs/show_bug.cgi?id=4463. Thunderbird Help Viewer is at
http://mozdev.org/bugs/show_bug.cgi?id=4486.

I'm planning on posting the Firebird Help documentation to the Help Viewer home
page (http://www.mozilla.org/projects/help-viewer) so that people can read it
for errors (without having to download fbh).
More Info -> http://firebirdhelp.mozdev.org
QA Contact: rudman → stolenclover

Comment 22

15 years ago
tracking bug doesn't need owner / qa
Assignee: stolenclover → nobody
QA Contact: stolenclover → nobody
Really out of date.
Status: NEW → RESOLVED
Last Resolved: 16 years ago12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.