If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash at [@ SkypeFfComponent.dll@0x440c3 ] & [@ @0x0 | SkypeFfComponent.dll@0x440c3 ]

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
--
critical
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

(4 keywords)

3.6 Branch
x86
Windows Vista
crash, topcrash, verified1.9.1, verified1.9.2
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking1.9.2 .14+, status1.9.2 .14-fixed, blocking1.9.1 .17+, status1.9.1 .17-fixed)

Details

(Whiteboard: [crashkill][crashkill-outreach] [crashkill-thirdparty][explosive], crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
new Crash for 3.6 currently new Top 30 Crash 

http://crash-stats.mozilla.com/report/list?range_value=2&range_unit=weeks&signature=SkypeFfComponent.dll%400x440c3&version=Firefox%3A3.6

i guess that the Skype Extension/Plugin for Firefox

Comment 1

8 years ago
That's not a plugin... over to extension-compat for now.
Component: Plug-ins → Extension Compatibility
Product: Core → Firefox
QA Contact: plugins → extension.compatibility
Version: 1.9.1 Branch → 3.6 Branch
This is the Skype web add-on which gets installed into the extension folder of the application directory. Its installation is enabled by default when installing or updating Skype as what I can read from different Skype forums.

Given by the crash reports this crash only occurs for Vista and Windows 7. Windows XP users are not affected.
OS: Windows XP → Windows Vista
The core-counts report in http://people.mozilla.com/crash_analysis/ suggests this is a threadsafety bug:

  SkypeFfComponent.dll@0x440c3|EXCEPTION_ACCESS_VIOLATION (1071 crashes)
      0% (0/1071) vs.   1% (503/69154) x86 with 0 cores
      6% (67/1071) vs.  38% (26266/69154) x86 with 1 cores
     75% (799/1071) vs.  54% (37616/69154) x86 with 2 cores
      1% (7/1071) vs.   0% (280/69154) x86 with 3 cores
     15% (157/1071) vs.   6% (3886/69154) x86 with 4 cores
      4% (41/1071) vs.   1% (601/69154) x86 with 8 cores
      0% (0/1071) vs.   0% (2/69154) x86 with 16 cores

(though 6% is a relatively high count for a single core machine).
Looks like this is related to a new version of skype:

    100% (1071/1071) vs.   5% (3232/69154) SkypeFfComponent.dll
          0% (1/1071) vs.   0% (1/69154) 
          0% (0/1071) vs.   0% (113/69154) 4.2.0.4825
        100% (1070/1071) vs.   5% (3118/69154) 4.2.0.5016
    100% (1070/1071) vs.   9% (6382/69154) SkypePnr.dll
          0% (1/1071) vs.   0% (2/69154) 
          0% (0/1071) vs.   0% (14/69154) 1.0.2.3224
          0% (0/1071) vs.   0% (8/69154) 1.0.2.3486
          0% (0/1071) vs.   0% (56/69154) 1.0.2.3765
          0% (0/1071) vs.   4% (3079/69154) 1.0.2.3920
          0% (0/1071) vs.   0% (4/69154) 1.0.2.4254
          0% (0/1071) vs.   0% (111/69154) 4.2.0.4823
        100% (1069/1071) vs.   4% (3108/69154) 4.2.0.5004

... probably one that shipped recently.

Comment 5

8 years ago
This is now the number 2 TopCrasher for Firefox 3.6.  Has Skype been contacted?

Comment 6

8 years ago
steady growth beginning feb 9 when it first appeared. 

20100205-crashdata 0 SkypeFfComponent.dll@0x440c3
20100206-crashdata 0 SkypeFfComponent.dll@0x440c3
20100207-crashdata 0 SkypeFfComponent.dll@0x440c3
20100208-crashdata 0 SkypeFfComponent.dll@0x440c3
20100209-crashdata 117 SkypeFfComponent.dll@0x440c3
20100210-crashdata 260 SkypeFfComponent.dll@0x440c3
20100211-crashdata 378 SkypeFfComponent.dll@0x440c3
20100212-crashdata 492 SkypeFfComponent.dll@0x440c3
20100213-crashdata 621 SkypeFfComponent.dll@0x440c3
20100214-crashdata 723 SkypeFfComponent.dll@0x440c3
20100215-crashdata 821 SkypeFfComponent.dll@0x440c3
20100216-crashdata 917 SkypeFfComponent.dll@0x440c3
20100217-crashdata 1038 SkypeFfComponent.dll@0x440c3
20100218-crashdata 1137 SkypeFfComponent.dll@0x440c3
20100219-crashdata 1248 SkypeFfComponent.dll@0x440c3
20100220-crashdata 1360 SkypeFfComponent.dll@0x440c3
20100221-crashdata 1480 SkypeFfComponent.dll@0x440c3
20100222-crashdata 1658 SkypeFfComponent.dll@0x440c3
20100223-crashdata 1740 SkypeFfComponent.dll@0x440c3
20100224-crashdata 1910 SkypeFfComponent.dll@0x440c3
20100225-crashdata 1703 SkypeFfComponent.dll@0x440c3
20100226-crashdata 1030 SkypeFfComponent.dll@0x440c3
20100227-crashdata 2175 SkypeFfComponent.dll@0x440c3
20100228-crashdata 1478 SkypeFfComponent.dll@0x440c3
20100301-crashdata 2461 SkypeFfComponent.dll@0x440c3
20100302-crashdata 2665 SkypeFfComponent.dll@0x440c3
20100303-crashdata 2679 SkypeFfComponent.dll@0x440c3
20100304-crashdata 2667 SkypeFfComponent.dll@0x440c3
20100305-crashdata 2718 SkypeFfComponent.dll@0x440c3
20100306-crashdata 2839 SkypeFfComponent.dll@0x440c3
20100307-crashdata 3159 SkypeFfComponent.dll@0x440c3
20100308-crashdata 2712 SkypeFfComponent.dll@0x440c3
20100309-crashdata 3356 SkypeFfComponent.dll@0x440c3
20100310-crashdata 3433 SkypeFfComponent.dll@0x440c3

pretty closely tied to start up

Correlation to startup or time of session
3433 total crashes for SkypeFfComponent.dll@0x440c3 on 20100310-crashdata.csv
2405 start up crashes inside 30 seconds of startup
3011 start up crashes inside 3 minutes of startup

seems to affect all versions but 3.6 more

checking --- 20100310-crashdata.csv SkypeFfComponent.dll@0x440c3
release total-crashes
              SkypeFfComponent.dll@0x440c3 crashes
                         pct.
all     271954  3433    0.0126235
3.0.15  922     3       0.0032538
3.0.16  288             0
3.0.17  886     2       0.00225734
3.0.18  15242   47      0.00308358
3.5.5   2648    4       0.00151057
3.5.6   1454    3       0.00206327
3.5.7   4369    8       0.00183108
3.5.8   88914   433     0.00486987
3.6     126611  2907    0.0229601
3.6b5   933     9       0.0096463
3.7a1   276             0
3.7a1pre327             0

also seems to only be affecting nt 6.1 and 6.0

2059 SkypeFfComponent.dll@0x440c3 Windows NT 6.1.7600
 485 SkypeFfComponent.dll@0x440c3 Windows NT 6.0.6002 Service Pack 2
 314 SkypeFfComponent.dll@0x440c3 Windows NT 6.0.6001 Service Pack 1

Updated

8 years ago
Whiteboard: [crashkill] → [crashkill][crashkill-outreach] [crashkill-thirdparty][explosive]

Comment 7

8 years ago
might also be known under the signatures

3026 SkypeFfComponent.dll@0x440c3
 404 @0x0 | SkypeFfComponent.dll@0x440c3
   1 freebl3.dll@0x4 | SkypeFfComponent.dll@0x440c3
   1 freebl3.dll@0x30002 | SkypeFfComponent.dll@0x440c3
   1 freebl3.dll@0x2 | SkypeFfComponent.dll@0x440c3

Comment 8

8 years ago
looks like there is a hotfix release yesterday but no indication a crash problem in firefox has been resolved in the detailed release notes.

http://www.skype.com/intl/en/download/skype/windows/

Comment 9

8 years ago
I submitted a support request to skype and hope they follow up here in the bug, or contact me.

Comment 10

8 years ago
(In reply to comment #7)
> might also be known under the signatures
> 
> 3026 SkypeFfComponent.dll@0x440c3
>  404 @0x0 | SkypeFfComponent.dll@0x440c3
>    1 freebl3.dll@0x4 | SkypeFfComponent.dll@0x440c3
>    1 freebl3.dll@0x30002 | SkypeFfComponent.dll@0x440c3
>    1 freebl3.dll@0x2 | SkypeFfComponent.dll@0x440c3

all these stack signatures look roughly the same with small variations at the top of the stack.

0  	 	@0x3010002  	
1 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0x440c3 	
2 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0x4261 	
3 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0x6271d 	
4 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0x4208 	
5 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0x45d2 	
6 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0x2f99d 	
7 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0x60013 	
8 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0x301fe 	
9 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0x3084d 	
10 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0x601d8 	
11 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0xeeb1 	
12 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0x62422 	
13 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0xee58 	
14 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0xf282 	
15 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0x1845e 	
16 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0x17df3 	
17 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0xf8fe 	
18 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0x625e7 	
19 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0x1564b 	
20 	SkypeFfComponent.dll 	SkypeFfComponent.dll@0x63c3f 	
21 	xul.dll 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1041
22 	xul.dll 	nsGlobalWindow::AddRef 	dom/base/nsGlobalWindow.cpp:1070
23 	xul.dll 	nsScriptSecurityManager::GetPrincipalAndFrame 	caps/src/nsScriptSecurityManager.cpp:2285
24 	xul.dll 	nsScriptSecurityManager::GetCxSubjectPrincipal 	caps/src/nsScriptSecurityManager.cpp:384
25 		@0x8f4c7f 	
26 	xul.dll 	nsCxPusher::Push 	content/base/src/nsContentUtils.cpp:2774
27 	xul.dll 	nsCxPusher::RePush 	content/base/src/nsContentUtils.cpp:2802
28 	xul.dll 	nsEventListenerManager::HandleEvent 	content/events/src/nsEventListenerManager.cpp:1147
Isn't SkypeFfComponent.dll the Skype Toolbar? While having a quick search on Google a lot of results point to that piece of Addon. Sadly I wasn't able to download that because of a broken download link.

Marcia, I have seen that the toolbar was installed on the QA machine in the lab which I have prepared with WinDBG. Can you point to the url of the toolbar to download or send me/attach that file?
Hi
It seems this might indeed be due to the Skype extension for Firefox. We are looking into it. 
Can anyone reproduce this problem? Any steps that reliably produces a crash?

Best regards
Peter Kalmström, PM Skype Toolbars, skype: peter.kalmstrom.nu
Peter, can you give me a link where I can download this version of the toolbar? That would help me a lot. I can try to reproduce it afterward.
Hi Henrik,
http://go.skype.com/dc.clicktocall
After some consideration we have found that this bug is actually fixed, but we have yet to release the update. Please let me know if you can reproduce the crash.

Best regards
Peter Kalmström, PM Skype Toolbars, skype: peter.kalmstrom.nu
Peter, I will try to get it reproduced. Btw. is there a download location for the new beta version?
Keywords: topcrash
Henrik,
No we currently do not have it available, we should within a few days though.
(In reply to comment #14)
> http://go.skype.com/dc.clicktocall

Peter, this msi installer does not contain the Skype toolbar for Firefox. When I click on change the only toolbar which is shown there is for IE.

Comment 18

8 years ago
#3 top crash in very early firefox 3.6.2 crash data.  Peter, any update on availability?

Comment 19

8 years ago
Hey guys, 


I just reinstalled a fresh version of windows 7, the newest skype client, and the latest version of firefox. 

I used to be having issues with a nvidia driver crashed the FF, since the reformat, i have had 1 firefox crash due to this skype extension. 

When I get home from school today in about 6 hours, I will try reproducing the crash the skype extension creates.

Comment 20

8 years ago
http://crash-stats.mozilla.com/report/index/0225a38d-f1f5-4946-a77e-808402100327

Very wierd, This crash happened right after i restarted my cpu, I stared my eve-online client, and then started firefox, it loaded the default google page, and I clicked on my "myspace" bookmark in the bookmarks tab, the FF client then crashed and submitted the report. 

Before my reformat I had always had trouble with the myspace site causing crashed for some odd reason, this may be unrelated, but I wont rule it out either. 

Will do some more browsing on and off the myspace site and others to try and reproduce again.
Joshua, can you please give me a link from where you have downloaded the Skype toolbar for Firefox? I'm still waiting for an answer from my comment 17.

Comment 22

8 years ago
(In reply to comment #21)
> Joshua, can you please give me a link from where you have downloaded the Skype
> toolbar for Firefox? I'm still waiting for an answer from my comment 17.



Henrik,

This extension was automatically installed when I downloaded the skype client. I have just reformatted my computer, I downloaded firefox first then used ff to download skype. It auto installed the toolbar plugin and asked me to restart fire fox.

I hope this helps.
(Reporter)

Updated

8 years ago
Summary: Crash at [@ SkypeFfComponent.dll@0x440c3 ] → Crash at [@ SkypeFfComponent.dll@0x440c3 ] & [@ @0x0 | SkypeFfComponent.dll@0x440c3 ]

Updated

8 years ago
Duplicate of this bug: 549226

Updated

8 years ago
Duplicate of this bug: 563279

Comment 25

7 years ago
Are you still looking for a copy of the skype client? I am bug report 578206 and have been having this crash quite frequently. I still have a 1.6MB executable in my downloads folder that I downloaded and installed from Skype.

SypeSetup.exe
File Version 4.2.0.155

I have uploaded a copy to one of my webservers. Let me know if you no longer need it, so that I can delete the file from the server.

http://www.theten.co.uk/SkypeSetup.exe

Comment 26

7 years ago
FYI, I just worked with a woman on the phone on this. She's running Win7, Fx 3.6.6 and has version 4.2.0.5198 of the Skype extension installed (she just recently installed skype). She called us because Fx would crash often (but not always) when opening it up from a shortcut on her desktop. The shortcut took her to her MyEbay page FWIW. I looked up her crash reports and they point to this bug. I had her disable the extension (no option to uninstall).

Comment 27

7 years ago
I just experienced this crash on Windows 7, however, I have the latest version of Skype installed (4.2.0.169). I also noticed that it is currently number 2 on the top crashers list for Firefox 3.6.8:

http://crash-stats.mozilla.com/topcrasher/byversion/Firefox/3.6.8

Why is the Skype toolbar still crashing Firefox if the bug has been fixed?

Updated

7 years ago
Assignee: nobody → peter.kalmstrom

Updated

7 years ago
Duplicate of this bug: 578206

Comment 29

7 years ago
I looked at a sample of 100 recent crashes.
100% of the crashes are when SkypeFfComponent.dll| version 4.2.0.5016 is around.
a 36% of the crashes are at address 0x10000000 and then there are a variety of other crash addresses.

http://www.skype.com/intl/en-us/get-skype/on-your-computer/windows/ says latest version.

Version 4.2.0.187 File size 18 MB. Official release. Release date: September 6, 2010. File name: SkypeSetup.exe

I'm not sure why the version number is higher than the latest version offered on the site.  Peter, can you comment on that?


I'm pretty our guidance should be for firefox users encountering this crash to update to the latest Skype to fix the crash.   If anyone spots a crash on a the current version offered for download or one later than 4.2.0.5016 please post in the bug.

Comment 30

7 years ago
Internet archive doesn't help to point out when 4.2.0516 would have been offered on the skype site.

http://web.archive.org/web/*/http://www.skype.com/download/skype/windows/

maybe the SkypeFfComponent.dll version and product version can differ.  Can anyone with skype installed report back on the version if SkypeFfComponent.dll when they have the latest product version (4.2.0.187) installed?

Comment 31

7 years ago
Hi, All...

I can tell you that I am running Skype BETA 5.0.0.123 - while there is no issue with Skype itself, these crashes still happen in Firefox.  Now that I know it's related to Skype, I can disable the Skype / Firefox connection - or I can leave it, if it would be good for testing / debugging purposes for someone.

Thanks...

Andy
Reassigning to nobody@mozilla.org since Sheila has mentioned Peter is no longer the contact there. She will work on finding a new contact.
Assignee: peter.kalmstrom → nobody
We need to blocklist at least older versions of Skype.

See also https://bugzilla.mozilla.org/show_bug.cgi?id=615799
blocking1.9.1: --- → ?
blocking1.9.2: --- → ?
blocking2.0: --- → ?

Updated

7 years ago
blocking2.0: ? → ---
Blocking to track the blocklisting update
blocking1.9.1: ? → .17+
blocking1.9.2: ? → .14+
status1.9.1: --- → wanted
status1.9.2: --- → wanted

Updated

7 years ago
Blocks: 615799
(In reply to comment #34)
> Blocking to track the blocklisting update

bug 627278
Depends on: 627278

Comment 36

7 years ago
Here is some of the latest correlation data on 3.6.13.

Crashes are predominently on 4.2.0.5198

but there are a few SkypeFfComponent.dll@0x440c3 crashes on 5.0.0.6906

and

SkypeFfComponent.dll@0x1ab6 has

         40% (35/87) vs.   3% (5319/158316) 5.0.0.6778
         53% (46/87) vs.   5% (8117/158316) 5.0.0.6906

so that might be a new crash or signature shifting.



  SkypeFfComponent.dll@0x440c3|EXCEPTION_ACCESS_VIOLATION_EXEC (4552 crashes)
    100% (4544/4552) vs.  17% (27657/158316) {AB2CE124-6272-4b12-94A9-7303C7397BD1}
        100% (4532/4552) vs.   9% (13870/158316) 4.2.0.5198
          0% (0/4552) vs.   0% (15/158316) 5.0.0.4825
          0% (0/4552) vs.   0% (46/158316) 5.0.0.5809
          0% (0/4552) vs.   0% (290/158316) 5.0.0.6483
          0% (9/4552) vs.   3% (5319/158316) 5.0.0.6778
          0% (3/4552) vs.   5% (8117/158316) 5.0.0.6906

  @0x0 | SkypeFfComponent.dll@0x440c3|EXCEPTION_ACCESS_VIOLATION_EXEC (681 crashes)
    100% (681/681) vs.  17% (27657/158316) {AB2CE124-6272-4b12-94A9-7303C7397BD1}
        100% (678/681) vs.   9% (13870/158316) 4.2.0.5198
          0% (0/681) vs.   0% (15/158316) 5.0.0.4825
          0% (0/681) vs.   0% (46/158316) 5.0.0.5809
          0% (0/681) vs.   0% (290/158316) 5.0.0.6483
          0% (1/681) vs.   3% (5319/158316) 5.0.0.6778
          0% (2/681) vs.   5% (8117/158316) 5.0.0.6906

  SkypeFfComponent.dll@0x440c3|EXCEPTION_ACCESS_VIOLATION_READ (196 crashes)
    100% (196/196) vs.  17% (27657/158316) {AB2CE124-6272-4b12-94A9-7303C7397BD1}
         99% (195/196) vs.   9% (13870/158316) 4.2.0.5198
          0% (0/196) vs.   0% (15/158316) 5.0.0.4825
          0% (0/196) vs.   0% (46/158316) 5.0.0.5809
          0% (0/196) vs.   0% (290/158316) 5.0.0.6483
          0% (0/196) vs.   3% (5319/158316) 5.0.0.6778
          1% (1/196) vs.   5% (8117/158316) 5.0.0.6906

  SkypeFfComponent.dll@0x440c3|EXCEPTION_ACCESS_VIOLATION_WRITE (119 crashes)
    100% (119/119) vs.  17% (27657/158316) {AB2CE124-6272-4b12-94A9-7303C7397BD1}
        100% (119/119) vs.   9% (13870/158316) 4.2.0.5198
          0% (0/119) vs.   0% (15/158316) 5.0.0.4825
          0% (0/119) vs.   0% (46/158316) 5.0.0.5809
          0% (0/119) vs.   0% (290/158316) 5.0.0.6483
          0% (0/119) vs.   3% (5319/158316) 5.0.0.6778
          0% (0/119) vs.   5% (8117/158316) 5.0.0.6906


SkypeFfComponent.dll@0x1ab6|EXCEPTION_ACCESS_VIOLATION_READ (87 crashes)
    100% (87/87) vs.  17% (27657/158316) {AB2CE124-6272-4b12-94A9-7303C7397BD1}
          7% (6/87) vs.   9% (13870/158316) 4.2.0.5198
          0% (0/87) vs.   0% (15/158316) 5.0.0.4825
          0% (0/87) vs.   0% (46/158316) 5.0.0.5809
          0% (0/87) vs.   0% (290/158316) 5.0.0.6483
         40% (35/87) vs.   3% (5319/158316) 5.0.0.6778
         53% (46/87) vs.   5% (8117/158316) 5.0.0.6906


SkypeFfComponent.dll@0x1a260|EXCEPTION_ACCESS_VIOLATION_READ (75 crashes)
    100% (75/75) vs.  17% (27657/158316) {AB2CE124-6272-4b12-94A9-7303C7397BD1}
          0% (0/75) vs.   9% (13870/158316) 4.2.0.5198
          0% (0/75) vs.   0% (15/158316) 5.0.0.4825
          0% (0/75) vs.   0% (46/158316) 5.0.0.5809
        100% (75/75) vs.   0% (290/158316) 5.0.0.6483
          0% (0/75) vs.   3% (5319/158316) 5.0.0.6778
          0% (0/75) vs.   5% (8117/158316) 5.0.0.6906


  @0x0 | SkypeFfComponent.dll@0x440c3|EXCEPTION_ACCESS_VIOLATION_READ (54 crashes)
    100% (54/54) vs.  17% (27657/158316) {AB2CE124-6272-4b12-94A9-7303C7397BD1}
        100% (54/54) vs.   9% (13870/158316) 4.2.0.5198
          0% (0/54) vs.   0% (15/158316) 5.0.0.4825
          0% (0/54) vs.   0% (46/158316) 5.0.0.5809
          0% (0/54) vs.   0% (290/158316) 5.0.0.6483
          0% (0/54) vs.   3% (5319/158316) 5.0.0.6778
          0% (0/54) vs.   5% (8117/158316) 5.0.0.6906
Skype is now softblocked (bug 627278).

Comment 38

7 years ago
Justin, Chris, can you please provide a crashdump of the 5.0 findings? Thanks
(In reply to comment #37)
> Skype is now softblocked (bug 627278).

calling this effectively fixed, then.
status1.9.1: wanted → .17-fixed
status1.9.2: wanted → .14-fixed

Comment 40

7 years ago
(In reply to comment #38)
> Justin, Chris, can you please provide a crashdump of the 5.0 findings? Thanks

You can drill down on any one of the reports under this search query

http://crash-stats.mozilla.com/report/list?signature=SkypeFfComponent.dll@0x1ab6

Comment 41

7 years ago
Created attachment 506527 [details]
daily Skype .dll crash rates for Jan 2011 pre and post soft block

(In reply to comment #39)
> (In reply to comment #37)
> > Skype is now softblocked (bug 627278).
> 
> calling this effectively fixed, then.

Still early to tell, but it looks like the soft block is starting to have a positive effect on the daily crash rate.   down from 8000 crashes per day to just under 6000 crashes per day on all skype crashes.  A few things complicate the numbers.  One is that a data migration for the crash system happended on Saturday and we may be missing a few crashes from my data sample there, and second is that most of this is over a weekend when usage and crash reporting is generally lower.   I'll update again in a few days with some more data.

Comment 42

7 years ago
Follow up on https://bugzilla.mozilla.org/show_bug.cgi?id=546632 – we don’t believe there are any bugs in our Skype release that start from 5.0.0.6483 onwards that have resulted in crashes stated above, specifically:

SkypeFfComponent.dll@0x1ab6|EXCEPTION_ACCESS_VIOLATION_READ (87 crashes)
    100% (87/87) vs.  17% (27657/158316) {AB2CE124-6272-4b12-94A9-7303C7397BD1}
          7% (6/87) vs.   9% (13870/158316) 4.2.0.5198
          0% (0/87) vs.   0% (15/158316) 5.0.0.4825
          0% (0/87) vs.   0% (46/158316) 5.0.0.5809
          0% (0/87) vs.   0% (290/158316) 5.0.0.6483
         40% (35/87) vs.   3% (5319/158316) 5.0.0.6778
         53% (46/87) vs.   5% (8117/158316) 5.0.0.6906

Our team looked at the Mozilla crash reports and we were not able to find any logs of crashes for 0x1ab6 on 5.0 – this problem was fixed on our side.  It has been several days of investigation and we cannot reproduce this , can you please double check your records and if these do exist provide us with more information to help troubleshoot this?


  SkypeFfComponent.dll@0x440c3|EXCEPTION_ACCESS_VIOLATION_READ (196 crashes)
    100% (196/196) vs.  17% (27657/158316)
{AB2CE124-6272-4b12-94A9-7303C7397BD1}
         99% (195/196) vs.   9% (13870/158316) 4.2.0.5198
          0% (0/196) vs.   0% (15/158316) 5.0.0.4825
          0% (0/196) vs.   0% (46/158316) 5.0.0.5809
          0% (0/196) vs.   0% (290/158316) 5.0.0.6483
          0% (0/196) vs.   3% (5319/158316) 5.0.0.6778
          1% (1/196) vs.   5% (8117/158316) 5.0.0.6906

Our team looked at the Mozilla crash reports and we were not able to find any logs of crashes for 440C3 – this problem was fixed on our side for all of 5.0 releases.  It has been several days of investigation and we cannot reproduce this , can you please double check your records and if these do exist provide us with more information to help troubleshoot this?

thanks
Marking verified for branches since it is now blocked in all versions.
Keywords: verified1.9.1, verified1.9.2

Comment 44

7 years ago
Crash volume has been around 5800 for the last couple of days so the affect of the soft blocking might be diminishing.  Hopefully we will see further declines in the crash rates and I'll update in another few days.

re: comment 42

There is one signature that is exclusively on version 5.0.0.6483

SkypeFfComponent.dll@0x1a260|EXCEPTION_ACCESS_VIOLATION_READ (62 crashes)
    100% (62/62) vs.  13% (22826/175979) {AB2CE124-6272-4b12-94A9-7303C7397BD1}
          0% (0/62) vs.   7% (11464/175979) 4.2.0.5198
          0% (0/62) vs.   0% (18/175979) 5.0.0.4825
          0% (0/62) vs.   0% (45/175979) 5.0.0.5809
        100% (62/62) vs.   0% (225/175979) 5.0.0.6483
          0% (0/62) vs.   3% (4484/175979) 5.0.0.6778
          0% (0/62) vs.   4% (6590/175979) 5.0.0.6906

The volume on this signature seems to be running 60-100 crashes per day.

And there continues to be crashes showing up on 5.0.0.6778 and 5.0.0.6906
Is 5.0.0.6483 a newer version than 5.0.0.6778 and 5.0.0.6906?

Here is a list of signatures where we see 5.0.0.6778 and 5.0.0.6906 showing up.

On SkypeFfComponent.dll@0x1ab6 |EXCEPTION_ACCESS_VIOLATION_READ (76 crashes)
    100% (76/76) vs.  13% (22826/175979) {AB2CE124-6272-4b12-94A9-7303C7397BD1}
          3% (2/76) vs.   7% (11464/175979) 4.2.0.5198
          0% (0/76) vs.   0% (18/175979) 5.0.0.4825
          0% (0/76) vs.   0% (45/175979) 5.0.0.5809
          0% (0/76) vs.   0% (225/175979) 5.0.0.6483
         41% (31/76) vs.   3% (4484/175979) 5.0.0.6778
         57% (43/76) vs.   4% (6590/175979) 5.0.0.6906

SkypeFfComponent.dll@0x9a2cf|EXCEPTION_ACCESS_VIOLATION_READ (22 crashes)
    100% (22/22) vs.  13% (22826/175979) {AB2CE124-6272-4b12-94A9-7303C7397BD1}
          0% (0/22) vs.   7% (11464/175979) 4.2.0.5198
          0% (0/22) vs.   0% (18/175979) 5.0.0.4825
          0% (0/22) vs.   0% (45/175979) 5.0.0.5809
          0% (0/22) vs.   0% (225/175979) 5.0.0.6483
        100% (22/22) vs.   3% (4484/175979) 5.0.0.6778
          0% (0/22) vs.   4% (6590/175979) 5.0.0.6906

And this one on 5.0.0.6906
SkypeFfComponent.dll@0x97d39|EXCEPTION_ACCESS_VIOLATION_READ (14 crashes)
    100% (14/14) vs.  13% (22826/175979) {AB2CE124-6272-4b12-94A9-7303C7397BD1}
          0% (0/14) vs.   7% (11464/175979) 4.2.0.5198
          0% (0/14) vs.   0% (18/175979) 5.0.0.4825
          0% (0/14) vs.   0% (45/175979) 5.0.0.5809
          0% (0/14) vs.   0% (225/175979) 5.0.0.6483
          0% (0/14) vs.   3% (4484/175979) 5.0.0.6778
        100% (14/14) vs.   4% (6590/175979) 5.0.0.6906

Comment 45

7 years ago
I spun off bug 629033 to deal exclusively with crashes that affect 5.0.0.x versions of the toolbar.

We should also spin of remaining bugs that deal with performance issues and hidden installation.  Does anyone know if bugs are on file for those issues?

Comment 46

7 years ago
still very slow progress in reducing the number of daily crashes.  it's inched down from 5800, to 5700, and 5200 crashes in the last few days.

I also checked about how many of these crashes had e-mail address, and it looks like only about 80-90 per day have contact info so it probably doesn't make sense to set up the e-mail auto responder for this one.

Comment 47

7 years ago
Why is this added to blockers? It is not a Firefox bug, but a Skype.

Comment 48

7 years ago
Kev, Boris and the skype team have been working on this.  As of this week all crash bugs are fixed with the latest build of Skype.  We are working with Boris , please let us know if there's someone else at Mozilla we should be working with to close this bug and confirm the fixes.  thanks
Whilst you say the crash bugs are all fixed on 3rd Feb, there were still 49,000 crashes in the last 2 weeks:
https://crash-stats.mozilla.com/report/list?range_value=2&range_unit=weeks&signature=SkypeFfComponent.dll%400x440c3&version=Firefox%3A3.6.13

Is it just a case of people not updating to newer versions of the Skype Firefox toobar? Might putting the toolbar on AMO help make sure that people get updated sooner?

Also, to add to the problems, it would seem that the softblock hasn't done much, since people are just pressing cancel without reading it, which doesn't disable the extension (bug 523784) - and so they aren't even seeing the advice to update their version of Skype on the blocklist info page.

Comment 50

7 years ago
Yes crashes are fixed in latest version. And yes we'd very much like to put the latest toolbar on AMO to force the upgrade.
(Assignee)

Updated

6 years ago
Crash Signature: [@ SkypeFfComponent.dll@0x440c3 ] [@ @0x0 | SkypeFfComponent.dll@0x440c3 ]

Comment 51

6 years ago
Ah, this one. I am resolving as works for me since they provided a new version that works. There have been subsequent crashes pop up and we have new bugs logged for those.
Status: NEW → RESOLVED
Crash Signature: [@ SkypeFfComponent.dll@0x440c3 ] [@ @0x0 | SkypeFfComponent.dll@0x440c3 ] → [@ SkypeFfComponent.dll@0x440c3 ] [@ @0x0 | SkypeFfComponent.dll@0x440c3 ]
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.