Last Comment Bug 615799 - Numerous problems with skype addon
: Numerous problems with skype addon
Status: RESOLVED FIXED
[blocklist]
:
Product: Firefox
Classification: Client Software
Component: Extension Compatibility (show other bugs)
: unspecified
: All All
: -- major with 1 vote (vote)
: ---
Assigned To: Justin Scott [:fligtar]
:
Mentors:
Depends on: 526058 530995 546632 580906 591495 627278 629033
Blocks: 635730
  Show dependency treegraph
 
Reported: 2010-11-30 20:54 PST by Boris Zbarsky [:bz]
Modified: 2011-10-02 08:18 PDT (History)
23 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments

Description Boris Zbarsky [:bz] 2010-11-30 20:54:55 PST
There seem to be a number of bug reports for the Skype addon:

https://bugzilla.mozilla.org/show_bug.cgi?id=613178 (breaks video controls)
https://bugzilla.mozilla.org/show_bug.cgi?id=554832 (more video issues)
https://bugzilla.mozilla.org/show_bug.cgi?id=508232 (breaks login to a bank 
                                                     site)
https://bugzilla.mozilla.org/show_bug.cgi?id=606745 (crashes Firefox)
https://bugzilla.mozilla.org/show_bug.cgi?id=607937 (extra network requests)
https://bugzilla.mozilla.org/show_bug.cgi?id=559286 (breaks web scripts by
                                                     putting unexpected 
                                                     elements in the DOM)

smaug also reports it as causing a performance hit on DOM manipulation; see comments at http://blog.mozilla.com/tglek/2010/11/30/crapware-and-firefox/

Smaug, any idea which addon version you saw that had the problem?

We've blacklisted some old skype addon versions in the past; maybe we need to do that again, given the above.  The video controls issues and the perf hit are particularly worrying me.
Comment 1 Mike Beltzner [:beltzner, not reading bugmail] 2010-11-30 22:06:07 PST
Is there a common version range for those bugs?
Comment 2 Olli Pettay [:smaug] (vacation Aug 25-28) 2010-12-01 02:43:47 PST
I need to find out the bug # for the performance problem.
Comment 3 Olli Pettay [:smaug] (vacation Aug 25-28) 2010-12-01 02:50:00 PST
https://bugzilla.mozilla.org/show_bug.cgi?id=606474#c7
Comment 4 Boris Zbarsky [:bz] 2010-12-01 10:06:20 PST
> Is there a common version range for those bugs?

For the video issues: waiting on responses.

For the bank login, the version being used at the time is 3.3.0.3789 which I think is already blacklisted.

For the crash, waiting on responses.

For the network requests, version 5.0.0.6483 does NOT have the problem.  Waiting on response, if it'll come, for which version did.

For breaking web scripts, bug seems to no longer be reproducible.

For the perf hit, the original report was with skype addon version 4.2.0.5198.  That caused a 325x perf hit (yes, as in 325 times slower).  When retested with skype addon version 5.0.0.6778 (which seems to be the most recent one), the tests are "only" 3-8x slower. 

Personally, I see even a 3-8x hit on DOM manipulation performance as grounds for blocklisting...  The 325x thing is just completely uncalled for.
Comment 5 Mike Beltzner [:beltzner, not reading bugmail] 2010-12-01 11:45:01 PST
We should, if we have not already, blocklist the older versions with the pathological performance impact. While 3-8x DOM slowdown with every Skype installation bites us, I'd rather we determine if we can work with them to ensure that the software is performing better, or can be enabled/disabled more intelligently so it's not hitting us on every single webpage.
Comment 6 Kev Needham [:kev] 2010-12-01 11:47:48 PST
Peter: could you give some input here? This seems to be a bit of a recurring issue, and if there's anything we can work on together, this is a good place to start.
Comment 7 Boris Zbarsky [:bz] 2010-12-01 11:52:46 PST
In case it wasn't clear, btw, from my pov as a DOM module peer the 3-8x hit is just not acceptable.  It more than undoes years of work that we've put in.  Given, further, that this isn't an add-on users _choose_ to install, I think we should strongly consider blocklisting all versions that have a performance impact like that.
Comment 8 Boris Zbarsky [:bz] 2010-12-01 18:50:08 PST
Bug 554832 is apparently caused by skype itself, not by the skype addon.
Comment 9 Boris Zbarsky [:bz] 2010-12-02 06:31:29 PST
Bug 607937 is skype addon version 4.2.0.155 is the claim.
Comment 10 Kev Needham [:kev] 2010-12-15 13:49:46 PST
Product manager from Skype is cc'd and no response, so let's nail the range and kill it if we can confirm perf hit.
Comment 11 Kev Needham [:kev] 2010-12-15 13:58:42 PST
Actually, on reflection, do we want to soft-block the extension as a whole, and hard block the version range of extensions we know seriously impacts UX? We've had past problems, and I think it's fair to say Skype qualifies as a repeat offender. I think it makes sense, but we'll need to cruft the rationale.
Comment 12 Kev Needham [:kev] 2010-12-15 14:00:08 PST
to be clear - cruft as in "make sure we explain why we're doing it adequately"
Comment 13 Ed Morley [:emorley] 2011-01-02 14:33:53 PST
More open Skype issues:
Bug 506941
Bug 509908
Bug 510718
Bug 530995
Bug 546632
Bug 580906
Bug 591495
Bug 591685

Also, according to bug 546632 comment 32, Peter is no longer the correct contact for Skype, so have added the old but still open 'establish contact' bug 526058 as dependency, to find someone more appropriate.
Comment 14 Ed Morley [:emorley] 2011-01-02 15:47:27 PST
The Skype plugin is currently topcrasher #1-2 (depending on when you look) on 3.6.13:
http://crash-stats.mozilla.com/topcrasher/byversion/Firefox/3.6.13
...which even ignoring the DOM slowdowns, is presumably enough to warrant blocklisting at the least 4.x versions anyway. See: Bug 546632

For reference, currently Skype extension versions 3.3.0.3970 and earlier are already blocklisted (in bug 448768).
Comment 15 Dave Garrett 2011-01-02 16:41:04 PST
(In reply to comment #14)
> For reference, currently Skype extension versions 3.3.0.3970 and earlier are
> already blocklisted (in bug 448768).

Soft blocked though, meaning it's user overrideable.

For anyone interested in past problems see bug 448768 comment 3 and bug 448768 comment 14 for a litany of old bugs similar to comment 13 above. There's also plenty of links to support inquiries in bug 448768 comment 0. The Skype extension has a long history of being a buggy piece of junk...
Comment 16 picnicpointwa 2011-01-10 18:09:15 PST
I work at Skype and have sent links to the test owner of the add-on to make sure there is visibility with the right set of people here.  I will also be looping in the PM owner who is responsible for this piece.  I will be following up to make sure these are being looked at.  Look out for an update in the near future.

Thanks.
Comment 17 Ed Morley [:emorley] 2011-01-10 18:14:03 PST
(In reply to comment #16)
> I work at Skype and have sent links to the test owner of the add-on to make
> sure there is visibility with the right set of people here.  I will also be
> looping in the PM owner who is responsible for this piece.  I will be following
> up to make sure these are being looked at.  Look out for an update in the near
> future.
If you could ask them to register on Bugzilla and add themselves to the CC list (top right of page) of this bug as well as the "establish contact with Skype" bug (bug 526058) - that would be extremely helpful - thanks!
Comment 18 Mike Beltzner [:beltzner, not reading bugmail] 2011-01-12 08:22:04 PST
(In reply to comment #11)
> Actually, on reflection, do we want to soft-block the extension as a whole, and
> hard block the version range of extensions we know seriously impacts UX? We've
> had past problems, and I think it's fair to say Skype qualifies as a repeat
> offender. I think it makes sense, but we'll need to cruft the rationale.

Yes, I think this is the right approach.
Comment 19 Dietrich Ayala (:dietrich) 2011-01-13 00:07:46 PST
What's the next step? File a separate bug in AMO::blocklisting for that piece of work?
Comment 20 Justin Scott [:fligtar] 2011-01-13 00:27:43 PST
Kev, Christian, and I met about this last week and wanted to spend 1 more week trying to find a Skype contact. We attacked from a few angles and made really good progress towards talking with the team actually working on the toolbar now. Kev might have more updates, but just wanted to note that this hasn't been sitting here -- we're actively working on it.
Comment 21 Dietrich Ayala (:dietrich) 2011-01-13 00:31:01 PST
Awesome news. Thanks Justin!
Comment 22 Justin Scott [:fligtar] 2011-01-19 19:08:45 PST
I've gone through all of the Skype-related bugs mentioned in this bug and I think there are 4 that are still active: bug 530995, bug 546632, bug 590806, and bug 591495.

These are in addition or relation to being a top-crasher (comment #14) and 3-8x perf impact (comment #4).

Over the past 2 weeks we've doubled our efforts to contact the Skype extension team and several people at Skype have told us they pinged the extension team for us. We did not receive a response from them until this afternoon.

Given the volume of crashes, the extent of the performance impact, the fact that users don't actually choose to install this add-on, and the extension team's lack of response during the weeks we were giving them to solve these issues, we should continue as planned to soft-block all versions of Skype in all versions of Firefox immediately.

This will supersede our previous soft-block of versions lower than 3.3.0.3970. I would like to wait on hard-blocking for a few days to see how helpful the soft-block is.

I've filed bug 627278 for the blocklist, as this bug should remain focused on actually fixing the issues. If these issues are fixed in a future version, we will be happy to reduce the block to only the affected versions. But with 33,000 crashes in the last week, this can't wait any longer for a fix from Skype.

I recommend that this bug's hardblocker status be moved to bug 627278, as that's the fix that's needed by Firefox 4 (though not the preferred one).
Comment 23 Shawn Wilsher :sdwilsh 2011-01-19 19:27:38 PST
Bug 627278 is now a hardblocker, so this no longer needs to block.
Comment 24 Justin Scott [:fligtar] 2011-01-20 18:41:44 PST
Skype is now softblocked (bug 627278).
Comment 25 Brian Smith (:briansmith, :bsmith, use NEEDINFO?) 2011-01-21 12:07:09 PST
Is Skype really affected by bug 590806 or setting it as blocking this a mistake?
Comment 26 Lilian PM for Skype 2011-01-21 12:09:35 PST
As a follow up to the email we have I will be your primary POC from skype for this item.

There are a few items of clarification that we have: 

bug 530995 -  This issue should be fixed in the latest version of skype toolbars (version 5.0.0.6906).  We recommend that users install the latest version of the Skype Client to fix the issue.  You can find the latest install here: http://www.skype.com/intl/en-us/get-skype/
 
bug 591495 - This issue should be fixed in the latest version of skype toolbars (version 5.0.0.6906).  We recommend that users install the latest version of the Skype Client to fix the issue.  You can find the latest install here:
http://www.skype.com/intl/en-us/get-skype/


bug 590806 - the bug is very vague and it is not clear how our plugin is responsible for this please update the bug if so.

bug 546632 - We are actively investigating this item in addition to the perf comments.
Comment 27 Shawn Wilsher :sdwilsh 2011-01-21 12:14:37 PST
(In reply to comment #25)
> Is Skype really affected by bug 590806 or setting it as blocking this a
> mistake?
Talked with fligtar online.  Should be bug 580906.
Comment 28 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-10-02 04:20:34 PDT
A report of a massive memory leak: http://www.reddit.com/r/firefox/comments/kxzqa/i_thought_firefox_7_was_supposed_to_use_less/c2o5wiv
Comment 29 Kev Needham [:kev] 2011-10-02 08:18:49 PDT
If we can verification, that'd be helpful. I've pinged the Skype product team and made them aware. If we do verify, we should open a new bug. This one has been addressed, I believe, so marking it fixed.

(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #28)
> A report of a massive memory leak:
> http://www.reddit.com/r/firefox/comments/kxzqa/
> i_thought_firefox_7_was_supposed_to_use_less/c2o5wiv

Note You need to log in before you can comment on or make changes to this bug.