Closed Bug 548041 Opened 10 years ago Closed 8 years ago

Add/port about:support to Thunderbird and add obfuscated SMTP, IMAP & POP settings

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: rolandtanglao, Assigned: rain1)

References

()

Details

Firefox implemented about:support in Bug 367596. Bug 518607 aims at moving the
basic functionality to Toolkit. This bug is for tracking/implementing the
Thunderbird side, e.g. string additions (en-US l10n).

Bug 545110 is the Seamonkey bug for this feature

Two steps:
1. port about:support to Thunderbird
2. and add smtp, imap and pop settings suitably obscured
FYI We (SeaMonkey) would want #2 as well.
Duplicate of this bug: 548042
(In reply to comment #0)
 
> Two steps:
> 1. port about:support to Thunderbird
> 2. and add smtp, imap and pop settings suitably obscured

Isn't the rule one issue per bug ?
One issue can have many aspects and steps, though.

In this case, step 1 (which is actually "add a menuitem and the code to have it open about:support in a tab" rather than "port") is premature, since there's nothing in toolkit to open yet, but step 2 really should be figured out *now*, in detail, before we move Firefox's code to toolkit and only then realize that we're going to want to show prefs that they don't want to show, or that we're going to want to blacklist regexes that will blacklist things they do want to show, and thus discover too late that we didn't want it in toolkit at all, we wanted to instead have our own copy.
But since we didn't do it before I moved Firefox's code, one of these days I'll file and fix a bug that will let us provide a file that just defines a PREFS_APP_WHITELIST and PREFS_APP_BLACKLIST which will be merged with whatever parts of the PREFS_WHITELIST and PREFS_BLACKLIST in http://mxr.mozilla.org/mozilla-central/source/toolkit/content/aboutSupport.js#52 we all agree are what every app wants.
hope this isn't too late:
(In reply to comment #4)
> One issue can have many aspects and steps, though.
> 
> In this case, step 1 (which is actually "add a menuitem and the code to have it
> open about:support in a tab" rather than "port") is premature, since there's
> nothing in toolkit to open yet, but step 2 really should be figured out *now*,
> in detail, before we move Firefox's code to toolkit and only then realize that
> we're going to want to show prefs that they don't want to show, or that we're
> going to want to blacklist regexes that will blacklist things they do want to
> show, and thus discover too late that we didn't want it in toolkit at all, we
> wanted to instead have our own copy.

whitelist: 
1. any prefs that about:support does for Firefox - About:support for Firefox
only shows modified preferences; we want only modified preferences in
Thunderbird too

obscure/blank out/obfuscate:
1. any pref with a userid of the form user@mailserver.com (would be nice if
about:support shows these prefs but when they are copied to the clipboard they
are obscured
e.g. mail.smtpserver.smtpx.username
mail.identity.idx.*_folder
mail.last_msg_movecopy_target_uri

blacklist:
don't think we need to blacklist anything
sid0 has agreed to take a run at porting about:support as an add-on. Thanks sid
Assignee: nobody → sid.bugzilla
Status: NEW → ASSIGNED
I'm adding a link to the about:support add-on page on Mozilla Labs to the URL
of this bug report for reference. There is also a direct link to AMO for it, https://addons.mozilla.org/en-US/thunderbird/addon/239387/
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.