Closed Bug 553455 Opened 10 years ago Closed 10 years ago

No notification of addons being installed from websites

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla2.0b2
Tracking Status
blocking2.0 --- beta2+

People

(Reporter: tchung, Assigned: mossop)

References

Details

(Whiteboard: [rewrite])

Attachments

(2 files)

There is no notification if an addon has been installed via AMO.  The addons manager should switch to the Features pane automatically.

Repro:
1) install addons branch build: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a3pre) Gecko/20100318 Minefield/3.7a3pre
2) open addons manager
3) install an addon via AMO through the discover pane (eg. Reminder Fox)
4) After the installation via AMO is completed, there is no automatic switch to the Features pane.

Expected:
- AM should switch to the Features pane, and highlight the newly installed addon.

Actual:
- After installation, the pane stays in the AMO window.
Whiteboard: [rewrite]
Blocks: 553457
No longer blocks: 553457
Blocks: 550048
Boriss: Do we want to switch to the Features pane when installing from the Discovery/Get Add-ons pane, or do we want to show some kind of UI in the Discover/Get Add-ons pane? 
The later feels like it fits in with the normal in-page UI that was proposed. Once that is implemented, it should be able to be used here as well - but I'm not expecting to be able to implement that (as currently proposed) for some time.
Assignee: nobody → bmcbride
Keywords: uiwanted
Would be nice to have a test with a locally installed extension. We can cover that with a litmus test via AMO.
Status: NEW → ASSIGNED
Flags: in-testsuite?
Flags: in-litmus?
What if you wanted to install multiple addons from the Get Addons page? If you get pulled away from that list of addons, that just makes more steps that you have to take to get back.
There are 2 issues here I see:

1. EM tab, if open, does not get focused/selected.
2. If you do select the open tab, it is not refreshed and no install progress is being shown.

Instead of switching to the tab (takes users away from what they are doing), perhaps some other sort of notification should be shown, e.g. similar to download progress in the status bar. And a notification when all installs are complete.
Jennifer, can we get feedback from UX?
(In reply to comment #4)
> 2. If you do select the open tab, it is not refreshed and no install progress
> is being shown.

This is no longer an issue.

How about a notification during install that sits on top of whatever you are doing? Similar to how Fennec does it.
Jennifer, do you have had any change to think about a proposal for this bug? What about the new type of notifications we popup via the identity panel or how the downloads are shown?
Version: unspecified → Trunk
blocking2.0: --- → beta1+
Summary: No notification of addons being installed → No notification of addons being installed from websites
Duplicate of this bug: 557959
Duplicate of this bug: 567665
As Blair says in Comment 1, we don't need to switch to the add-ons manager once an add-on has been installed from AMO or an external site.  We only need to notify the user that the download or installation has been successful, prompt for restart (if required), and provide a link to the add-ons manager once the add-on has been successfully installed.  The goal is that the user need not discontinue their current browsing task unless they would like to have additional configuration options.
What about a user not dismissing (i.e. clicking "Restart") the Notification and installing another Addon?
Is the Notification capable of presenting a "Restart needed Info" mentioning all Addons?
Or is it just one notification per Addon?
Can multiple Addon-Installation Notifications exist at all? Do they overlap?
In reply to comment #10 an comment #11:
Hm, maybe always display an "Add-ons Manager" button, and add a "Restart Now" button when one or more add-ons need restart to complete installation or upgrade? What do you think? This would mean (if some previously installed addon needs restart)
 ____________________________/\___
/ / IC \   Woot Watcher has been  \
| \ ON /   installed successfully.|
| One or more add-ons need restart|
| to complete installation/update.|
| [Add-ons Manager] [Restart Now] |
\_________________________________/
Duplicate of this bug: 571437
Depends on: doorhanger
(In reply to comment #12)
> In reply to comment #10 an comment #11:
> Hm, maybe always display an "Add-ons Manager" button, and add a "Restart Now"
> button when one or more add-ons need restart to complete installation or
> upgrade? What do you think? This would mean (if some previously installed addon
> needs restart)
>  ____________________________/\___
> / / IC \   Woot Watcher has been  \
> | \ ON /   installed successfully.|
> | One or more add-ons need restart|
> | to complete installation/update.|
> | [Add-ons Manager] [Restart Now] |
> \_________________________________/

Good idea. However, instead of a balloon, I feel a "Download Completed"-style box should open.
Assignee: bmcbride → dtownsend
Blocks: 552965
This is a hard beta2+ blocker, I think, unless someone has compelling reasons why it should be later.
blocking2.0: beta1+ → beta2+
The 'balloon' kind of thing telling that something has been installed within Firefox is more clear in telling that, than just an 'download completed' kind of message.
(In reply to comment #16)
> The 'balloon' kind of thing telling that something has been installed within
> Firefox is more clear in telling that, than just an 'download completed' kind
> of message.

Considering the user has just accepted the download, it should be only a few seconds before the confirmation of the install being completed. Thus, it doesn't have to be too overt and it should fit with the concept of the unobtrusiveness that's being tested with the new add-ons manager.
Depends on: 574227
Depends on: 574230
No longer blocks: 552965
Depends on: 552965
Fixed by the patches in bug 552965
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Flags: in-testsuite?
Flags: in-testsuite+
Flags: in-litmus?
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3
Lets flag in-litmus? again. Our Litmus tests will also have cover that as an necessary step.
Flags: in-litmus- → in-litmus?
Target Milestone: mozilla1.9.3 → mozilla1.9.3b2
Still not seeing this.

"Right now when I install an addon, a box pops up.  I press install.  Then nothing happens.  Then I have to manually go to the new AOM, scroll down to the random position(why isn't it at the top?) where the restart button is, and press restart.  This is annoying because the restart button used to be on the addon install box after pressing install."
(In reply to comment #20)
> Still not seeing this.
> 
> "Right now when I install an addon, a box pops up.  I press install.  Then
> nothing happens.  Then I have to manually go to the new AOM, scroll down to the
> random position(why isn't it at the top?) where the restart button is, and
> press restart.  This is annoying because the restart button used to be on the
> addon install box after pressing install."

This only landed on trunk an hour or so ago, what build are you testing with?
(In reply to comment #21)
> (In reply to comment #20)
> > Still not seeing this.
> > 
> > "Right now when I install an addon, a box pops up.  I press install.  Then
> > nothing happens.  Then I have to manually go to the new AOM, scroll down to the
> > random position(why isn't it at the top?) where the restart button is, and
> > press restart.  This is annoying because the restart button used to be on the
> > addon install box after pressing install."
> 
> This only landed on trunk an hour or so ago, what build are you testing with?


30-Jun-2010 16:03
released about 12 minutes ago.
(In reply to comment #22)
> (In reply to comment #21)
> > (In reply to comment #20)
> > > Still not seeing this.
> > > 
> > > "Right now when I install an addon, a box pops up.  I press install.  Then
> > > nothing happens.  Then I have to manually go to the new AOM, scroll down to the
> > > random position(why isn't it at the top?) where the restart button is, and
> > > press restart.  This is annoying because the restart button used to be on the
> > > addon install box after pressing install."
> > 
> > This only landed on trunk an hour or so ago, what build are you testing with?
> 
> 
> 30-Jun-2010 16:03
> released about 12 minutes ago.

OS? Where did you download it from?
(In reply to comment #23)
> (In reply to comment #22)
> > 30-Jun-2010 16:03
> > released about 12 minutes ago.
> 
> OS? Where did you download it from?

Better yet, what was it built from in about:buildconfig
(In reply to comment #24)
> (In reply to comment #23)
> > (In reply to comment #22)
> > > 30-Jun-2010 16:03
> > > released about 12 minutes ago.
> > 
> > OS? Where did you download it from?
> 
> Better yet, what was it built from in about:buildconfig


http://hg.mozilla.org/mozilla-central/rev/dacfa73ea420
(In reply to comment #25)
> (In reply to comment #24)
> > (In reply to comment #23)
> > > (In reply to comment #22)
> > > > 30-Jun-2010 16:03
> > > > released about 12 minutes ago.
> > > 
> > > OS? Where did you download it from?
> > 
> > Better yet, what was it built from in about:buildconfig
> 
> 
> http://hg.mozilla.org/mozilla-central/rev/dacfa73ea420

That build does not include the fixes for this then.
Attached image screenshot
in mockup, notification popup from Bookmarks Widget/button.
but notification popup from favicon/identity indicator.
intended ?

see screenshot.
(In reply to comment #27)
> Created an attachment (id=455314) [details]
> screenshot
> 
> in mockup, notification popup from Bookmarks Widget/button.
> but notification popup from favicon/identity indicator.
> intended ?
> 
> see screenshot.


Right now, I think it should stay in the navbar. After Bug 574511 lands, having it popup from the bookmark button will be weird if it isn't there.
Backed out due to test failures.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #27)
> Created an attachment (id=455314) [details]
> screenshot
> 
> in mockup, notification popup from Bookmarks Widget/button.
> but notification popup from favicon/identity indicator.
> intended ?

Yes this was intended. The notifications are essentially coming from the webpage, not your bookmarks
Duplicate of this bug: 576229
Bug 552965 has re-landed
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; en-US; rv:2.0b2pre) Gecko/20100718 Minefield/4.0b2pre

Notifications which are now shown are: 1) allowing the installation for not whitelisted pages and 2) restart Firefox or open the add-ons manager
Status: RESOLVED → VERIFIED
I am not sure whether this is now really fixed, or there is another problem.
The doorhanger restart message is not displayed always.
Scenarios where this doesn't happen:
1. Install the same extension or theme multiple times (e.g. by drag & drop of the jar file into Firefox). Only the first time the doorhanger is shown. 
2. Enabling other theme. The 'restart now' appears on the old and new theme, but the doorhanger is not displayed.

In all cases, the 'restart now' button in the theme list, but the doorhanger is NOT shown.

Detailed scenario:
a. Drag 'theme.jar' into the Addons manager.
b. Click on 'Install Now'.
c. Doorhanger message appears.
d. Enable the new theme.
d. Restart Firefox.
e. Drag 'theme.jar' again into the Addons manager.
f. Click on 'Install Now'.
g. Doorhanger message DOES NOT appear.
h. See in Addons manager that 'restart now' button is in the theme entry.

Expected result:
Everytime an 'Restart Now' button is presented in the Addons Manager list, the doorhanger should also be activated.
Reopening per comment #34.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Alfred, this works fine for me when installing add-ons from websites and which this bug is about. It's not about installing from the local disk. Please file a new bug for the local installation issue you are seeing. Thanks.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
For bug archeology purposes:
Bug 577048 is about the local disk installation, addressing my comments. 
Thanks for opening and solving that bug!
Depends on: 589954
The installation of an add-on from disk shouldn't be triggering a site level notification (doorhanger).  I've filed follow up bug 594564 to convert this to a traditional dialog box.
You need to log in before you can comment on or make changes to this bug.