Enabling plugin should take user to Plugin pane in addons manager

VERIFIED FIXED in mozilla2.0b1

Status

()

VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Trunk
mozilla2.0b1
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [rewrite])

(Reporter)

Description

9 years ago
when enabling a plugin via the Plugin UI, the user should be taken to the "plugins "pane of the new addons manager UI.   Instead, it takes user to "Feature" pane.

Repro:
1) Download Addons project branch nightly: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a4pre) Gecko/20100321 Minefield/3.7a4pre
2) Install Flash, but disable the service via addons manager
3) goto Youtube.com, and find any flash video 
4) notice since flash is disabled, the UI says "The plugin for this content has been disabled. Click here to manage your plugins."
5) Click the viewing area, and notice addons manager opens in a new tab with focus on the Features Pane

Expected:
- It should take user to the Plugins Pane, so user can activate plugin

Actual:
- User is taken to the Features pane.
(Reporter)

Updated

9 years ago
Blocks: 550048
Whiteboard: [rewrite]
blocking2.0: --- → beta1+
blocking2.0: beta1+ → final+
Duplicate of this bug: 571909
Fixed by bug 560449
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite+
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a6
Verified fixed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a6pre) Gecko/20100616 Minefield/3.7a6pre

There is still one problem. All add-ons will be shown when following the steps mentioned in comment 0. I have filed bug 572653 for it.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.