Last Comment Bug 569166 - Enable Direct2D by default for some subset of hardware
: Enable Direct2D by default for some subset of hardware
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Windows Vista
: -- normal with 7 votes (vote)
: ---
Assigned To: Bas Schouten (:bas.schouten)
:
: Milan Sreckovic [:milan]
Mentors:
Depends on: 553089 571447 d2d-reftest 543729 549120 555353 556180 556193 557372 558339 558627 560050 565120 568495 568719 573229 584536 587508
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-30 17:18 PDT by Bas Schouten (:bas.schouten)
Modified: 2013-02-26 05:33 PST (History)
26 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Bas Schouten (:bas.schouten) 2010-05-30 17:18:39 PDT
This is a bug for tracking all issues which prevent Direct2D from being enabled by default, on -some subset- of hardware.
Comment 1 Joe Drew (not getting mail) 2010-08-03 12:25:17 PDT
Let's get this in for beta 4!
Comment 2 Shawn Wilsher :sdwilsh 2010-08-12 09:12:40 PDT
Given the number of dependent bugs for this, is this actually going to make it for beta4?
Comment 3 Bas Schouten (:bas.schouten) 2010-08-12 09:14:25 PDT
(In reply to comment #2)
> Given the number of dependent bugs for this, is this actually going to make it
> for beta4?

I don't think all the dependent bugs actually block Beta4. Some of them can be handled after beta4 I think. We're doing what we can, in any case.
Comment 4 Bas Schouten (:bas.schouten) 2010-08-16 00:25:02 PDT
D2D was re-enabled http://hg.mozilla.org/mozilla-central/rev/f2959b949445. Let's hope it sticks.
Comment 5 Egor Pelevin 2010-08-16 01:53:06 PDT
Why isn't this bug blocked by bug 532106?

Until it's fixed (by the patch for bug 130078 I suppose) D2D is making browsing painful. I need to go to another tab and then switch back before I see any content.

OS: Windows Vista
Graphic card: ATI Mobility Radeon HD 3400 Series (DirectX 10.1)
Drivers: Catalyst 10.7
Comment 6 Bas Schouten (:bas.schouten) 2010-08-16 02:00:22 PDT
(In reply to comment #5)
> Why isn't this bug blocked by bug 532106?
> 
> Until it's fixed (by the patch for bug 130078 I suppose) D2D is making browsing
> painful. I need to go to another tab and then switch back before I see any
> content.
> 
> OS: Windows Vista
> Graphic card: ATI Mobility Radeon HD 3400 Series (DirectX 10.1)
> Drivers: Catalyst 10.7

Because bug 130078 blocks Beta5, and we need to start getting D2D tested now or it won't be ready. We will do what we can to find a temporary fix that will cover the beta 4 testing period. It's possible to try beta 4 without D2D by setting mozilla.widget.render-mode to 0 in about:config.
Comment 7 Joe Drew (not getting mail) 2010-08-16 13:31:49 PDT
Sadly, this needs to slip to beta 5.
Comment 8 Mike Beltzner [:beltzner, not reading bugmail] 2010-08-18 07:34:19 PDT
I believe that this was turned on in http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=42545f8d4b10, yes?
Comment 9 Mike Beltzner [:beltzner, not reading bugmail] 2010-08-18 07:36:01 PDT
Sorry, ignore comment 8 - that's bug 549116 (Enable D2D by default)
Comment 10 Joe Drew (not getting mail) 2010-08-27 20:29:58 PDT
We enabled it by default a couple of weeks ago; we'll leave this open as a tracking bug, but there's no need for it to block beta 5.
Comment 11 Matt Woodrow (:mattwoodrow) 2011-10-06 20:13:15 PDT
Closing this since Direct2D is enabled by default now.

Note You need to log in before you can comment on or make changes to this bug.