[D2D] Page Bookmarked dialog doesn't appear with DirectWrite enabled.

RESOLVED DUPLICATE of bug 556180

Status

()

defect
RESOLVED DUPLICATE of bug 556180
9 years ago
9 years ago

People

(Reporter: streetwolf, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100619 Minefield/3.7a6pre Firefox/3.6.4
Build Identifier: 20100619040308

With DW enabled if you use the context menu 'Bookmark this Page' the normal dialog does not appear and the page is bookmarked automatically in the default folder.  You therefore have no option where to place the bookmark.

With DW disabled it works fine.

Reproducible: Always
Reporter

Updated

9 years ago
Blocks: d2d
Version: unspecified → Trunk
Reporter

Updated

9 years ago
Summary: Page Bookmarked dialog doesn't appear with DirectWrite enabled. → [DW] Page Bookmarked dialog doesn't appear with DirectWrite enabled.
Maybe this is related to the "no tooltips with DW/D2D on" bug?
Reporter

Comment 2

9 years ago
(In reply to comment #1)
> Maybe this is related to the "no tooltips with DW/D2D on" bug?

This?  https://bugzilla.mozilla.org/show_bug.cgi?id=556193

Comment 3

9 years ago
Isn't this already filled under https://bugzilla.mozilla.org/show_bug.cgi?id=556180 ?
Reporter

Comment 4

9 years ago
(In reply to comment #3)
> Isn't this already filled under
> https://bugzilla.mozilla.org/show_bug.cgi?id=556180 ?

It looks like it might be the same problem. Let's see what the Dev thinks.
You have to have D2D rendering enabled to see bug 556180 otherwise its just a bookmarks bug, because I get the same behavior without DW enabled.
 
Unless you click on the star again, the panel doesn't come up.  Bug 556180 is the panel doesn't show at all ever and trying to bookmark does nothing.

Gary, I guess you will have to decide which issue it is.
Reporter

Comment 6

9 years ago
Using the Star button the bookmark goes directly to the Unsorted folder without any panel.  Works this way with or without DW enabled.

Using the Right-Click context menu to 'Bookmark This Page' results in the following:

DW on = No panel asking me where I want to put the bookmark.  I notice that before I reply it's already placed under the Bookmarks Menu folder.  Also if I click anywhere on the screen the panel disappears and my bookmark is left there.

DW off = I do get the panel asking me where I want to put my bookmark. The same situation happens as in sentence 2 and 3 under 'DW on' above.

So it looks to me like a DW problem.
(In reply to comment #6)
> Using the Star button the bookmark goes directly to the Unsorted folder without
> any panel.  Works this way with or without DW enabled.

Confirming, this is what I see.  Putting it in [unsorted] maybe by design for quick bookmarking functionality.  The second time you click it asks to "Edit this bookmark" 

> 
> Using the Right-Click context menu to 'Bookmark This Page' results in the
> following:
> 
> DW on = No panel asking me where I want to put the bookmark.  I notice that
> before I reply it's already placed under the Bookmarks Menu folder.  Also if I
> click anywhere on the screen the panel disappears and my bookmark is left
> there.

Yeah, it looks like its in [bookmarks menu] by default here, I see the panel the first time as "Page Bookmarked"

> DW off = I do get the panel asking me where I want to put my bookmark. The same
> situation happens as in sentence 2 and 3 under 'DW on' above.
> 
> So it looks to me like a DW problem.

Not quite sure about this last bit, I tried a new profile even.  The behavior with _Bookmark this page_ is the same for me with or without DW.  But there are definitely various paths it takes depending on your actions.  They don't all do the same thing.
Please note that you must have D2D disabled to see if DW is the culprit. Disabling DW will -also- disable D2D.
Reporter

Comment 9

9 years ago
With D2D disabled and DW enabled the Bookmarks panel shows up as it also does with both disabled.  So what is this telling you Bas?
(In reply to comment #6)
> DW on =  I notice that before I reply it's already placed under the Bookmarks Menu folder.  Also if I click anywhere on the screen the panel disappears and my bookmark is left there.

> DW off = I do get the panel asking me where I want to put my bookmark. 
> The same situation happens as in sentence 2 and 3 under 'DW on' above.

Confirming I see this too, panel behavior is consistent with both DW on and off. ie after choosing _bookmark this page_, clicking away from the open panel back on the screen somewhere, the panel disappears, the bookmark still gets added.

Note: I also don't have D2D rendering enabled, but just testing DW, DW is also not a live pref.

Basically, I cannot reproduce comment 0 under 32bit windows 7 build.
(In reply to comment #9)
> With D2D disabled and DW enabled the Bookmarks panel shows up as it also does
> with both disabled.  So what is this telling you Bas?

This means it's probably D2D, if it doesn't show up with D2D and DW both enabled.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Summary: [DW] Page Bookmarked dialog doesn't appear with DirectWrite enabled. → [D2D] Page Bookmarked dialog doesn't appear with DirectWrite enabled.
Duplicate of bug: 556180
You need to log in before you can comment on or make changes to this bug.