Open Bug 557990 Opened 10 years ago Updated Last year

In advanced "Search messages" (Ctrl+Shift+F), if search triggered with ENTER after searchword, cannot delete single result message with DEL key if click-selected without prior selection or focus in results list

Categories

(Thunderbird :: Search, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

REOPENED

People

(Reporter: mail, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: reproducible)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)
Build Identifier: 3.0.4

Hi there,

Whenever I go to search for specific e-mails & then I go highlight one of them & click "delete", it doesn't delete.

I finally narrowed it down to being the e-mail that is highlighted in the window pane.

But I think it's still a problem even when I highlight several & press the delete key on the keyboard.

I literally have to use my mouse & hit the "delete" button in the search window to get them to delete.

Reproducible: Sometimes

Steps to Reproduce:
1. I'm cleaning up my inbox, I find an e-mail, I copy the addy to my clipboard then search in a search window for all e-mails from that company/person.
2. I highlight the e-mail(s) I want to delete in the search window & press the delete key.
3.
Actual Results:  
Nothing, the e-mails won't delete.

Only once after nearly killing the delete key would it delete the e-mails, but the rest of the time it wouldn't work.

Expected Results:  
Deleted the e-mails LOL

This has happened several times over the last wkdn. when I started really cleaning out my inbox.

Thank you :  )
Hi Michelle,

thanks for reporting this bug (although the format of your report suggests that you haven't had much time to watch http://blog.johnath.com/2010/02/04/bugzilla-for-humans/ yet, as recommended via mail... ;)
We'd still need a lot more details in the STR... so that we know exactly what you do and where you are. Unfortunately, "magic crystall ball addon" hasn't been implemented yet LOL... I'll try to translate and improve this bug report to show what level of detail we need... (see comment 3)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Won't delete → In advanced "Search messages" (Ctrl+Shift+F), cannot delete first result message with DEL if click-selected right after search
Confirming for Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100406 Lightning/1.0b1 Shredder/3.0.5pre

New Summary:
In advanced "Search messages" (Ctrl+Shift+F), cannot delete first result message with DEL if click-selected right after search
("Won't delete" isn't a good summary as it could refer to virtually anything)

STR (Steps to reproduce):
1 from inbox, press Ctrl+Shift+F (advanced "Search messages" dialogue pops up)
2 with mouse, set "From" contains "the_sender"
3 with cursor still after "the_sender", press ENTER or click "Search" to start search (don't don anything else in the dialogue before, you'll easily spoil it)
4 use MOUSE(!) to click-select a single (!), say first result message
5 press DEL key on keyboard

Expected result
- that (first) result msg should be deleted

Actual result
- nothing happens

STR continued
6a select another (second) message from results with mouse or keyboard
7a press DEL on second msg
7b or return selection to first result message and press DEL
--> will delete the msg as expected

OR
6b expand selection with mouse or keyboard to span multiple msgs, press DEL
--> will delete selected msgs as expected

I conlude that when the dialogue is still untouched and no previous selection has been made in the results list, only the first(!) click on any single result msg does NOT correctly set the selection for that msg.

This is confusing for users as it's somewhat unpredictable if/when DEL will work on the results or not.

A possibly related problem I saw:
- leave search results window alone for some time, to write bug report
- click on (already selected) msg to make sure it's focussed
- press DEL
--> nothing happens at first
--> took 3 full seconds until the msg was actually deleted
(which will probably cause dataloss if user presses DEL more than once because it doesn't seem to work)
This might account for some of the problems described by reporter in comment 0.

Off Topic (OT):

Advanced "Search Messages" seems to be a somewhat forgotten corner of TB, although it's the only specific/advanced search that we have.

- missing preview (bug 258371)
- missing context menu on search results (!!! Bug 302609, SeaMonkey (SM) bug 66970)
- missing keyboard shortcuts for contextual actions on selected search result(s), like Ctrl+R, Ctrl+L etc.
- archaic text-only "toolbar" at the bottom
- what does "File >" mean? Should this be "Move to >"?
- missing "Copy to >" button
- missing "Archive" button
...
(In reply to comment #2)
> A possibly related problem I saw:
> - leave search results window alone for some time, to write bug report
> - click on (already selected) msg to make sure it's focussed
> - press DEL
> --> nothing happens at first
> --> took 3 full seconds until the msg was actually deleted
> (which will probably cause dataloss if user presses DEL more than once because
> it doesn't seem to work)
> This might account for some of the problems described by reporter in comment 0.

I don't have time and it's not reproducible, so I'll dump here FTR

STR
- when testing for this bug, after moving msgs back and forth between Junk and Trash, partly with Ctrl+Shift+M
- when DELeting 2 selected messages from advanced "Search messages" results

Actual result
- huge time lag (> 10 secs) before messages actually went away, and not sure if the right messages were deleted
- during the time lag, status bar showed "Moving 2 messages to trash"
- Thunderbird task still running after closing TB (crash?)

No idea what caused this, maybe Gloda got confused as I was deleting and moving back the same messages all over again quite quickly? Otherwise, TB seemed to be responsive and WinXP was stable.
Sorry for bugspam, Comment 3 should be a separate bug, and STR of comment 3 are NOT for this bug, but it might be somehow related to this bug or the experiences of comment 0.
Summary: In advanced "Search messages" (Ctrl+Shift+F), cannot delete first result message with DEL if click-selected right after search → In advanced "Search messages" (Ctrl+Shift+F), cannot delete single result message with DEL if click-selected without prior selection
Hi Thomas,

Ok, a few things:

1. I don't think it makes a difference, but I don't use Control Shift F. I right click on the folder I want to search on.

2. Ok, I just tested it & it does look like if I click on another e-mail lower down in the list it does delete. I never tried that b4, so maybe it is only the first e-mail that's a problem.

But even when deleting the last e-mail in the search window it took a few seconds to delete. It wasn't as instantaneous like when I was using Mail Tweak in 2.0.

HTH :  )

Thanks


Michelle
P.S. Multiple Search Windows is a MUST for me. I have to be able to open as many as I need, so I was happy to see that this was a new feature in 3.0, but I still would like that other issue fixed (hopefully) where the order of the e-mails come out backwards. Don't remember what bug report that is.

Just searched & I think it was deleted?

This is what I'm referring to...

The new multiple search window feature is great, but when TB finds the
e-mails, I need the e-mails oldest to newest, not the other way around.
I cannot reproduce with 58.0b1 using steps in comment 2. If you are able to reproduce please update the bug
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
(In reply to Wayne Mery (:wsmwk) from comment #6)
> I cannot reproduce with 58.0b1 using steps in comment 2. If you are able to
> reproduce please update the bug

Nothing to update, still fails exactly as described in comment 2.
59.0a1 (2018-01-10) (64-bit)
(In reply to Thomas D. (currently busy elsewhere) from comment #7)
> (In reply to Wayne Mery (:wsmwk) from comment #6)
> > I cannot reproduce with 58.0b1 using steps in comment 2. If you are able to
> > reproduce please update the bug
> 
> Nothing to update, still fails exactly as described in comment 2.
> 59.0a1 (2018-01-10) (64-bit)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I still fail to see how to reproduce this, and using search a lot I have never seen this so I can't imagine it happens always or reliabily, unless this is an edge case.

Which step makes this an edge case?
Flags: needinfo?(bugzilla2007)
(In reply to Wayne Mery (:wsmwk) from comment #9)
> I still fail to see how to reproduce this, and using search a lot I have
> never seen this so I can't imagine it happens always or reliabily, unless
> this is an edge case.
> 
> Which step makes this an edge case?

Reproduces reliably every time, exactly as described, without any imagination.
Imho this isn't an edge case as it fails reliably within a regular workflow, but ymmv as it only fails for the first(!) mouse click on a msg in a results list which hasn't been focused before(!). Any prior focus in the results list, any shift of focus, or using keyboard to focus/select, and the bug will not occur. So it's an edge case only in the sense that it fails only for every first virgin click-select in results list after opening the search.

(In reply to Thomas D. (currently busy elsewhere) from comment #2)
> STR (Steps to reproduce):
> 1 from inbox, press Ctrl+Shift+F (advanced "Search messages" dialogue pops
> up)
> 2 with mouse, set "From" contains "the_sender"

Step 2 "From" not required, subject works the same.

> 3 with cursor still after "the_sender", press ENTER or click "Search" to
> start search (don't don anything else in the dialogue before, you'll easily
> spoil it)
> 4 use MOUSE(!) to click-select a single (!), say first result message
> 5 press DEL key on keyboard

exactly that

> Expected result
> - that (first) result msg should be deleted
> 
> Actual result
> - nothing happens

exactly that

> STR continued
> 6a select another (second) message from results with mouse or keyboard
> 7a press DEL on second msg
> 7b or return selection to first result message and press DEL
> --> will delete the msg as expected
> 
> OR
> 6b expand selection with mouse or keyboard to span multiple msgs, press DEL
> --> will delete selected msgs as expected

The following comment is key:

> I conlude that when the dialogue is still untouched and no previous
> selection has been made in the results list, only the first(!) click on any
> single result msg does NOT correctly set the selection for that msg.

Exactly that, changing selection or focus in the results list in any way, and things are back to normal, until closing and reopening search, when first click will fail again to delete the clicked result message.

> This is confusing for users as it's somewhat unpredictable if/when DEL will
> work on the results or not.

Indeed.
Flags: needinfo?(bugzilla2007)
Also, it's important to use DEL key on keyboard(!) as per STR, NOT the Delete button. All the more weird, so somehow selection works, but not reliably.
Fwiw, I'm on Windows 10 with said 59.0a1 (2018-01-10) (64-bit)
walt, can you have a go?

I still cannot reproduce
Flags: needinfo?(wls220spring)
I can reproduce this using the STR 1 to 5. 

The first result message does not get deleted using the Delete key on the keyboard.

Using Mozilla/5.0 (Windows NT 10.0; WOW64; rv:59.0) Gecko/20100101 Thunderbird/59.0a1 BuildID: 20180122030201
Flags: needinfo?(wls220spring)
(In reply to WaltS48 from comment #14)
> I can reproduce this using the STR 1 to 5. 
> 
> The first result message does not get deleted using the Delete key on the
> keyboard.

Yes, but more precisely, it's the first-clicked result message (any message in the list provided nothing else in the list has been focused yet).
I trust that you can reproduce, which hopefully makes it easy to fix.

But I still cannot reproduce. So I'm either doing something different that you all for "> 3 with cursor still after "the_sender", press ENTER or click "Search" or something is different on my system.  All the more weird because there's only a couple people in this bug, and no dups (I find none), despite this being 8 years old.
Keywords: reproducible
OS: Windows XP → All
(In reply to Wayne Mery (:wsmwk) from comment #16)
> I trust that you can reproduce, which hopefully makes it easy to fix.
> 
> But I still cannot reproduce. So I'm either doing something different that
> you all for "> 3 with cursor still after "the_sender", press ENTER or click
> "Search"

Ugh, sorry Wayne, my bad: You really need to press ENTER after the search word, as clicking [Search] button will NOT reproduce the bug. Weird, I was quite sure about having tested that. With that caveat, reproduced on POP and IMAP, release and daily. So it boils down to:

1) Ctrl+Shift+F -> Advanced Search messages
2) Click into search input field (tabbing into search field also reproduces but make sure to end there and not to tab into results list)
3) Enter search word, press ENTER (important; which field you're searching on doesn't matter but make sure never to focus results list)
4) CLICK-select exactly any ONE result msg in the list (important; don't use keyboard to select, don't click another result item again)
5) Press DEL key on keyboard (important; do not use "Delete" button)

Can you reproduce now?

> or something is different on my system.  All the more weird because
> there's only a couple people in this bug, and no dups (I find none), despite
> this being 8 years old.

Well, conditions of reproducing are quite narrow so easy to miss, and even if it occurs, users will probably not realize it as a bug because if you try on any other msg of the same result set, it's back to normal, so they'll just shrug their shoulders and continue.
Flags: needinfo?(vseerror)
Summary: In advanced "Search messages" (Ctrl+Shift+F), cannot delete single result message with DEL if click-selected without prior selection → In advanced "Search messages" (Ctrl+Shift+F), if search triggered with ENTER after searchword, cannot delete single result message with DEL if click-selected without prior selection or focus in results list
Summary: In advanced "Search messages" (Ctrl+Shift+F), if search triggered with ENTER after searchword, cannot delete single result message with DEL if click-selected without prior selection or focus in results list → In advanced "Search messages" (Ctrl+Shift+F), if search triggered with ENTER after searchword, cannot delete single result message with DEL key if click-selected without prior selection or focus in results list
Thanks for the info.  Yes, now I can reproduce. 

Side test - I got to this bug originally because of bug 1432537
Flags: needinfo?(vseerror)
Depends on: 1468940
You need to log in before you can comment on or make changes to this bug.