Last Comment Bug 558044 - (bmo-upgrade-3.6) Upgrade b.m.o to 3.6
(bmo-upgrade-3.6)
: Upgrade b.m.o to 3.6
Status: RESOLVED FIXED
:
Product: bugzilla.mozilla.org
Classification: Other
Component: General (show other bugs)
: other
: All All
: P1 enhancement with 1 vote (vote)
: ---
Assigned To: Dave Miller [:justdave] (justdave@bugzilla.org)
:
Mentors:
https://bugzilla-stage-tip.mozilla.org/
Depends on: 567981 576685 577376 577728
Blocks: 223988 452933 484247 528849 567324 570786 574173 577604
  Show dependency treegraph
 
Reported: 2010-04-08 05:42 PDT by Frédéric Buclin
Modified: 2011-06-26 22:59 PDT (History)
30 users (show)
See Also:
Due Date:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Frédéric Buclin 2010-04-08 05:42:48 PDT
We are mostly ready to release Bugzilla 3.6 (planned release date is next Tuesday, see bug 554523), so we could upgrade b.m.o to this stable release.
Comment 1 Dave Miller [:justdave] (justdave@bugzilla.org) 2010-04-08 05:56:59 PDT
http://groups.google.com/group/mozilla.dev.apps.bugzilla/browse_thread/thread/358ed7399bf0a1f3#
Comment 2 Reed Loden [:reed] (use needinfo?) 2010-04-08 06:01:33 PDT
(In reply to comment #1)
> http://groups.google.com/group/mozilla.dev.apps.bugzilla/browse_thread/thread/358ed7399bf0a1f3#

Preliminary look at how that would go seems promising... A number of the conflicts are password lockout related, so it might be a good idea to back-out that entire patch from 3.4 before building the bundle, as that code is now in 3.6 proper.
Comment 3 Dave Miller [:justdave] (justdave@bugzilla.org) 2010-04-12 23:49:42 PDT
I backed out the two password-lockout related patches and tried this, and still got 33 files with conflicts.  A few of them are braindead things like both we and upstream added code in the same spot, and the merge algorithm didn't know which order to put them in.  Some of them are more involved.
Comment 4 Gervase Markham [:gerv] 2010-05-20 06:35:23 PDT
I have the first cut of a merge done. I'm testing now.

Gerv
Comment 5 Dave Miller [:justdave] (justdave@bugzilla.org) 2010-06-30 10:34:24 PDT
A status update for this, since this never got posted here yet...

Bugzilla 3.6 got staged a few weeks ago, but we had a "time spent" issue with the upgrade (it took over 6 hours to run the database upgrade, which we don't like).  We have some tweaks to the mysql configuration to try to make the upgrade go faster, but I haven't had time to try again yet.  As soon as that revised test run completes, we'll schedule a downtime for it (and if it winds up being an 8 hour downtime at that point, so be it, but I'd like to avoid being down that long if we can).

I've had other high priority projects to complete preventing me from spending time on it, but those are due for the end of Q2 (which is almost over) so I should be free to play with this again by next week, and we could be upgrading as soon as Thursday July 8.
Comment 6 Reed Loden [:reed] (use needinfo?) 2010-07-10 03:13:15 PDT
This is done. Yay! File any new issues against the bmo-regressions bug.
Comment 7 Alice0775 White 2010-07-10 11:12:37 PDT
Where is My Votes of saved search?
Comment 8 Frédéric Buclin 2010-07-10 11:15:39 PDT
(In reply to comment #7)
> Where is My Votes of saved search?

We removed it in favor of the "Browse" link. You can still view all your votes by clicking the "vote" link in a bug of your choice.
Comment 9 Alice0775 White 2010-07-10 11:26:44 PDT
(In reply to comment #8)
> (In reply to comment #7)
> > Where is My Votes of saved search?
> 
> We removed it in favor of the "Browse" link. You can still view all your votes
> by clicking the "vote" link in a bug of your choice.
OK

In page of "Help with voting( https://bugzilla.mozilla.org/page.cgi?id=voting.html )"
>You may review your votes at any time by clicking on the "My Votes" link in the page footer.

This description should be revised.
Comment 10 Frédéric Buclin 2010-07-10 11:31:22 PDT
(In reply to comment #9)
> This description should be revised.

You are right. Could you file a bug about this?
Comment 11 Alice0775 White 2010-07-10 11:41:35 PDT
(In reply to comment #10)
> (In reply to comment #9)
> > This description should be revised.
> 
> You are right. Could you file a bug about this?

I filed Bug 577849.
Comment 12 Tony Mechelynck [:tonymec] 2010-07-10 11:43:47 PDT
(In reply to comment #7)
> Where is My Votes of saved search?

Alice, if, like me, you cannot live without it, add https://bugzilla.mozilla.org/votes.cgi to your bookmarks.

I'd report this as a "regression" bug, maybe even "dataloss", except that in view of comment #8 I'd expect it to get WONTFIX at best, maybe even INVALID.
Comment 13 Alice0775 White 2010-07-10 11:46:23 PDT
Thanks Tony. I bookmarked it.
Comment 14 David Weir (satdav) 2010-07-11 09:28:58 PDT
hey guys that is good what we still have all the old accounts in it but it would be better if we can get openid and a spam fetaure on it
Comment 15 christian 2010-07-12 11:45:26 PDT
I believe I found a bug with the new version's REST api: bug 578111.
Comment 16 Reed Loden [:reed] (use needinfo?) 2010-07-12 12:37:42 PDT
(In reply to comment #15)
> I believe I found a bug with the new version's REST api: bug 578111.

Nope, just a bug with gerv's BzAPI, which is not official or connected to Bugzilla proper at all.
Comment 17 Neville Hillyer 2010-07-13 08:14:51 PDT
I suspect this is not the place to post this but I could not find anywhere else.

Would it be possible in a future update to allow email addresses to be removed from public view?
Comment 18 Neville Hillyer 2010-07-14 14:46:31 PDT
Please ignore comment 17 and go to:

https://bugzilla.mozilla.org/show_bug.cgi?id=578787

Note You need to log in before you can comment on or make changes to this bug.