Are the two hyphens/dashes in the email signature really necessary?

VERIFIED WONTFIX

Status

MailNews Core
Composition
P3
minor
VERIFIED WONTFIX
18 years ago
10 years ago

People

(Reporter: Alex, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This annoyed me in Netscape Communicator, and as I'm using Mozilla for almost
everything now, this is annoying me now:

Say that I have an email signature, in a file called signature.txt, that looks
like this:
  Joe
  Visit my web site: http://www.blahblahblah.com/

I go into MailNews and set my email signature for that file, when I open a
composition window, I get this:

  --
  Joe
  Visit my web site: http://www.blahblahblah.com/

Are those two dashes just before the signature really necessary? I personally
don't like them, they seem unnatural, and if I wanted such a boundary or border,
I can put it in my email signature file. Right now it really annoys me that I
have to manually delete it every time I am writing an email.

I would at least appreciate a way to turn this off. Thank you.

Comment 1

18 years ago
Apparantly some mailers use the "-- " line to leave signatures out of the 
quoted text when replying.  See bug 35118 and bug 35158 (both fixed).
(Assignee)

Comment 2

18 years ago
Yes, it's a convention to allow other email client recognize the signature.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
VERIFIED WONTFIX.
Status: RESOLVED → VERIFIED

Comment 4

15 years ago
*** Bug 199291 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
*** Bug 228086 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
My users don't care about network standards or rfc's, and don't use newsgroups
and always manually remove the "-- " before the sig. I have tried to convince
them otherwise but to no avail. Therefore a hidden pref to disable the default
"-- " would be appreciated by them.

Comment 7

15 years ago
Please provide an option to turn off this feature.
Product: MailNews → Core

Comment 8

12 years ago
*** Bug 331546 has been marked as a duplicate of this bug. ***

Comment 9

12 years ago
(In reply to comment #6)
> My users don't care about network standards or rfc's, and don't use newsgroups
> and always manually remove the "-- " before the sig. I have tried to convince
> them otherwise but to no avail. Therefore a hidden pref to disable the default
> "-- " would be appreciated by them.

Indeed. I don't care if it is a standard, I always manually remove it anyway (and with the number of emails I send every day, it's quite annoying and tiresome). It needs to at least be an option, default on, but having the ability to turn it off, even if hidden.

Comment 10

12 years ago
*** Bug 337673 has been marked as a duplicate of this bug. ***

Comment 11

12 years ago
Frankly it's a load of BS that this came up 5, 6 years ago, and people STILL want it changed to a preference, if even hidden, and we STILL have not been given this option. What the heck good is open source then when **** like this goes on? I don't care if it's by design, make it by design for the option to default _on_, but for godsakes somebody give us the option to turn it off! Rediculous (and wasted donations)!
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.