Last Comment Bug 561054 - No search icon or text on global search bar
: No search icon or text on global search bar
Status: RESOLVED FIXED
: regression
Product: Thunderbird
Classification: Client Software
Component: Search (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 3.1b2
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 563647 563654 566282
Blocks: filterbar
  Show dependency treegraph
 
Reported: 2010-04-22 03:55 PDT by Mark Banner (:standard8, afk until Dec)
Modified: 2010-05-17 01:11 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
beta2+
beta2-fixed


Attachments
screenshot of Linux behaviour (12.49 KB, image/png)
2010-04-22 04:21 PDT, Andreas Nilsson (:andreasn)
no flags Details
Use gtk-find for gnomestripe (426 bytes, patch)
2010-04-27 19:16 PDT, Takanori MATSUURA
mkmelin+mozilla: review+
Details | Diff | Splinter Review

Description Mark Banner (:standard8, afk until Dec) 2010-04-22 03:55:59 PDT
When bug 545955 landed it had completely broken the mac build. We found this to be due to the inclusion of textbox.css into extraCustomizeItems.xul, which NeilAway pointed out may be a bad thing as that's designed to be included in xbl files anyway (unless he was talking about the content version).

In any case, removing it fixed the mac issues, but broke the icons and text on the global search bar on Windows and Linux (i.e. broke = not displayed). As this seemed the better of two evils, we've left the textbox.css removed from the file for now and this bug is for fixing up the search icon and text.
Comment 1 Andreas Nilsson (:andreasn) 2010-04-22 04:21:52 PDT
Created attachment 440736 [details]
screenshot of Linux behaviour
Comment 2 Andrew Sutherland [:asuth] 2010-04-22 10:04:39 PDT
Yeah, I added that to get the search icon to show up.  The autocomplete widget lacks such niceties, and I wanted to keep search.xml as simple as possible, so I added the button back in extraCustomizeItems.xml instead of in the XBL content for search.xml.  My assumption was that accordingly the styling had to come from the document since it would not be part of the anonymous sub-content, but maybe the XBL CSS will affect the children?  We also can move stuff back into search.xml...
Comment 3 Andrew Sutherland [:asuth] 2010-04-22 19:09:18 PDT
I pushed a bustage-fix for this, testing the patch on all 3 platforms first:
http://hg.mozilla.org/comm-central/rev/9759a8e7417f
Comment 4 Alfred Kayser 2010-04-25 02:45:16 PDT
Can you attach the patch also to this bug, so that other people can review it, and include the necessary changes also in their themes?
Comment 5 Takanori MATSUURA 2010-04-27 19:16:36 PDT
Created attachment 442008 [details] [diff] [review]
Use gtk-find for gnomestripe

Same as bug 525971.
Comment 6 Magnus Melin 2010-04-28 11:57:24 PDT
Comment on attachment 442008 [details] [diff] [review]
Use gtk-find for gnomestripe

Thx for the patch. r=mkmelin
(Would have been better to put the patch in a follow-up bug though)
Comment 7 Takanori MATSUURA 2010-05-03 23:25:40 PDT
(In reply to comment #6)
Thank you for reviewing and a comment.
I'll do so next time I found a bug which is a follow-up one.

Could you add "checkin-needed" to keywords?
I have no permission to check in.
Comment 8 Mark Banner (:standard8, afk until Dec) 2010-05-04 07:31:59 PDT
(In reply to comment #7)
> (In reply to comment #6)
> Thank you for reviewing and a comment.
> I'll do so next time I found a bug which is a follow-up one.
> 
> Could you add "checkin-needed" to keywords?
> I have no permission to check in.

No, we're going to need to move this to a follow-up bug. As this bug is already marked fixed for beta 2 and we've already shipped that. Otherwise we're not going to be easily able to track this getting fixed.

As you didn't know about that, I'll file a follow-up bug and transfer the patch there in a few mins.
Comment 9 Takanori MATSUURA 2010-05-04 07:35:00 PDT
OK.
I'll file new bug for comment #5 shortly.
Comment 10 Takanori MATSUURA 2010-05-04 07:45:07 PDT
(In reply to comment #9)
File as bug 563647.
Comment 11 Ginn Chen 2010-05-16 22:49:03 PDT
_updateVisibleText()?
I think this method is gone in comm-central (See Bug Bug 547224).

I got this error.


       -- Exception object --
       + message (string) 'this._updateVisibleText is not a function'
       + fileName (string) 'chrome://messenger/content/search.xml'
       + lineNumber (number) 140
       + stack (string) '()@chrome://messenger/content/search.xml:140
       '
       + name (string) 'TypeError'
       *
       -- Stack Trace --
       ()@chrome://messenger/content/search.xml:140
Comment 12 Andrew Sutherland [:asuth] 2010-05-17 00:55:23 PDT
(In reply to comment #11)
> _updateVisibleText()?
> I think this method is gone in comm-central (See Bug Bug 547224).

Yes, this is gone from mozilla-central and so affects comm-central but not comm-1.9.2.  Please file a new bug for it if it does not already exist.

Note You need to log in before you can comment on or make changes to this bug.