for MS Exchange Return Receipts are always sent and is not influenced by the settings or answer to the receipt question

RESOLVED INVALID

Status

Thunderbird
Preferences
--
major
RESOLVED INVALID
8 years ago
6 years ago

People

(Reporter: Bauke Conijn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100423 Thunderbird/3.0.4

When reading mail through imap from a microsoft exchange server 2007, the return receipt settings are completely ignored, making it impossible to not sent the receipt.

Reproducible: Always

Steps to Reproduce:
A1. Go to 'preferences>advanced>general>return receipts' and set these all to "ask me"
B1. Go to 'preferences>advanced>general>return receipts' and select "never send a return receipt"
2. Choose an account that reads emails through imap from a microsoft exchange server 2007.
3. Make sure that the receipt preferences for that account are set to "use my global return receipt preferences for this account"
4. Send a mail to that account with 'options>return receipt' enabled (you can do this from any email address)
5. Read the email when it has arrived


Actual Results:  
In case A: one might be asked if you want to send the return receipt. No matter what the answer is, it will be sent. If you are not asked, the receipt is also sent. 

In case B: the return receipt is sent anyway.

Expected Results:  
In case A: Always ask, and don't ignore the answer.
In case B: Never sent the receipt.

This bug is only triggered when using the mail server I'm using, which is a Microsoft exchange server 2007. 

With a different account (also imap, but not microsoft exchange) the return receipt settings do work.

So this might also be a bug in the exchange server, (maybe even it's settings) however I'm unable to test this.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0
(Reporter)

Comment 1

8 years ago
If in case A you answer yes, 2 different return receipts are sent. One of them clearly originates from the exchange server, the following lines are in the header:

<meta name=3D"Generator" content=3D"Microsoft Exchange Server">

and 

Disposition: automatic-action/MDN-sent-automatically; displayed
(In reply to comment #1)
> If in case A you answer yes, 2 different return receipts are sent. One of them
> clearly originates from the exchange server, the following lines are in the
> header:
> 
> <meta name=3D"Generator" content=3D"Microsoft Exchange Server">
> 
> and 
> 
> Disposition: automatic-action/MDN-sent-automatically; displayed

This means the exchange server is configured for that then.
If you access the server with outlook , do you have the same issue ?
(Reporter)

Comment 3

8 years ago
I'm not running windows, so I've tried accessing the server with Evolution. Even though I did not have a SMTP server configured, I still received the return receipt. So this is definitely an exchange server issue.

Would it be useful to add a remark to the return receipt configuration dialog stating that "Some servers send return receipts upon reading and the settings in this dialog do not affect this behavior."?
(In reply to comment #3)
 
> Would it be useful to add a remark to the return receipt configuration dialog
> stating that "Some servers send return receipts upon reading and the settings
> in this dialog do not affect this behavior."?

That's a very specific edge case. It might be worth a knowledge base article.

As the bug is not in Thunderbird closing INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Duplicate of this bug: 769461

Comment 6

6 years ago
Exchange feature according to http://technet.microsoft.com/en-us/library/cc296568%28EXCHG.80%29.aspx
OS: Linux → All
Hardware: x86 → All
Summary: Return Receipts are always sent and is not influenced by the settings or answer to the receipt question → for MS Exchange Return Receipts are always sent and is not influenced by the settings or answer to the receipt question
You need to log in before you can comment on or make changes to this bug.