Won't save in sent message - status bar "Copy failed.", dialog "There was an error copying the message to the Sent folder. Retry?" caused by Sent folder >4 GB

RESOLVED DUPLICATE of bug 387502

Status

defect
--
critical
RESOLVED DUPLICATE of bug 387502
9 years ago
8 years ago

People

(Reporter: fleslie, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; Ringo; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; InfoPath.2; .NET CLR 3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100317 Thunderbird/3.0.4

Won'ts save sent messages in sent file.

Reproducible: Always

Steps to Reproduce:
1.Send a message
2.
3.
Actual Results:  
Error box popps up that message can't be sent.

Expected Results:  
Save the message in sent file.

Save the sent message in sent file.  This is a repeat of Bug 278446.
What is the exact error message, and how exactly are you checking that the message isn't saved in the Sent folder? Does the Sent folder (Tools -> Account Settings -> Copies & Folders -> When sending messages …) exist?

What protocol are you using - IMAP, POP, or something else?

Are there any messages in Tools -> Error Console? Have you tried safe mode? (see https://support.mozillamessaging.com/en-US/kb/Safe+Mode for more information)

Finally, if this is really a repeat of bug 278446 or bug 298229, it should be resolved as a duplicate of one of them (preferably the one with NEW status, but whichever is closest).
In addition, 
a) do you have automatic compact enabled and what value is it set to? Options|advanced|network&disk|disk space|compact folders when it will save over ...
b) what happens when you click retry?
Reporter

Comment 3

9 years ago

What do you mean, "What is the exact error message"?  I gave it!  I'm a user, not a tech.  You get user responses from me.  

Your second question is so parallel universe that I won't dignify it with an answer!  

Protocol is POP.  

Why should I be checking an Error Console, like I should know about it?  

Forget Safe Mode.  If Windows is in Safe Mode, I'm probably not even able to check email!

It gives me all the indications it is a repeat.  That's why I referenced it.



(In reply to comment #1)
> What is the exact error message, and how exactly are you checking that the
> message isn't saved in the Sent folder? Does the Sent folder (Tools -> Account
> Settings -> Copies & Folders -> When sending messages …) exist?
> What protocol are you using - IMAP, POP, or something else?
> Are there any messages in Tools -> Error Console? Have you tried safe mode?
> (see https://support.mozillamessaging.com/en-US/kb/Safe+Mode for more
> information)
> Finally, if this is really a repeat of bug 278446 or bug 298229, it should be
> resolved as a duplicate of one of them (preferably the one with NEW status, but
> whichever is closest).
Reporter

Comment 4

9 years ago
a) No.  It is not set.
b) program locks up my computer.
c) program is still "indexing" folders from previous version.  Sure would have been nice to know that was going to happen.

(In reply to comment #2)
> In addition, 
> a) do you have automatic compact enabled and what value is it set to?
> Options|advanced|network&disk|disk space|compact folders when it will save over
> ...
> b) what happens when you click retry?
Frank, we understand that you are a user and appreciate bug reports, but you did not even check his links - "safe mode" is not windows safe mode. The link even says "Note: Windows users may be familiar with a Safe Mode for Windows. Thunderbird Safe Mode has no connection to Windows Safe Mode."


And "Won'ts save sent messages in sent file." is most certainly not an exact, verbatim error message, unless you are translating from a foreign language, localized version of thunderbird.  But if getting the text exactly right is a problem, a screen shot is a perfect alternative.

If you file a bug here you need to be prepared to assist by providing useful respones to useful questions. (bugzilla is not a support forum)

your comment 4 indicates the problem is not related to compact. I'll let Nathan take it from here :).  Thanks for the additional information.
Reporter

Comment 6

9 years ago
When I'm having problems with a program, I don't think to go check some link somewhere on the web, I'm trying to figure out why it won't do what it is supposed to do.  If Help does not have the answer, I shut the program down.  IN this case I have had to hard reboot the computer as this version of Thunderbird locked it up.

I am not able now to recall exactly what the message said.  I was and still am frustrated with the program It won't show me anything in the Sent file since it is still "indexing" files from the previous version.

(In reply to comment #5)
> Frank, we understand that you are a user and appreciate bug reports, but you
> did not even check his links - "safe mode" is not windows safe mode. The link
> even says "Note: Windows users may be familiar with a Safe Mode for Windows.
> Thunderbird Safe Mode has no connection to Windows Safe Mode."
> And "Won'ts save sent messages in sent file." is most certainly not an exact,
> verbatim error message, unless you are translating from a foreign language,
> localized version of thunderbird.  But if getting the text exactly right is a
> problem, a screen shot is a perfect alternative.
> If you file a bug here you need to be prepared to assist by providing useful
> respones to useful questions. (bugzilla is not a support forum)
> your comment 4 indicates the problem is not related to compact. I'll let Nathan
> take it from here :).  Thanks for the additional information.
Reporter

Comment 7

9 years ago
Now I have a screen shot of the EXACT Error message in jpg format.  How do I get it to you?
Reporter

Comment 8

9 years ago
Screen shot of Sent File Save Error Message.
Reporter

Comment 9

9 years ago
Screen shot showing the EXACT Error Message is posted above in your attachments file.
Reporter

Comment 10

9 years ago
Indexing finally finished.  No saved messages in Sent Folder.  Guess I'll just have to cc myself in order to know what I sent.
(In reply to comment #6)
> When I'm having problems with a program, I don't think to go check some link
> somewhere on the web, I'm trying to figure out why it won't do what it is
> supposed to do.

Understood, but can you please try following the instructions given at https://support.mozillamessaging.com/en-US/kb/Safe+Mode now?

Also, assuming you're in Smart Folders mode (check the top of the folder pane on the left to be sure, but it's the default in 3.x), check the Sent folder to see if it has any subfolders. If so, check if they have any messages inside.
Frank, check next please.
(0) At folder pane, change to "All Folders" view to avoid confusion.
(1) Create a root level folder named TEST under the POP3 account.
    create Archives, Drafts, Sent, Templates, under the TEST folder.
(2) At Account Settings/Copies and Folders, select above folder under TEST
    via folder selection list of "Others:" for four special folders.
(3) Restart Tb, to avoid unwanted/irrelevant problems.
(4) Copy relatively large mail to above four folders under TEST. 
(5) Check of compose a mail, save in Drafts, send it, copy to Sent after send.
(5-1) Compose a mail, attach files if required
(5-2) Save as draft
(5-3) Send Later => mail is saved in Outbox of "Local Folders"
(5-4) At context menu of Outbox, "Send Unsent Messages"
      => mail is sent, and copy of mail is saved in TEST/Sent 
Does your problem still occur with folders under TEST?
Is mail data saved as expected in expected folder(s) under TEST?

Aftter checking, change Copies&Folders setting to normal one except for "Sent" setting, please.

What is file size of Sent and Sent.msf?

Updated

9 years ago
Keywords: dataloss
Summary: Won't save in sent file → Won't save in sent message - status bar "Copy failed.", dialog "There was an error copying the message to the Sent folder. Retry?"
Reporter

Comment 13

9 years ago
Sent folder won't open.  Have to close Tb in order to stop the program from whatever it is doing.

(In reply to comment #11)
> (In reply to comment #6)
> > When I'm having problems with a program, I don't think to go check some link
> > somewhere on the web, I'm trying to figure out why it won't do what it is
> > supposed to do.
> Understood, but can you please try following the instructions given at
> https://support.mozillamessaging.com/en-US/kb/Safe+Mode now?
> Also, assuming you're in Smart Folders mode (check the top of the folder pane
> on the left to be sure, but it's the default in 3.x), check the Sent folder to
> see if it has any subfolders. If so, check if they have any messages inside.
Reporter

Comment 14

9 years ago
Sent folder won't even open.  I don't have the time until Sudnay to mess with this.

(In reply to comment #12)
> Frank, check next please.
> (0) At folder pane, change to "All Folders" view to avoid confusion.
> (1) Create a root level folder named TEST under the POP3 account.
>     create Archives, Drafts, Sent, Templates, under the TEST folder.
> (2) At Account Settings/Copies and Folders, select above folder under TEST
>     via folder selection list of "Others:" for four special folders.
> (3) Restart Tb, to avoid unwanted/irrelevant problems.
> (4) Copy relatively large mail to above four folders under TEST. 
> (5) Check of compose a mail, save in Drafts, send it, copy to Sent after send.
> (5-1) Compose a mail, attach files if required
> (5-2) Save as draft
> (5-3) Send Later => mail is saved in Outbox of "Local Folders"
> (5-4) At context menu of Outbox, "Send Unsent Messages"
>       => mail is sent, and copy of mail is saved in TEST/Sent 
> Does your problem still occur with folders under TEST?
> Is mail data saved as expected in expected folder(s) under TEST?
> Aftter checking, change Copies&Folders setting to normal one except for "Sent"
> setting, please.
> What is file size of Sent and Sent.msf?
Reporter

Comment 15

9 years ago
Two questions.

1.  Why do I need to do all that stuff?
2.  Where do I find this *.msf file?

(In reply to comment #12)
> Frank, check next please.
> (0) At folder pane, change to "All Folders" view to avoid confusion.
> (1) Create a root level folder named TEST under the POP3 account.
>     create Archives, Drafts, Sent, Templates, under the TEST folder.
> (2) At Account Settings/Copies and Folders, select above folder under TEST
>     via folder selection list of "Others:" for four special folders.
> (3) Restart Tb, to avoid unwanted/irrelevant problems.
> (4) Copy relatively large mail to above four folders under TEST. 
> (5) Check of compose a mail, save in Drafts, send it, copy to Sent after send.
> (5-1) Compose a mail, attach files if required
> (5-2) Save as draft
> (5-3) Send Later => mail is saved in Outbox of "Local Folders"
> (5-4) At context menu of Outbox, "Send Unsent Messages"
>       => mail is sent, and copy of mail is saved in TEST/Sent 
> Does your problem still occur with folders under TEST?
> Is mail data saved as expected in expected folder(s) under TEST?
> Aftter checking, change Copies&Folders setting to normal one except for "Sent"
> setting, please.
> What is file size of Sent and Sent.msf?
(In reply to comment #15)
> 1.  Why do I need to do all that stuff?

That steps is equivallent to question of "What happens if other folder is used as folder to which copy of sent mail is saved?". I didn't want answer style like your comment #3 or comment #6. I wanted answer style like your comment #4.
And, as changing of sent setting only produces confusion in some cases, I asked you to select folder which you newly created at Others: of all special folders in Copies&Folders.

> 2.  Where do I find this *.msf file?

Account Settings/Server Settings, Local Directory: shows mail directory for an account. Files/directories(xxx.sbd) for mail folder is kept under the mail directory for an account.
Reporter

Comment 17

9 years ago
I did something different.  I created a new folder called "New Sent" and went into Tools and Accounts and searched until I found where I could designate where sent messages are to be saved.  I selected the "New Sent".  And tried it.  Three times.  It has three sent messages in it.

Now to find out where on my computer for the sent messages from between April 25 and today are.

One of you asked earlier for a screen shot of the error message.  I have provided that.  And I was still getting that error message today until I did what I described above.  Now it is up to y'all to figure out why it does that.  I have an effective work around.

(In reply to comment #16)
> (In reply to comment #15)
> > 1.  Why do I need to do all that stuff?
> That steps is equivallent to question of "What happens if other folder is used
> as folder to which copy of sent mail is saved?". I didn't want answer style
> like your comment #3 or comment #6. I wanted answer style like your comment #4.
> And, as changing of sent setting only produces confusion in some cases, I asked
> you to select folder which you newly created at Others: of all special folders
> in Copies&Folders.
> > 2.  Where do I find this *.msf file?
> Account Settings/Server Settings, Local Directory: shows mail directory for an
> account. Files/directories(xxx.sbd) for mail folder is kept under the mail
> directory for an account.
Reporter

Comment 18

9 years ago
No response to my last.  So I will presume, as old soldiers only assume battle positions, that the solution that works for me did not provide you with enough to figure out why the problem occured in the first place.  Might want to check the lines of code that establish the "Sent" file and has messages saved in it.
My question of comment #12, question from an old soldier, consists of;
(A) What happens if other folder is used as folder to which copy of sent mail
    is saved?
(B) If "other than Sent" works well, it's probably somethig wrong happend
    in/on files for Sent folder or mail folder of Sent in your environment.
    And, according to your observations or answers to other questions,
    the something wrong doesn't look one which can be corrected automatically
    or internally by Thunderbird. 
    So, at first, I asked about real file size of files for Sent folder
    in your environment.
I know some bugs which can produce some phenomena involved in your problem. My question is to check the some phenomena in your problem is different from such bugs or not. 

However, you didn't answer to part (A) unless I explained reason why I asked part (A), and you still don't answer to part (B).

Should I explain details of some bugs I know to you before asking some questions? Should I state detail of reason why I asked you some questions in order to obtain your check result from you?
Do you need instructions like open MS Windows Explorer, select "C:\Document...", see property of file named Sent by right clicking of file, check value displayed at xxx field, ..., with screen shot of each step?
Or need instructions like DIR "C:\Document...\Mail\..." /S > C:\WORK\LIST.TXT followed by notepad.exe C:\WORK\LIST.TXT?
Reporter

Comment 20

9 years ago
I answered (A) when I stated I created a New Sent files that works and it is still working.

(B) 4,325,025 KB for Sent, and 4,819 Kb for Sent.msf.

(In reply to comment #19)
> My question of comment #12, question from an old soldier, consists of;
> (A) What happens if other folder is used as folder to which copy of sent mail
>     is saved?
> (B) If "other than Sent" works well, it's probably somethig wrong happend
>     in/on files for Sent folder or mail folder of Sent in your environment.
>     And, according to your observations or answers to other questions,
>     the something wrong doesn't look one which can be corrected automatically
>     or internally by Thunderbird. 
>     So, at first, I asked about real file size of files for Sent folder
>     in your environment.
> I know some bugs which can produce some phenomena involved in your problem. My
> question is to check the some phenomena in your problem is different from such
> bugs or not. 
> However, you didn't answer to part (A) unless I explained reason why I asked
> part (A), and you still don't answer to part (B).
> Should I explain details of some bugs I know to you before asking some
> questions? Should I state detail of reason why I asked you some questions in
> order to obtain your check result from you?
> Do you need instructions like open MS Windows Explorer, select
> "C:\Document...", see property of file named Sent by right clicking of file,
> check value displayed at xxx field, ..., with screen shot of each step?
> Or need instructions like DIR "C:\Document...\Mail\..." /S > C:\WORK\LIST.TXT
> followed by notepad.exe C:\WORK\LIST.TXT?
(In reply to comment #20)
> (B) 4,325,025 KB for Sent, and 4,819 Kb for Sent.msf.

It's Bug 387502. To recover data, next is required.
(1) Split Sent file to two parts.
    f-1 : data from offset=0 to 4GB-1 (4GB data)
  f-2 : Last "From -" line just before 4GB boundary to end of Sent file
    Check file size of f-1/f-2, copy f-1/f-2 to f-1X/f-2X for step (6).
(2) Resatrt Tb, wait for rebuild-index.
(3) Create Sent-1, Sent-2, ... Sent-N folders,
(4) Last mail in f-1 can be partial mail of first mail in f-2,
    Remove it if last mail in f-1 is really partial mail of first mail in f-2.
(5) Move all mails in f-1 to Sent-X folders,
    Move all mails in f-2 to Sent-X folders.
(6) "Compact" of f-1X, f-2X, check file size.
    Is file size reduced?

If "Global Search and Indexer" is active, indexing is executed for mails while you are executing your mail data recovery procedure. I recommend you to disable "Global Search and Indexer" before your try to recover mail data.

By the way, could you stop news post like quoting for readability, please. Former comments will never be lost in bugzilla.mozilla.org system.
A way to create f-1 and f-2.
  f-1 : data from offset=0 to 2GB-1 (2GB data) + 0x0D0A([CRLF])
  restart Tb, wait for rebuild-index of f-1
  show "Order Received" column, sort in ascending order
  XXX : "Order Received" column value of bottom most mail(XXX is largest)
  f-2 : data from offset=XXX to end of Sent file
  restart Tb, wait for rebuild-index of f-2

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Summary: Won't save in sent message - status bar "Copy failed.", dialog "There was an error copying the message to the Sent folder. Retry?" → Won't save in sent message - status bar "Copy failed.", dialog "There was an error copying the message to the Sent folder. Retry?" caused by Sent folder >4 GB
Duplicate of bug: tb-4gb
You need to log in before you can comment on or make changes to this bug.