[adbe 3113833] OOPP hang in mozilla::plugins::PPluginInstanceParent::CallPBrowserStreamConstructor

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
--
critical
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: marcia, Unassigned)

Tracking

(Blocks: 1 bug, {crash, hang})

Trunk
x86
Windows 7
crash, hang
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking1.9.2 needed, status1.9.2 wanted)

Details

(Whiteboard: [oopp-watchlist], crash signature, URL)

(Reporter)

Description

8 years ago
Seen while running 3.6.4 Build 4 on Windows 7, Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100513 Firefox/3.6.4. 

Here are my three crash reports, all crashes playing HD videos on youtube. The stacks are all different:

http://crash-stats.mozilla.com/report/index/bp-e7803222-c761-4b3f-8bb9-3ea9c2100514
http://crash-stats.mozilla.com/report/index/bp-8201b39f-53fc-4f25-8378-1abfb2100514
http://crash-stats.mozilla.com/report/index/bp-619c0499-48e9-4814-aaa4-2e4952100514

STR:
1. Load a HD video from youtube.com - http://www.youtube.com/watch?v=BvuvgV3w33o&feature=fvw
2. Go to full screen.
3. Try to exit out of full screen

I think in the cases where I crashed it was actually after the video finished playing. If you let the video play about 10-20 seconds you will not be able to get out of FS mode. After I failed to be able to get out of FS mode I just let the video finish playing.

I was also able to reproduce this on Windows XP using a different youtube video and got the same stack as listed in this bug summary. On Win XP the crash happened shortly after the video I can post that crash ID if it useful.
This might be a dupe of bug 563377.
blocking1.9.2: --- → ?

Comment 2

8 years ago
Likely a regression from the first patch. Lets leave this open and confirm after the follow up fix lands.
Blocks: 478976

Updated

8 years ago
Depends on: 563377

Updated

8 years ago
Blocks: 563377
No longer depends on: 563377
Marcia: can you confirm that this is the same as bug 563377 comment 61? Can you also try that try build to see if it resolves?
blocking1.9.2: ? → .4+
(Reporter)

Comment 4

8 years ago
I haven't crashed, but I cannot get out of FS mode using the tryserver build on the same Windows 7 x64 machine using either the ESC key or alt-tab. Not sure if this is perhaps an x64 issue?

Comment 5

8 years ago
Al, any help you can provide here? We have one report of this being fixed, and one report that it isn't. FWIW, I'm on a win7 64-bit quad-core system and am not having problems.

Comment 6

8 years ago
Also, FYI, the patch landed today and will be in tomorrow's (5/19) nightly.
This is the crash I was seeing occasionally on my XP VM, I think. I haven't been able to reproduce it recently. I was watching 1080 video in fullscreen and hitting escape and alt-tab. We just fixed the alt-tab problem in bug 563377. I haven't been able to repro this recently but I will try again and see if I can get a crash report.
(Reporter)

Comment 8

8 years ago
Using Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.5pre) Gecko/20100520 Namoroka/3.6.5pre I continue to get stuck in full screen mode when playing HD videos. The video I was playing was http://www.youtube.com/watch?v=egNcMQ4CnAs in 1080 mode.

Crash/Hang reports on Win 7:

http://crash-stats.mozilla.com/report/index/dee3985f-1116-4f76-97a9-cc84a2100520
http://crash-stats.mozilla.com/report/index/7946adfa-52ba-4a98-bbc7-485542100520

I performed the same steps on my Vista x64 lab machine and although I don't crash, I have great difficultly getting out of FS mode. When I finally do the browser is non responsive and the process has to be killed.
(Reporter)

Comment 9

8 years ago
Using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.5pre) Gecko/20100520 Namoroka/3.6.5pre ( .NET CLR 3.5.30729), I get the following crash playing http://www.youtube.com/watch?v=yQ5U8suTUw0 in 1080:

http://crash-stats.mozilla.com/report/index/cc50cf81-74c1-426d-a0a9-f05b52100520
http://crash-stats.mozilla.com/report/index/57b1290d-2ea1-47f6-b7ba-9a1682100520

Comment 10

8 years ago
Appears to be something new and not related to bug 563377.
No longer blocks: 563377

Updated

8 years ago
blocking1.9.2: .4+ → ?

Updated

8 years ago
blocking1.9.2: ? → .5+
status1.9.2: --- → wanted
blocking1.9.2: .5+ → .6+

Updated

8 years ago
Whiteboard: [oopp-watchlist]

Updated

8 years ago
blocking1.9.2: .6+ → needed
Per http://crash-stats.mozilla.com/topcrasher/byversion/Firefox/3.6.9 this is #7 Crash on 1.9.2 Branch.

Comment 12

7 years ago
So this is the #2 signature in 5.0b2 right now (and it's also seen in 6.0a1 nightlies).

Updated

7 years ago
Crash Signature: nsCString const... ] [@ hang | mozilla::plugins::PPluginInstanceParent::CallPBrowserStreamConstructor(mozilla::plugins::PBrowserStreamParent*, nsCString const&, unsigned int const&, unsigned int const&, mozilla::plugins::PStreamNotifyParent*, nsCSt…

Comment 13

6 years ago
It is #3 top signature in 6.0b2.
I am currently running Firefox 5.01 with this crash: 
https://crash-stats.mozilla.com/report/index/2089564a-ab9e-41f8-a2b1-141fa2110804

I am running Windows XP with this issue. 
Firefox starts out hanging then unhanging and then lets my go to my bookmarks. I then access them, which uses adobe Flash Player and so Firefox crashes and then hangs then after hanging Adobe flash crashes.

Comment 15

6 years ago
(In reply to Feer56 from comment #14)
> I am currently running Firefox 5.01 with this crash: 
> https://crash-stats.mozilla.com/report/index/2089564a-ab9e-41f8-a2b1-
> 141fa2110804
> 
> I am running Windows XP with this issue. 
> Firefox starts out hanging then unhanging and then lets my go to my
> bookmarks. I then access them, which uses adobe Flash Player and so Firefox
> crashes and then hangs then after hanging Adobe flash crashes.

@ Feer56: Can you go to "about:crashes" in the URL bar, and copy all the crash reports url here.

Since you say that it hangs immediately after you start Firefox, can you download the latest Nightly build https://nightly.mozilla.org/ and see if you can reproduce the crash.

And then post the crash report url for the nightly build here.

Comment 16

6 years ago
(In reply to Feer56 from comment #14)
> I am currently running Firefox 5.01 with this crash: 
> https://crash-stats.mozilla.com/report/index/2089564a-ab9e-41f8-a2b1-
> 141fa2110804
> 
> I am running Windows XP with this issue. 
> Firefox starts out hanging then unhanging and then lets my go to my
> bookmarks. I then access them, which uses adobe Flash Player and so Firefox
> crashes and then hangs then after hanging Adobe flash crashes.

Most of the crashes with this signature has a Plugin Report which is in the Crash report, but your crash doesn't have one...so I am curious....

Updated

6 years ago
Summary: OOPP: [@ hang | mozilla::plugins::PPluginInstanceParent::CallPBrowserStreamConstructor(mozilla::plugins::PBrowserStreamParent*, nsCString const&, unsigned int const&, unsigned int const&, mozilla::plugins::PStreamNotifyParent*, nsCString const&, nsCStrin → OOPP hang in mozilla::plugins::PPluginInstanceParent::CallPBrowserStreamConstructor

Comment 17

6 years ago
(In reply to Vic from comment #16)
> Most of the crashes with this signature has a Plugin Report which is in the
> Crash report, but your crash doesn't have one...so I am curious....

Because of throttling, we automatically only process 10% of all reports, not caring if any of them is one side of a hang. We always process the other side if you click on it from about:crashes but else we very rarely happen to get both sides on release versions. On Beta, Aurora, and Nightly we always process 100% and get both sides.
(In reply to Vic from comment #16)
> (In reply to Feer56 from comment #14)
> > I am currently running Firefox 5.01 with this crash: 
> > https://crash-stats.mozilla.com/report/index/2089564a-ab9e-41f8-a2b1-
> > 141fa2110804
> > 
> > I am running Windows XP with this issue. 
> > Firefox starts out hanging then unhanging and then lets my go to my
> > bookmarks. I then access them, which uses adobe Flash Player and so Firefox
> > crashes and then hangs then after hanging Adobe flash crashes.
> 
> Most of the crashes with this signature has a Plugin Report which is in the
> Crash report, but your crash doesn't have one...so I am curious....

I just checked again and there is another crash report submitted at the same time, https://crash-stats.mozilla.com/report/index/23e5fe61-39e9-4e77-b33a-489452110804

Currently it's running smoothly and not hanging or crashing´╝îbut the link above goes to a crash but I'm not sure if that is related to this. The main reason for me is that my computer is old and second is that I haven't used it for about 10 days so that might of caused the crashing and hanging.
Issue occurring again. Crash reports:
https://crash-stats.mozilla.com/report/index/77b8935c-4364-4e88-bdef-9817c2110925
https://crash-stats.mozilla.com/report/index/0df302ed-851b-4089-ae65-7851a2110925

Adobe flash crashes - not firefox. 
I will try the nightly build (https://nightly.mozilla.org/)
Nightly build - not adobe flash crash.

Comment 21

6 years ago
There are still crashes in 10.0a1 but maybe with different STR:
https://crash-stats.mozilla.com/report/list?product=Firefox&version=Firefox:10.0a1&signature=hang%20|%20mozilla%3A%3Aplugins%3A%3APPluginInstanceParent%3A%3ACallPBrowserStreamConstructor%28mozilla%3A%3Aplugins%3A%3APBrowserStreamParent*%2C%20nsCString%20const%26%2C%20unsigned%20int%20const%26%2C%20unsigned%20int%20const%26%2C%20mozilla%3A%3Aplugins%3A%3APStreamNotifyParent*%2C%20nsCString%20const%26%2C%20nsCString%20const...
Disregard last post,

It actually crashed again. https://crash-stats.mozilla.com/report/index/bp-cde24d56-e1a0-4326-a8f9-01d022111001

The crash could possibly bug 683967 ?

Updated

6 years ago
Duplicate of this bug: 697889

Comment 24

6 years ago
Occurs in Nightly see Bug 697889 and Comment 23.

Comment 25

6 years ago
Please update the "Crash Signature" as only Bug: 697889 is showing up in bp-974cf1fc-74cf-408a-b634-04c692111109 and this (Bug 566062) should appear in the "Related Bugs" section of that "bp-".

Updated

6 years ago
Crash Signature: nsCString const... ] [@ hang | mozilla::plugins::PPluginInstanceParent::CallPBrowserStreamConstructor(mozilla::plugins::PBrowserStreamParent*, nsCString const&, unsigned int const&, unsigned int const&, mozilla::plugins::PStreamNotifyParent*, nsCSt… → nsCString const&, bool... ] nsCString const... ] [@ mozilla::plugins::PPluginInstanceParent::CallPBrowserStreamConstructor(mozilla::plugins::PBrowserStreamParent*, nsCString const&, unsigned int const&, unsigned int const&, mozilla::plugins::PStre…

Updated

6 years ago
Keywords: topcrash

Updated

6 years ago
Severity: normal → critical

Comment 26

6 years ago
jet asked that we look into this.  we are tracking the issue internally in 3113833.
Summary: OOPP hang in mozilla::plugins::PPluginInstanceParent::CallPBrowserStreamConstructor → [adbe 3113833] OOPP hang in mozilla::plugins::PPluginInstanceParent::CallPBrowserStreamConstructor

Comment 27

6 years ago
where can i get a link to the plugin side of the crash? a link to a current FP11 player...

Comment 28

6 years ago
I can't reproduce it in 10.0.1 and Nightly on Windows 7 with the STR in comment 0.

Comment 29

6 years ago
Here is the Plugin side of the crash:

https://crash-stats.mozilla.com/report/index/e6602da5-0f00-40ad-8c2b-c4a192120215

This is the browser side of the crash:

https://crash-stats.mozilla.com/report/index/3265a2a0-f66d-47b3-87e6-3559c2120215


STR:

http://issuu.com/abbotsfordnews/docs/abbotsford-news_thur_feb9_2012

Don't press "click to read", press the Next or Previous button instead. So it should not become full screen, but just change the page.

This will cause the whole Firefox to be not responsive for a while.

Updated

6 years ago
Duplicate of this bug: 676458

Comment 31

6 years ago
(In reply to Vic from comment #29)
> STR:
> http://issuu.com/abbotsfordnews/docs/abbotsford-news_thur_feb9_2012
> Don't press "click to read", press the Next or Previous button instead. So
> it should not become full screen, but just change the page.
> This will cause the whole Firefox to be not responsive for a while.
I can't reproduce with FP 11.1.102.55 and FF 10.0.1 on my computer.
What is the plugin side crash with FP 11.1.102.55 (no debug symbols for FP 11.2.202.183)?

Comment 32

6 years ago
(In reply to Scoobidiver from comment #31)
> (In reply to Vic from comment #29)
> > STR:
> > http://issuu.com/abbotsfordnews/docs/abbotsford-news_thur_feb9_2012
> > Don't press "click to read", press the Next or Previous button instead. So
> > it should not become full screen, but just change the page.
> > This will cause the whole Firefox to be not responsive for a while.
> I can't reproduce with FP 11.1.102.55 and FF 10.0.1 on my computer.
> What is the plugin side crash with FP 11.1.102.55 (no debug symbols for FP
> 11.2.202.183)?

I updated flash to the final beta version for 11.2: http://labs.adobe.com/technologies/flashplatformruntimes/flashplayer11-2/

Here is the plugin side crash:

https://crash-stats.mozilla.com/report/index/bp-15f01d11-a3bb-45ed-a526-95c682120215

-----------

Try pressing the "Next" button here http://issuu.com/abbotsfordnews/docs/abbotsford-news_thur_feb9_2012 very quickly.

You should not be able to get to the last page by pressing Next very quickly.

Comment 33

6 years ago
Or maybe you have to press Next after the whole page has been loaded.

But here is the plugin side crash with FP 11.1.102.55 :

https://crash-stats.mozilla.com/report/index/bp-ef2ccd4f-c848-438d-99e9-c62212120215

Comment 34

6 years ago
Vic, the browser side crash of this bug is associated with 65 different plugin side crashes. So please file a new bug based on your crash ID from comment 33. Don't forget to mention your steps to reproduce.

Marcia, are you able to reproduce a crash based on your STR in comment 0?
Keywords: qawanted

Comment 35

6 years ago
(In reply to Scoobidiver from comment #34)
> Vic, the browser side crash of this bug is associated with 65 different
> plugin side crashes. So please file a new bug based on your crash ID from
> comment 33. Don't forget to mention your steps to reproduce.
> 
> Marcia, are you able to reproduce a crash based on your STR in comment 0?

That would be Bug 676458? That was marked WONTFIX!!!

Anyways the browser side with FP 11.1.102.55:

https://crash-stats.mozilla.com/report/index/9e9e09ea-0215-4600-9df4-856062120215

redirects me here to this bug.

Plugin side with FP 11.1.102.55:

https://crash-stats.mozilla.com/report/index/ef2ccd4f-c848-438d-99e9-c62212120215


-----------

Comment 36

6 years ago
(In reply to Vic from comment #35)
> That would be Bug 676458? That was marked WONTFIX!!!
bug 676458 has been marked as wontfix because it was hijacked by other issues in the Firefox plugin component.

> https://crash-stats.mozilla.com/report/index/9e9e09ea-0215-4600-9df4-856062120215
Click the Report This Crash link and explain your steps to reproduce.

Comment 37

6 years ago
(In reply to Vic from comment #35)
> (In reply to Scoobidiver from comment #34)
> > Vic, the browser side crash of this bug is associated with 65 different
> > plugin side crashes. So please file a new bug based on your crash ID from
> > comment 33. Don't forget to mention your steps to reproduce.
> > 
> > Marcia, are you able to reproduce a crash based on your STR in comment 0?
> 
> That would be Bug 676458? That was marked WONTFIX!!!
> 
> Anyways the browser side with FP 11.1.102.55:
> 
> https://crash-stats.mozilla.com/report/index/9e9e09ea-0215-4600-9df4-
> 856062120215
> 
> redirects me here to this bug.
> 
> Plugin side with FP 11.1.102.55:
> 
> https://crash-stats.mozilla.com/report/index/ef2ccd4f-c848-438d-99e9-
> c62212120215
> 
> 
> -----------

@vic thanks for the link.  i've added the stack to our internal bug.  hopefully there's enough info.

Comment 38

6 years ago
It's a low volume crasher in 11.0 and 12.0b4, but it's #3 top crasher in 13.0a2 and #19 in 14.0a1.
Version: 1.9.2 Branch → Trunk

Updated

5 years ago
Keywords: topcrash

Comment 39

5 years ago
(In reply to Marcia Knous [:marcia] from comment #0)

http://www.youtube.com/watch?v=BvuvgV3w33o&feature=fvw

Cannot reproduce using:
Win 7 Ultimate x86 SP1, 
FF v15.0, 
Flash v11.4.402.265, 
Java plugins disabled, 
Avast Free installed. 
-- Let movie play for circa 10 seconds. Exited HD movie once in displayed in Fullscreen via ESc key. FF was in Fullscreen also.

Cannot reproduce using:
Win XP Mode x86 SP3, 
FF v18.0.a1 (29th August 2012), 
Flash v11.4.402.265, 
Java plugins not installed, 
Avast Free installed. 
-- Let movie play for circa 10 seconds. Exited HD movie once in displayed in Fullscreen via ESc key. FF was in Fullscreen also.

-------------------------------------------

(In reply to Vic from comment #29)

http://issuu.com/abbotsfordnews/docs/abbotsford-news_thur_feb9_2012

Cannot reproduce using:
Win 7 Ultimate x86 SP1, 
FF v15.0, 
Flash v11.4.402.265, 
Java plugins disabled, 
Avast Free installed. 
-- Clicked on "Next" arrow, then on "Previous" arrow. 

Cannot reproduce using:
Win XP Mode x86 SP3, 
FF v18.0.a1 (29th August 2012), 
Flash v11.4.402.265, 
Java plugins not installed, 
Avast Free installed. 
-- Clicked on "Next" arrow, then on "Previous" arrow.

Comment 40

5 years ago
http://play.cultures-online.de/co/bin/index.php?id=8390117&hash=7d52d13820b86167aa5321be4bcb47bb659f50f4&timestamp=1294243073860&affiliate=163&country=DE

Windows 7 64bit vm with 32bit build Flash  11.4.402.265

bp-9c41c2b0-0726-47f4-97dc-f26f82120830
Firefox 16.0 Crash Report [@ hang | mozilla::plugins::PPluginInstanceParent::CallPBrowserStreamConstructor(mozilla::plugins::PBrowserStreamParent*, nsCString const&, unsigned int const&, unsigned int const&, mozilla::plugins::PStreamNotifyParent*, nsCString const&, nsCString const... ] 

bp-ebf49c77-c0a8-4afc-aa9f-b32502120830
Firefox 16.0 Crash Report [@ hang | WaitForMultipleObjectsEx | RealMsgWaitForMultipleObjectsEx | MsgWaitForMultipleObjects | F_1152915508___________________________________ ] 

see also bug 779830 bug 779657 bug 763896
Blocks: 532972

Comment 41

5 years ago
Hi Bob. I notice your version is Windows 7 64bit, however this bug is for Windows 7 32bit.

Comment 42

5 years ago
(In reply to nick_prowse34 from comment #41)
> Hi Bob. I notice your version is Windows 7 64bit, however this bug is for
> Windows 7 32bit.
Bob hit this crash with a 32-bit Firefox, so it's valid.

Comment 43

5 years ago
For those of you that are able to reproduce this with the current public Flash Player build (11.4.402.265), it would be very helpful to get the output of dxdiag on your machines. 

Start > Run > dxdiag  (Or Start > Type "dxdiag" for the Win7 folks)

Save the output to a file, and attach it to the bug. 

Thanks!
Not able to reproduce any hang or crash following STR from comment 0 on Latest Nightly (2013-05-09) on Windows 7 x64:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130509 Firefox/23.0
Build ID: 20130509031047

I think this should be set as Resolved WFM based on my investigations done, based on comment 39 and as long as there we're lots of changes in FF plugg-ins (flash) since FF 3.7a5.
Georg, any suggestion here?
(In reply to MarioMi (:MarioMi) from comment #45)
> Georg, any suggestion here?

Does comment 40 produce any results?

I'm not seeing any hangs containing the CallPBrowserStreamConstructor on current releases in crash-stats. 
So if we can't reproduce with comment 40 either i think we should close as WFM.
(In reply to Georg Fritzsche [:gfritzsche] from comment #46)

> Does comment 40 produce any results?
No it doesn't.
> So if we can't reproduce with comment 40 either i think we should close as
> WFM.
Sounds good for me. Thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Issue is resolved - clearing old keywords - qa-wanted clean-up
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.