Intermittent "initialization timed out" (and only that error) running ts_places_generated_max (and only that suite) on OS X (and only that OS)

RESOLVED WORKSFORME

Status

Testing
Talos
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: philor, Assigned: alice)

Tracking

({intermittent-failure})

Trunk
All
Mac OS X
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1274446263.1274448173.15388.gz
Rev3 WINNT 6.1 mozilla-central talos nochrome on 2010/05/21 05:51:03  
s: talos-r3-w7-031

Running test tgfx: 
		Started Fri, 21 May 2010 05:59:30
NOISE: __metrics	Screen width/height:1280/1024
NOISE: 	colorDepth:24
NOISE: 	Browser inner width/height: 1008/605
NOISE: 	Browser outer width/height: 1024/768__metrics
Failed tgfx: 
		Stopped Fri, 21 May 2010 06:19:31
FAIL: Busted: tgfx
FAIL: initialization timed out
Assignee: nobody → anodelman
(Reporter)

Comment 1

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1278341374.1278342880.3209.gz
Rev3 WINNT 5.1 mozilla-central talos nochrome on 2010/07/05 07:49:34  
s: talos-r3-xp-017

Running test tdhtml: 
		Started Mon, 05 Jul 2010 07:50:40
NOISE: __metrics	Screen width/height:1280/1024
NOISE: 	colorDepth:24
NOISE: 	Browser inner width/height: 1016/632
NOISE: 	Browser outer width/height: 1024/768__metrics
Failed tdhtml: 
		Stopped Mon, 05 Jul 2010 08:10:44
FAIL: Busted: tdhtml
FAIL: initialization timed out
Summary: Intermittent "initialization timed out" running tgfx → Intermittent "initialization timed out" running tgfx and tdhtml
(Reporter)

Comment 2

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281148252.1281150260.17234.gz
Rev3 WINNT 6.1 mozilla-central talos chrome on 2010/08/06 19:30:52  
s: talos-r3-w7-016

Running test tgfx: 
		Started Fri, 06 Aug 2010 19:40:07
Failed tgfx: 
		Stopped Fri, 06 Aug 2010 20:00:18
FAIL: Busted: tgfx
FAIL: initialization timed out
(Reporter)

Comment 3

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281649348.1281652868.17533.gz
Rev3 WINNT 6.1 mozilla-central talos dirty on 2010/08/12 14:42:28  
s: talos-r3-w7-025

Running test ts: 
		Started Thu, 12 Aug 2010 14:44:30
NOISE: __metrics	Screen width/height:1280/1024
NOISE: 	colorDepth:24
NOISE: 	Browser inner width/height: 1008/655
NOISE: 	Browser outer width/height: 1024/768__metrics
Failed ts: 
		Stopped Thu, 12 Aug 2010 15:04:38
FAIL: Busted: ts
FAIL: initialization timed out
Summary: Intermittent "initialization timed out" running tgfx and tdhtml → Intermittent "initialization timed out" running tgfx and tdhtml and ts

Comment 4

8 years ago
Does this count? I hope so.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281683205.1281686600.21331.gz
Rev3 WINNT 6.1 mozilla-central talos dromaeo

Running test dromaeo_jslib: 
		Started Fri, 13 Aug 2010 00:30:45
NOISE: __metrics	Screen width/height:1280/1024
NOISE: 	colorDepth:24
NOISE: 	Browser inner width/height: 1008/655
NOISE: 	Browser outer width/height: 1024/768__metrics
Failed dromaeo_jslib: 
		Stopped Fri, 13 Aug 2010 00:50:45
FAIL: Busted: dromaeo_jslib
FAIL: initialization timed out
Completed test dromaeo_jslib: 
		Stopped Fri, 13 Aug 2010 00:50:45
(Reporter)

Comment 5

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1283192604.1283196549.22324.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2010/08/30 11:23:24  
s: talos-r3-snow-031

Running test ts_cold_generated_max: 
		Started Mon, 30 Aug 2010 11:30:37
NOISE: __metrics	Screen width/height:1280/1024
NOISE: 	colorDepth:24
NOISE: 	Browser inner width/height: 1024/665
NOISE: __metrics
sh: line 1:   586 Terminated              ../Minefield.app/Contents/MacOS/firefox-bin -foreground -profile /var/folders/H5/H5TD8hgwEqKq9hgKlayjWU+++TM/-Tmp-/tmpveo4KB/profile getInfo.html > browser_output.txt
Failed ts_cold_generated_max: 
		Stopped Mon, 30 Aug 2010 11:50:48
FAIL: Busted: ts_cold_generated_max
FAIL: initialization timed out
(Assignee)

Comment 21

7 years ago
The last 5 timeouts listed are all from places_generated_max - which isn't that surprising and will be easier to fix.
(Assignee)

Comment 22

7 years ago
Furthered narrowed down to only being on leopard/snow leopard machines.
(Assignee)

Comment 23

7 years ago
From testing on staging got 100% cpu usage and unresponsive on snow leopard during first shut down of the browser post-installation of max dirty profile places.sqlite.

Adding  browser.bookmarks.max_backups = 0 drastically reduced cpu usage and allowed the browser to close in a timely manner.

Discussing with places team how to go forward with this bug.
(Reporter)

Comment 25

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1288961852.1288963874.5666.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2010/11/05 05:57:32 
s: talos-r3-snow-044
FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Assignee)

Comment 26

7 years ago
Created attachment 488506 [details] [diff] [review]
[checked in]add pref to talos (browser.bookmarks.max_backups : 0)
Attachment #488506 - Flags: review?(mak77)
Comment on attachment 488506 [details] [diff] [review]
[checked in]add pref to talos (browser.bookmarks.max_backups : 0)

approved based on the discussion. Please file a bug in toolkit/places depending on this one, to fix the underlying issue.
Attachment #488506 - Flags: review?(mak77) → review+
(Assignee)

Comment 29

7 years ago
Filed bug 610825 to track.
(Assignee)

Comment 30

7 years ago
Comment on attachment 488506 [details] [diff] [review]
[checked in]add pref to talos (browser.bookmarks.max_backups : 0)

changeset:   206:c85dd2064859
Attachment #488506 - Attachment description: add pref to talos (browser.bookmarks.max_backups : 0) → [checked in]add pref to talos (browser.bookmarks.max_backups : 0)
(Assignee)

Updated

7 years ago
Attachment #488506 - Flags: checked-in+
(Assignee)

Updated

7 years ago
Flags: needs-treeclosure?
(Assignee)

Comment 33

7 years ago
Sorry, the most current version of talos.zip is found in bug 610841,
5c7b44ac3599.  That should be landed instead of the request in comment #31.
(Assignee)

Updated

7 years ago
Duplicate of this bug: 611275

Comment 36

7 years ago
Adding bug 608248 as dependency which will land the talos fix needed.

You will probably be able to close this bug if we manage to land this in the morning.
Depends on: 608248

Updated

7 years ago
Flags: needs-treeclosure?
Whiteboard: [orange]
(Assignee)

Comment 42

7 years ago
Looks like my fix has reduced the occurrences of this bug, but we are still getting stuck on occasion. 

I'll take another look and see what else can be done.
(Reporter)

Comment 43

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1290551909.1290553407.21372.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos svg on 2010/11/23 14:38:29 
s: talos-r3-leopard-050
FAIL: Busted: tsvg
FAIL: initialization timed out
(Reporter)

Comment 44

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1290551550.1290553664.22369.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2010/11/23 14:32:30 
s: talos-r3-snow-054
FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 46

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1291409371.1291411551.10306.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey talos dirty on 2010/12/03 12:49:31 
s: talos-r3-snow-049
FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 47

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1291669756.1291672099.20989.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2010/12/06 13:09:16 
FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 48

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1292785220.1292787265.11652.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2010/12/19 11:00:20 
FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1293001012.1293003069.27189.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2010/12/21 22:56:52

talos-r3-snow-013: 
		Started Tue, 21 Dec 2010 22:59:46
Running test ts_places_generated_max: 
		Started Tue, 21 Dec 2010 22:59:46
NOISE: __metrics	Screen width/height:1280/1024
NOISE: 	colorDepth:24
NOISE: 	Browser inner width/height: 1024/682
NOISE: __metrics
sh: line 1:   370 Terminated              ../Minefield.app/Contents/MacOS/firefox-bin -foreground -profile /var/folders/H5/H5TD8hgwEqKq9hgKlayjWU+++TM/-Tmp-/tmp3ToZ6R/profile getInfo.html > browser_output.txt
Failed ts_places_generated_max: 
		Stopped Tue, 21 Dec 2010 23:19:56
FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
Completed test ts_places_generated_max: 
		Stopped Tue, 21 Dec 2010 23:19:56
Running test ts_places_generated_min: 
		Started Tue, 21 Dec 2010 23:19:56
	Screen width/height:1280/1024
	colorDepth:24
	Browser inner width/height: 1024/682
(Reporter)

Comment 50

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Places/1292946317.1292948393.10034.gz
Rev3 MacOSX Snow Leopard 10.6.2 places talos dirty on 2010/12/21 07:45:17 
s: talos-r3-snow-029

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 51

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1293720497.1293722523.24898.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey talos dirty on 2010/12/30 06:48:17 
s: talos-r3-snow-034

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 52

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1294002328.1294004362.21835.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey talos dirty on 2011/01/02 13:05:28
s: talos-r3-snow-026

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 53

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1294066133.1294068327.4659.gz
Rev3 WINNT 5.1 tracemonkey talos dirty on 2011/01/03 06:48:53 
s: talos-r3-xp-033

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 54

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1294130550.1294132628.11753.gz
Rev3 WINNT 5.1 mozilla-central talos dirty on 2011/01/04 00:42:30 
s: talos-r3-xp-014

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 55

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1294294527.1294296574.17183.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2011/01/05 22:15:27 
talos-r3-snow-050

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 56

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1294335991.1294338112.838.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2011/01/06 09:46:31 
s: talos-r3-snow-032

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Assignee)

Comment 57

7 years ago
Updating summary to reflect that these are all ts_generated_max timeouts.
Summary: Intermittent "initialization timed out" running tgfx and tdhtml and ts → Intermittent "initialization timed out" running ts_generated_max
(Reporter)

Comment 58

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1294346940.1294349022.17099.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2011/01/06 12:49:00 
s: talos-r3-snow-045

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 59

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1294379016.1294381083.30500.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2011/01/06 21:43:36 
s: talos-r3-snow-035

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 60

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1294384739.1294386756.23204.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2011/01/06 23:18:59 
s: talos-r3-snow-026

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 61

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1294409517.1294411564.30118.gz
Rev3 WINNT 5.1 mozilla-central talos dirty on 2011/01/07 06:11:57 
s: talos-r3-xp-053

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 62

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1294432858.1294434938.16333.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey talos dirty on 2011/01/07 12:40:58 
s: talos-r3-snow-027

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 63

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1294433606.1294435621.19955.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey talos dirty on 2011/01/07 12:53:26 
s: talos-r3-snow-028

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 64

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1294440953.1294443004.24089.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2011/01/07 14:55:53 
s: talos-r3-snow-034

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 65

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1294448924.1294450985.30129.gz
Rev3 WINNT 5.1 tracemonkey talos dirty on 2011/01/07 17:08:44 
s: talos-r3-xp-042

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 66

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1294565964.1294568005.3870.gz
Rev3 WINNT 5.1 mozilla-central talos dirty on 2011/01/09 01:39:24 
s: talos-r3-xp-005

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 67

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1294584647.1294586662.22631.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey talos dirty on 2011/01/09 06:50:47 
s: talos-r3-snow-042

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 68

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1294693473.1294695543.11754.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey talos dirty on 2011/01/10 13:04:33 
s: talos-r3-snow-042

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 69

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1294701886.1294703958.24951.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey talos dirty on 2011/01/10 15:24:46 
s: talos-r3-snow-035

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 70

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1294707266.1294709373.19432.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey talos dirty on 2011/01/10 16:54:26
s: talos-r3-snow-026

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 71

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1294724629.1294726663.2914.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey talos dirty on 2011/01/10 21:43:49 
s: talos-r3-snow-045

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 72

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1294727062.1294729147.15202.gz
Rev3 WINNT 5.1 tracemonkey talos dirty on 2011/01/10 22:24:22 
s: talos-r3-xp-024

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 73

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295547912.1295549946.5282.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2011/01/20 10:25:12 
s: talos-r3-leopard-050

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 74

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295619357.1295621364.8079.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2011/01/21 06:15:57 
s: talos-r3-leopard-052

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 75

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295664536.1295666551.21762.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2011/01/21 18:48:56 
s: talos-r3-leopard-015

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 76

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1295910951.1295913000.29091.gz
Rev3 MacOSX Leopard 10.5.8 tracemonkey talos dirty on 2011/01/24 15:15:51 
s: talos-r3-leopard-019

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295912144.1295914206.3278.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty

TinderboxPrint:FAIL: Busted: ts_places_generated_max
TinderboxPrint:FAIL: initialization timed out
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295941836.1295943480.30479.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos chrome on 2011/01/24 23:50:36
s: talos-r3-snow-040

TinderboxPrint:FAIL: Busted: ts
TinderboxPrint:FAIL: initialization timed out
(apologies if Comment 78 isn't this bug -- it's not ts_places_generated_max, but I'm assuming it's related since it looks similar, and it also matches comment 3)
(Reporter)

Comment 80

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1295949595.1295951579.4679.gz
Rev3 MacOSX Leopard 10.5.8 tracemonkey talos dirty on 2011/01/25 01:59:55 
s: talos-r3-leopard-012

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 81

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1295977967.1295979976.32725.gz
Rev3 MacOSX Leopard 10.5.8 tracemonkey talos dirty on 2011/01/25 09:52:47 
s: talos-r3-leopard-008

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 82

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1296079933.1296081992.6649.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey talos dirty on 2011/01/26 14:12:13 
s: talos-r3-snow-012

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 83

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1296102781.1296105114.26548.gz
Rev3 MacOSX Leopard 10.5.8 tracemonkey talos dirty on 2011/01/26 20:33:01 
s: talos-r3-leopard-017

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 84

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1296146389.1296148365.20919.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2011/01/27 08:39:49 
s: talos-r3-leopard-048

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 85

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1296508005.1296509989.24135.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2011/01/31 13:06:45 
s: talos-r3-leopard-049

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 86

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1296613548.1296615877.26812.gz
Rev3 MacOSX Leopard 10.5.8 tracemonkey talos dirty on 2011/02/01 18:25:48 
s: talos-r3-leopard-005

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 87

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297009701.1297011675.3941.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2011/02/06 08:28:21 
s: talos-r3-leopard-018

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 88

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297089635.1297091650.18862.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2011/02/07 06:40:35 
s: talos-r3-snow-044

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 89

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297141722.1297143753.14000.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2011/02/07 21:08:42 
s: talos-r3-snow-025

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 90

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297172707.1297174702.26048.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2011/02/08 05:45:07 
s: talos-r3-leopard-051

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 91

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297152741.1297154745.28724.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2011/02/08 00:12:21 
s: talos-r3-leopard-022

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out

Comment 92

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297189499.1297191471.1950.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2011/02/08 10:24:59
s: talos-r3-leopard-022

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 93

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297194701.1297196794.25485.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2011/02/08 11:51:41 
s: talos-r3-leopard-022

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 94

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297298655.1297300735.20408.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2011/02/09 16:44:15 
s: talos-r3-snow-053

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297365204.1297367197.23599.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2011/02/10 11:13:24

Running test ts_places_generated_max: 
		Started Thu, 10 Feb 2011 11:15:14
NOISE: __metrics	Screen width/height:1600/1200
NOISE: 	colorDepth:24
NOISE: 	Browser inner width/height: 1024/681
NOISE: __metrics
sh: line 1:   387 Terminated              ../Minefield.app/Contents/MacOS/firefox-bin -foreground -profile /var/folders/H5/H5TD8hgwEqKq9hgKlayjWU+++TM/-Tmp-/tmp9Tk5W7/profile getInfo.html > browser_output.txt
Failed ts_places_generated_max: 
		Stopped Thu, 10 Feb 2011 11:35:23
FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
Completed test ts_places_generated_max: 
		Stopped Thu, 10 Feb 2011 11:35:23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297405648.1297407830.5817.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2011/02/10 22:27:28

Running test ts_places_generated_max: 
		Started Thu, 10 Feb 2011 22:32:14
NOISE: __metrics	Screen width/height:1600/1200
NOISE: 	colorDepth:24
NOISE: 	Browser inner width/height: 1024/681
NOISE: __metrics
sh: line 1:   339 Terminated              ../Minefield.app/Contents/MacOS/firefox-bin -foreground -profile /var/folders/H5/H5TD8hgwEqKq9hgKlayjWU+++TM/-Tmp-/tmpsAWwd9/profile getInfo.html > browser_output.txt
Failed ts_places_generated_max: 
		Stopped Thu, 10 Feb 2011 22:52:25
FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
Completed test ts_places_generated_max: 
		Stopped Thu, 10 Feb 2011 22:52:25
(Reporter)

Comment 97

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297653920.1297655923.25337.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2011/02/13 19:25:20 
s: talos-r3-snow-025

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 98

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297731874.1297733896.5730.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2011/02/14 17:04:34 
s: talos-r3-snow-049

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 99

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297882973.1297884961.19099.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2011/02/16 11:02:53 
s: talos-r3-leopard-004

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 100

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1297955399.1297957413.27612.gz
Rev3 MacOSX Leopard 10.5.8 tracemonkey talos dirty on 2011/02/17 07:09:59 
s: talos-r3-leopard-034

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
afaict,
* the fixes so far are in updated talos.zip (alice on leave, so reassigning and adding bob/clint) 
* dep bug#610825 which needs work from places developers.

There is nothing for RelEng to do here, so moving to Testing:General. Obviously, if I missed something here let me know.
Component: Release Engineering → General
Flags: checked-in+
Product: mozilla.org → Testing
QA Contact: release → general
Version: other → unspecified
(Reporter)

Comment 102

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1298023144.1298025132.14822.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2011/02/18 01:59:04 
s: talos-r3-leopard-004

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1298029077.1298031197.10907.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2011/02/18 03:37:57 
s: talos-r3-snow-034

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 104

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1298581673.1298583843.5826.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2011/02/24 13:07:53 
s: talos-r3-leopard-016

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 105

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1298944253.1298946372.11091.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central talos dirty on 2011/02/28 17:50:53 
s: talos-r3-snow-044

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Reporter)

Comment 106

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1298990677.1298992688.28054.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2011/03/01 06:44:37 
s: talos-r3-leopard-039

FAIL: Busted: ts_places_generated_max
FAIL: initialization timed out
(Assignee)

Comment 120

7 years ago
Going to make another attempt at reproducing this and collecting trace information.
(Reporter)

Updated

7 years ago
Component: General → Talos
QA Contact: general → talos
Summary: Intermittent "initialization timed out" running ts_generated_max → Intermittent "initialization timed out" running ts_places_generated_max on OS X
(Assignee)

Comment 135

7 years ago
Created attachment 524097 [details] [diff] [review]
potential fix for intermittent orange (take 1)

I was unable to reproduce the frozen browser over 400 or so runs on leopard.  On closer examination of the logs I'm suspecting that the browser isn't frozen, but that subprocess.poll is failing to report the closed browser - possibly due to some interaction with another poll/wait.  This patch removes the dependency on poll and allows us to move on with testing.  If the browser really is frozen/open it will be caught before the test run can start when we check for open browsers.
Attachment #524097 - Flags: review?(jmaher)
(Assignee)

Updated

7 years ago
Attachment #524097 - Flags: review?(jmaher)
(Assignee)

Comment 136

7 years ago
Created attachment 524108 [details] [diff] [review]
potential fix for intermittent orange (take 2)

This attempt is pretty similar to the original code, except that it allows for a secondary check to ensure that the browser is closed.  If the browser remains open it will fall through to ttest.py initializeProfile(self, profile_dir, browser_config), which will do a check for the existence of a firefox process.
Attachment #524097 - Attachment is obsolete: true
Attachment #524108 - Flags: review?(jmaher)
Comment on attachment 524108 [details] [diff] [review]
potential fix for intermittent orange (take 2)

>diff -r bd4f59ed70a0 ffsetup.py
>--- a/ffsetup.py	Wed Mar 30 12:47:10 2011 -0400
>+++ b/ffsetup.py	Tue Apr 05 16:48:16 2011 -0700

this is only an issue in ffsetup.py, not bcontroller as well?


>+        if (total_time >= 1200) and (res == 0):
>             raise talosError("initialization timed out")
>+        if (res == 0 ):
>+            raise talosError("initalization has no output from browser")

is it possible that we have res == 0 and successfully initialized the browser?  We terminate the while loop on process.poll(), but no guarantee that we have matched the REGEX where we would set res = 1.


>+
>+        time.sleep(browser_wait)
>+        #clean up the bcontroller process
>+        timer = 0
>+        while ((process.poll() is None) and timer < browser_wait):
>+            time.sleep(1)
>+            timer+=1
> 

I don't understand why we poll again?  My understanding is we get to this part of the function after the browser has closed or we time out.

r- as I have too many questions.
Attachment #524108 - Flags: review?(jmaher) → review-
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1302287394.1302289524.29293.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2011/04/08 11:29:54
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1302673753.1302675996.32035.gz

This one actually shows "browser frozen" rather than "initialization timed out", but seems likely to be the same issue, just happened to get a little further on this run.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1302797992.1302800007.2539.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central talos dirty on 2011/04/14 09:19:52
{
# FAIL: Busted: ts_places_generated_max
# FAIL: initialization timed out
}
Version: unspecified → Trunk
(Reporter)

Updated

7 years ago
Summary: Intermittent "initialization timed out" running ts_places_generated_max on OS X → Intermittent "initialization timed out" (and only that error) running ts_places_generated_max (and only that suite) on OS X (and only that OS)
we still run this test, but haven't seen this occur for almost a year, wfm.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Keywords: intermittent-failure
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.