Last Comment Bug 608248 - update talos.zip from http://people.mozilla.org/~anodelman/taloszips/5c7b44ac3599/talos.zip
: update talos.zip from http://people.mozilla.org/~anodelman/taloszips/5c7b44ac...
Status: RESOLVED FIXED
[talos][buildduty]
:
Product: Release Engineering
Classification: Other
Component: Other (show other bugs)
: other
: x86 Linux
: P3 normal (vote)
: ---
Assigned To: Armen Zambrano [:armenzg] (EDT/UTC-4)
:
Mentors:
: 610841 (view as bug list)
Depends on:
Blocks: 567401 596255 605039 608569
  Show dependency treegraph
 
Reported: 2010-10-29 06:21 PDT by Joel Maher ( :jmaher)
Modified: 2013-08-12 21:54 PDT (History)
4 users (show)
armenzg: needs‑treeclosure+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Joel Maher ( :jmaher) 2010-10-29 06:21:13 PDT
we have landed some patches to clean up talos a bit more and during the next talos downtime we need to update talos.zip.

You can get talos.zip from:
http://people.mozilla.org/~jmaher/talos.zip

The two bugs which were fixed depend on this bug.
Comment 1 John Ford [:jhford] CET/CEST Berlin Time 2010-10-29 08:31:00 PDT
I am going to assume this requires a treeclosure.  This is going to happen next week at the earliest.
Comment 2 Joel Maher ( :jmaher) 2010-10-29 08:38:00 PDT
yeah, a tree closure is usually needed for talos updates.  Next week works fine.
Comment 3 Armen Zambrano [:armenzg] (EDT/UTC-4) 2010-11-11 05:58:50 PST
Which zip shall I land?
This:
http://people.mozilla.org/~anodelman/taloszips/5c7b44ac3599/talos.zip
or this:
http://people.mozilla.org/~jmaher/talos.zip

I would deploy it tomorrow morning on a tree-closure only if I get this answered on time.
Comment 4 Joel Maher ( :jmaher) 2010-11-11 06:14:36 PST
I would suspect the anodelman one since it probably includes my changes as well.  I will let Alice comment on what her zip contains...regardless we can easily create a .zip file that has all pending talos changes.

This wouldn't be a problem if a talos update include a fresh pull from hg to create the .zip.  That might be something to consider doing in the future.
Comment 5 Joel Maher ( :jmaher) 2010-11-11 10:11:23 PST
please use the one that alice has:
http://people.mozilla.org/~anodelman/taloszips/5c7b44ac3599/talos.zip
Comment 6 alice nodelman [:alice] [:anode] 2010-11-11 10:22:27 PST
5c7b44ac3599 is the most current pull and should be used.
Comment 7 Armen Zambrano [:armenzg] (EDT/UTC-4) 2010-11-11 11:34:27 PST
*** Bug 610841 has been marked as a duplicate of this bug. ***
Comment 8 Armen Zambrano [:armenzg] (EDT/UTC-4) 2010-11-12 06:48:02 PST
Deployed:
ae90ded66004d69ba2d27b16dcf9adf5  /home/armenzg/talos.beforeBug610841.zip
bd57382b2f9e260529ac84f47d26d819  /home/armenzg/talos.zip

 5973983 Nov 12 06:33 /home/armenzg/talos.beforeBug610841.zip
16126922 Nov  9 16:23 /home/armenzg/talos.zip

Is it known the increased size?
Comment 9 Joel Maher ( :jmaher) 2010-11-12 06:54:14 PST
hmm, the talos.zip on my share is 5972769 in size, I wonder if the .zip file alice has has a tp4.zip or some additional .zip file included in it.  I looked at the patches that have landed and I don't see any new files, just small tweaks to the same files.
Comment 10 Armen Zambrano [:armenzg] (EDT/UTC-4) 2010-11-12 07:06:14 PST
Triggered a new set of talos jobs for mozilla-central/f7e0aeb5462b just for reference.
Comment 11 Joel Maher ( :jmaher) 2010-11-12 07:22:00 PST
appears to be .hg files:

joel@joel-laptop:~$ diff -r joel alice
Only in alice/talos: .hg
Only in alice/talos: .hgtags
diff -r joel/talos/run_tests.py alice/talos/run_tests.py
241d240
<         vals = [[x, 'NULL'] for x in cd[count_type]]
243c242,245
<         utils.stamped_msg("Generating results file: " + counterName, "Started")
---
>         if cd[count_type] == []: #failed to collect any data for this counter
>           utils.stamped_msg("No results collected for: " + counterName, "Error")
>           continue
>         vals = [[x, 'NULL'] for x in cd[count_type]]
diff -r joel/talos/sample.config alice/talos/sample.config
35a36
>   browser.bookmarks.max_backups : 0 
Binary files joel/talos.zip and alice/talos.zip differ
joel@joel-laptop:~$
Comment 12 Armen Zambrano [:armenzg] (EDT/UTC-4) 2010-11-12 08:06:47 PST
joel and I agreed that the bundle might be bigger but it has no effect on talos.
I added notes on https://wiki.mozilla.org/Auto-tools/staging#Talos_Changes
to help us avoid this problem again.

Note You need to log in before you can comment on or make changes to this bug.