Make entire urlbar edit area touchable

VERIFIED FIXED

Status

Fennec Graveyard
General
VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

8 years ago
Created attachment 446939 [details] [diff] [review]
patch

Only a small area of the urlbar edit area responds to clicks/taps, and the boundaries of this area are invisible to users (see screenshot).

This patch makes the entire white edit box touchable.

(Note: This patch expects the showToolbar behavior added by bug 567044, which is currently on mobile-browser but not on mobile-1.1.)
Attachment #446939 - Flags: review?(mark.finkle)
(Assignee)

Comment 1

8 years ago
Created attachment 446940 [details]
Screenshot: touchable area (shaded)
(Assignee)

Updated

8 years ago
Attachment #446940 - Attachment description: touchable area (shaded) → Screenshot: touchable area (shaded)
Bug 564075 caused this regression, I think, with:
http://mxr.mozilla.org/mobile-browser/source/chrome/content/browser-ui.js#767

the "&& gFocusManager.focusedElement == this._edit.inputField" part

Bug 557619 has also affected how we handle tapping in the urlbar area.
Comment on attachment 446939 [details] [diff] [review]
patch

I'd rather not introduce a new way (and code path) of opening the awesomebar. Let's get the previous code working again.
Attachment #446939 - Flags: review?(mark.finkle) → review-
(Assignee)

Comment 4

8 years ago
Created attachment 447012 [details] [diff] [review]
patch v2

Updated based on comment 2.  This fixes the "onmouseup" problem noted in bug 564075 by listening for click instead of mouseup, so the action won't be triggered by a drag that didn't start in the edit area.
Attachment #446939 - Attachment is obsolete: true
Attachment #447012 - Flags: review?(mark.finkle)
Comment on attachment 447012 [details] [diff] [review]
patch v2

>       // URL textbox events
>-      case "mouseup":
>-        if (aEvent.detail < 2 && aEvent.button == 0 && gFocusManager.focusedElement == this._edit.inputField) {
>+      case "click":
>+        if (aEvent.detail < 2 && aEvent.button == 0) {
>           this.doCommand("cmd_openLocation");
>         }

This patch works well on mobile-trunk (mozilla-central) but still fails on mobile-1.1 (mozilla-192). Fails ==  regresses bug 557619.

We can drop the aEvent.detail and aEvent.button checks too. They were only used to make sure a "click" had happened.

I tested without the checks, and everything worked fine. I'll remove them for check in.
Attachment #447012 - Flags: review?(mark.finkle) → review+
pushed to m-b:
http://hg.mozilla.org/mobile-browser/rev/3988af326c73
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
This bug (not all the url bar is touchable) _does_ exist in m-1.1 too, but we would need a different patch to fix it, if we deem it blocking Fennec 1.1

We might be able to use the initial patch in this bug (or similar) if we need a quick fix.
(Assignee)

Updated

8 years ago
Duplicate of this bug: 561863
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110922
Firefox/9.0a1 Fennec/9.0a1
Device: Samsung Galaxy S
OS: Android 2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.