Closed Bug 572695 Opened 9 years ago Closed 9 years ago

Remove "Report a Broken Website" from Firefox

Categories

(Firefox :: General, defect)

3.5 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 4.0b5
Tracking Status
blocking2.0 --- betaN+
blocking1.9.2 --- -
status1.9.2 --- wanted
blocking1.9.1 --- -
status1.9.1 --- wanted

People

(Reporter: aakashd, Assigned: Margaret)

References

Details

Attachments

(1 file, 3 obsolete files)

We need code removal of the Reporter code located here:

http://mxr.mozilla.org/mozilla-central/source/extensions/reporter/

before we ship Fx 4 Beta 1....nominating!
Do we have a bug about replacing it with something?

For Firefox 4 betas we'll have the Feedback Add-On, but afterwards do we not want a general "Give us feedback..." button?
blocking1.9.1: ? → -
blocking1.9.2: ? → -
blocking2.0: ? → final+
I doubt it. SUMO is the right outlet for feedback on final updates of Firefox as the expectations on what we can do with feedback collected changes. 

I believe it goes from fixing issues before the browser is released to offering-ideas(I need to talk to Tenser about this)/explaining-new-features/top-issues after the browser is released.
Oh, wow, I couldn't disagree more with that comment, but that's a discussion for another time I suppose.
Interesting; yeah, we'll need to talk about this.
After some thinking and re-reading it over, I now disagree with my own comments :). There's more to this, but yes, let's chat.
So, I think we want to:

 - unhook the current Reporter (which isn't monitored, and is overly complex)
 - add a new menuItem that brings people to the Feedback website and allows them to report a website that is broken in Firefox

Agree?
blocking2.0: final+ → betaN+
Yep.

For the second point: The link should be http://input.mozilla.com/sad for the Betas until we get closer to Fx Proper. 

My plan, as it stands right now, will be to change the link to another URL (as we get closer to a release) on Input which is specifically targeted for information gathering from users on the released version when that new feature is ready. You're going to have sign off on the idea and mockups once it's ready to be reviewed.
Assignee: nobody → margaret.leibovic
The patch replaces the "Report a Broken Web Site..." menu option with a "Submit Feedback..." The new option opens http://input.mozilla.com/sad, as suggested in comment 7, but we need to change that url when a final feedback website is ready.
Attachment #466814 - Flags: review?(dolske)
Hi Margaret, welcome aboard :)

(In reply to comment #8)
> The patch replaces the "Report a Broken Web Site..." menu option with a "Submit
> Feedback..." The new option opens http://input.mozilla.com/sad, as suggested in
> comment 7, but we need to change that url when a final feedback website is
> ready.

Agreed -- the webapp will not currently accept feedback from stable versions of Firefox. But as long as we're still in beta, it'll work.
I filed bug 588209 to determine the final URL and I assigned it to Aakash. Hopefully that will resolve that issue :)
Comment on attachment 466814 [details] [diff] [review]
add "submit feedback..." menu option

What are the plans for the webservice side of things? We should probably actually remove /extensions/reporter at some point, but I guess SeaMonkey is still using it.

The accesskey added here ("F") conflicts with the existing "F" accesskey for Report A Web Forgery... "S" appears to be unused, though.

r+ with that change.
Attachment #466814 - Flags: review?(dolske) → review+
> What are the plans for the webservice side of things? We should probably
> actually remove /extensions/reporter at some point, but I guess SeaMonkey is
> still using it.

The plans are listed in the dependency bug for the one that Margaret filed in comment #10. Thanks!
Attached patch patch-final (obsolete) — Splinter Review
Fixed accesskey conflict mentioned in comment 11
Attachment #466814 - Attachment is obsolete: true
Checkin-needed on final patch
Keywords: checkin-needed
Attached patch patch-final (obsolete) — Splinter Review
Updated patch to apply cleanly
Attachment #468324 - Attachment is obsolete: true
Attachment #468352 - Attachment is patch: true
Attachment #468352 - Attachment mime type: application/octet-stream → text/plain
Landed: http://hg.mozilla.org/mozilla-central/rev/cbf5a3941272
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b5
Attached patch patch-finalSplinter Review
patch that shouldn't break the build anymore...
Attachment #468352 - Attachment is obsolete: true
Blocks: 590102
Blocks: 590492
Comment on attachment 468466 [details] [diff] [review]
patch-final

>+/**
>+ * Opens the feedback page for this version of the application.
>+ */
>+function openFeedbackPage()
>+{
>+  openUILinkIn("http://input.mozilla.com/sad", "tab");
>+}

This should have been put into a pref and not hardcoded in a .js file.
Adding "Submit feedback" in the help menu with the intent of replacing "Report Broken website" is kind of weird. The result is now I got a user report that he wanted to send a happy feedback, which he can't do with that item (test pilot is disabled on unbranded builds, but anyways, once 4.0 ships, test pilot won't be enabled either)
Mike, take a look at Comment #10 and read through the blocker bugs related to that bug. That should offer some help!
Blocks: 602662
Duplicate of this bug: 624711
(In reply to comment #9)
> Agreed -- the webapp will not currently accept feedback from stable versions of
> Firefox. But as long as we're still in beta, it'll work.

The same applies to nightly builds where you get a useless page:
http://input.mozilla.com/en-US/beta/download

(In reply to comment #19)
> >+function openFeedbackPage()
> >+{
> >+  openUILinkIn("http://input.mozilla.com/sad", "tab");
> >+}
> 
> This should have been put into a pref and not hardcoded in a .js file.

Margarete, has this been fixed or a follow-up bug filed?

Aakash, do we have follow-up bugs for necessary work to support the final Firefox 4.0 release?

I will have to update the following litmus test once my questions are solved:
https://litmus.mozilla.org/show_test.cgi?id=10064
Flags: in-litmus?(hskupin)
There was a follow-up bug to change the url for the feedback page (bug 588209), but I don't believe there was a bug to turn it into a pref.
> Aakash, do we have follow-up bugs for necessary work to support the final
Firefox 4.0 release?


Yes, and that's done. You can see the changes by switching your user agent on Firefox 4 to the latest release version (i.e. 3.6.13) and going to input.mozilla.com/feedback.

https://bugzilla.mozilla.org/show_bug.cgi?id=626705
(In reply to comment #25)
> Yes, and that's done. You can see the changes by switching your user agent on
> Firefox 4 to the latest release version (i.e. 3.6.13) and going to
> input.mozilla.com/feedback.

Ok, but there is no way for nightly testers to submit those feedback. Don't we explicitly support that?
We currently explicitly do *not* support that. There's no feedback button in nightlies (there's not supposed to be, anyway) and Input won't support nightly feedback until its 4.x milestones (currently working on 3.1).
Ok, thanks for the information Fred. Marking as verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

Litmus test has been updated to the renamed menu entry:
https://litmus.mozilla.org/show_test.cgi?id=10064
Status: RESOLVED → VERIFIED
Flags: in-litmus?(hskupin) → in-litmus+
Version: unspecified → 3.5 Branch
Blocks: 663679
Depends on: 751282
You need to log in before you can comment on or make changes to this bug.