Re-paint issue of iframe with xul dialog (Description of Mozilla Privacy Policy in "Report A Broken Web Site" dialog is empty(unreadable)(Alt > Help > Report Broken Web Site…))

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

(Depends on 1 bug, {regression})

Trunk
mozilla2.0
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

22.30 KB, image/png
Details
1.09 KB, application/vnd.mozilla.xul+xml
Details
Reporter

Description

9 years ago
Posted image screenshot
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100821 Minefield/4.0b5pre ID:20100821040844
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100821 Minefield/4.0b5pre ID:20100821040844

Alt > Help > Report Broken Web Site…, 
Description of Mozilla Privacy Policy in "Report A Broken Web Site" dialog  is empty(unreadable).


Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open HOME
3. Alt > Help > Report Broken Web Site…

Actual Results:
 Description of Mozilla Privacy Policy is empty(unreadable)

Expected Results:
 Description of Mozilla Privacy Policy should appears (readable).


Regression Window:
Works:
http://hg.mozilla.org/mozilla-central/rev/1feed65f4d5b
Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100627 Minefield/3.7a6pre ID:20100627201551
Fails:
http://hg.mozilla.org/mozilla-central/rev/7ad36412775e
Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100627 Minefield/3.7a6pre ID:20100627215239
Puhlog
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1feed65f4d5b&tochange=7ad36412775e
Candidate:
Bug 574690 - Title bar(window without body) appears at the upper left corner of monitor screen for a split second when starting Minefield and restore previous size of browser
Reporter

Updated

9 years ago
Depends on: 588687
This will be INVALID when Bug 572695 is fixed.
(Unless there's a "real" underlying Bug and just exposed by the "Report Broken Web Site" Issue ...)
Depends on: 572695
Reporter

Comment 2

9 years ago
I think this is repainting issue.
Because, Contents(iframe) appear temporarily while I move the other window to overlap  this dialogue.
(In reply to comment #2)
> I think this is repainting issue.
> Because, Contents(iframe) appear temporarily while I move the other window to
> overlap  this dialogue.

Not sure this dependency is right Alice. The code in bug 579421 landed on 6-27, and was backed out on 7-15 and replaced with different logic.

A followup bug re-landed similar code that had improvements. (bug 579421, landed 8-3)

If the regression date of 6-27 is right, it should have gone away on 7-16, and possibly came back on 8-4.
Reporter

Comment 4

9 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > I think this is repainting issue.
> > Because, Contents(iframe) appear temporarily while I move the other window to
> > overlap  this dialogue.
> 
> Not sure this dependency is right Alice. The code in bug 579421 landed on 6-27,
> and was backed out on 7-15 and replaced with different logic.
> 
> A followup bug re-landed similar code that had improvements. (bug 579421,
> landed 8-3)
> 
> If the regression date of 6-27 is right, it should have gone away on 7-16, and
> possibly came back on 8-4.
Yes. first regression is in comment#0, and working again on 
http://hg.mozilla.org/mozilla-central/rev/7124132f0506Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; en-US; rv:2.0b2pre) Gecko/20100715 Minefield/4.0b2pre ID:20100715211042


And Second regression window:
Works:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100819 Minefield/4.0b5pre ID:20100820130619
Fails:
http://hg.mozilla.org/mozilla-central/rev/95a39e236cc4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100820 Minefield/4.0b5pre ID:20100820131417
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4192ba38ebee&tochange=95a39e236cc4
Candidate bug:
Bug 582057 - Replace platforms widgets in content processes with cross-platform fake widgets
Blocks: 582057
No longer blocks: 574690
Reporter

Comment 5

9 years ago
This does *not* happens on Linux and Window Xp:
Mozilla/5.0 (X11; Linux i686; rv:2.0b5pre) Gecko/20100822 Minefield/4.0b5pre ID:20100822030835

Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100822 Firefox/4.0b5pre ID:20100822040607

It happens on Windows 7(Clssic Style and Aero Style both) (I did not check on Vista)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100822 Minefield/4.0b5pre ID:20100822040607
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Target Milestone: --- → mozilla2.0
Reporter

Comment 6

9 years ago
Posted file testcase
[STR]
1. Open this test case, and click "Click to open popup".  then the following popup will open.
2. Follow STR of the popup.


<?xml version="1.0"?>
<?xml-stylesheet href="chrome://global/skin/" type="text/css"?>

<window id="test" title="test"
  xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">
  <description>[STR]</description>
  <description>1. turn the mouse wheel</description>
  <description>2-a. move mouse to resizer or star icon</description>
  <description>2-b. move this window  upper/lower outside of screen</description>
  <spacer height="20"/>
  <iframe id="iframe" type="content" flex="1" src="http://reporter.mozilla.org/privacy/?plain"/>
</window>
Reporter

Updated

9 years ago
Summary: Description of Mozilla Privacy Policy in "Report A Broken Web Site" dialog is empty(unreadable)(Alt > Help > Report Broken Web Site…) → Re-paint issue of iframe with xul dialog (Description of Mozilla Privacy Policy in "Report A Broken Web Site" dialog is empty(unreadable)(Alt > Help > Report Broken Web Site…))
I can't repro this with the fix in bug 589864.  Please reopen if you can with tomorrow's nightly.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.