Closed Bug 574168 Opened 10 years ago Closed 2 years ago

Real Player Browser Record plugin doesn't work in Firefox 3.6.4

Categories

(Firefox :: Extension Compatibility, defect)

3.6 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
blocking2.0 --- -
status1.9.2 --- wanted

People

(Reporter: cww, Unassigned)

References

Details

After OOPP released, we're seeing reports of the Real Player Browser Record Plugin that downloads Flash videos.  (ref: http://kb2.adobe.com/cps/402/kb402905.html -- I'm having trouble finding a way to download it so it may no longer be supported)

This extension was provided to everyone who downloaded or had real player so a number of users are finding this functionality suddenly gone.
This addon breaks often after a major browser update and we have several reports in the past about it.
Yeah, plenty of Sumo users running into this with 3.6.4.
Duplicate of this bug: 574665
Duplicate of this bug: 574956
Duplicate of this bug: 575025
I was able to download the main player and use this but this has caveats.

Navigate to http://www.real.com/realplayer
Download RealPlayerSP
Let it install, it will install the extension.

Now the fun part:

Must turn off OOPP for flash in about:config
dom.ipc.plugins.enabled.npswf32.dll = false

It might be that when when OOPP is off the browser knows when to paint the extension popup bar.  When the OOPP is on, I bet this isn't allowed or possible.

Maybe Roc or Jimm can determine if its something fixable or not and maybe require some kind of user documentation.
blocking1.9.2: --- → ?
setting that OOPP to false. appears to have fixed it.(for now) but this is ridiculous i hope someone copes out with an actual bug fix( either real or firefox)

why would firefox do that and disable a main plugin to its browser without taking the time to test its update first?
Well, true the developers have to review it, this is a workaround if you want to use it. 

I don't know if a bug was filed, this is the first report i've seen in bugzilla about it. 

Can someone update this so its blocking OOPP?  Thanks.
Duplicate of this bug: 575158
(In reply to comment #8)
> Can someone update this so its blocking OOPP?  Thanks.

blocking1.9.2:?  is a nomination to do that.

what we need now is a deeper diagnosis of why this is broken with OOPP, and a fix to make it work.  that will be fast path to making sure a fix makes the next 3.6.x release train.
(In reply to comment #10)
> (In reply to comment #8)
> > Can someone update this so its blocking OOPP?  Thanks.
> 
> blocking1.9.2:?  is a nomination to do that.

I meant in the block field, add it to the "OOPP" meta tracking bug 478976. Since its probably going to be broken on the m-c also.
Duplicate of this bug: 575207
Blocks: OOPP
blocking1.9.2: ? → ---
blocking2.0: --- → ?
Duplicate of this bug: 576566
Duplicate of this bug: 577860
blocking2.0: ? → -
I had the problem even in firefox 3.6.10 until I reinstalled the real player software.  I tested the plugin in youtube and the download now button works!  I am using the realplayer browser record plugin 1.1.5
I forgot to mention that I did not use the work around in comment 6. my current setting is "true" and the button displays.
Jamin, I could not confirm the same.  I still always had to turn off OOPP for flash using 10.1 r85. I tried a fresh profile in firefox and a clean install of RealPlayerSPgold which installs the 1.1.5 extension (which is not a plugin) and manipulated the download & record settings in RealPlayerSP, I tested mouseover and download show on right click.  I test 3.6.10 and 4.0 and neither one worked with OOPP flash enabled.
I went to www.real.com and clicked on the "free download realplayer"  from internet explorer and ran the file. It shuts down any open browsers and installs real player.  when I checked the stats on about real player this is what it says "RealPlayerSP(tm)(win32) Version 1.1.5 Helix Powered Build 12.0.0.879 Distribution: R51R06."  After I installed it my issue with the plugin "RealPlayer Version Plugin 6.0.12.775" RealPlayer(tm) G2 LiveConnect-Enabled Plug-In(32-bit) 6.0.12.775, RealPlayer HTML5VideoShim Plug-In(32Bit) 1.0.0.0.  Shockwave Flash is 10.1.85.3 or the 10.1 r85.  I never turned off the oopp it is still set to true.  Hope it helps that is how I fixed my issue.
WFM too, Mozilla/5.0 (Windows; U; Windows NT 6.1; nl; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
i tried to turn back OPPP on again. still nothing. after all these months. no fix. it does work on youtube ok. but certain other sites it does NOT. the button appears much higher. something is still wrong
Mass-closing old Extension Compatibility bugs that relate to legacy add-ons or NPAPI plug-ins. If you think this bug is still valid, please reopen or comment.

Sorry for the bug spam, and happy Friday!
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.