Closed Bug 576114 Opened 9 years ago Closed 9 years ago

Cannot remove "Quick Filter" that is obligatory post 3.1 "upgrade"

Categories

(Thunderbird :: Toolbars and Tabs, defect)

All
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 570815

People

(Reporter: Mly, Unassigned)

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.4) Gecko/20100608 Thunderbird/3.1

Somebody dumped this new junk onto my screen real estate without asking me.

Now I have TWO different tool bars with TWO different search boxes wasting vertical space.  Just wonderful.

There is no obvious or even moderately non-obvious way to MAKE IT GO AWAY.

* Right-clicking on the ultra-super-kewl-gee-whiz new toolbar does ... nothing.

* Attempting to drag away the wonder-nifty-mega-awesome new toolbar does ... nothing.

* Looking under menu items Thunderbird / Preferences / General
and Thunderbird / Preferences / Display
and Thunderbird / Advanced / General
and Thunderbird / Advanced / Reading & Display
show ... nothing.

* Looking under Thunderbird / Preferences / Advanced / Config Editor ...
and then looking for anything containing the strings "quick" or "search"
comes up with ... nothing.


So I know that whoever wrote this code for sure believes it is the most
hyper-awesome new feature in the history of the universe, and that anybody
who isn't just BLOWN AWAY by having an extra line-and-a-half-tall toolbar
stealing space from their message summary pane is, like, totally lame, and,
like, stuff, you know, but ...

I DON'T WANT IT and I DIDN'T ASK FOR IT and it's MY COMPUTER showing MY MAIL
so please PROVIDE A WAY TO MAKE IT GO AWAY.

Thanks.


Reproducible: Always

Steps to Reproduce:
1. "Upgrade" to Thunderbird 3.1
2. Now with less displayed content and more UI fluff.  Two search bars.  Just what I ALWAYS wanted.

Actual Results:  
Two search bars, one of which eats up more than one line of my message summary pane.

Expected Results:  
At most one search bar, living in the the window toolbar where it belongs and where it does not steal any more screen real estate.

If I want your new feature I'll ask for it, thanks very much.


Stop it!  Just stop it.  "Upgrading" anything Thunderbird starting with 3.0 has just been a nightmare of unrequested UI ****, mistakenly downloaded under the false pretense that fatal bugs might also have been fixed.
Uh, did you try clicking the magnifying glass on the tab bar?
As an addendum, if you're a keyboarding sort of person, you can just hit "Escape" when the bar has focus, much like the other "Find" toolbars already present in Thunderbird and Firefox.
Just felt like adding my 2c to this bug -- I usually leave the new filter bar hidden, as seen in this snip, but use it at times for efficient filtering for a short period. In hidden mode, it uses up a few dozen pixels of horizontal space in the tab strip, which (in my Thunderbird usage habits since 3.0b4) hasn't yet gotten crowded.

I do agree that it's frustrating to lose screen space, and I also agree that the filter bar might be more easily hidable. Perhaps an additional close button would be suitable, although I believe that was originally prototyped and presumably found wanting (or unnecessary?).

Hope this helps.
(In reply to comment #1)

> Uh, did you try clicking the magnifying glass on the tab bar?

Uh, no.  Why should I.  I DON'T WANT TO SEARCH -- I want the search thing to go away, not to activeate it, which is what clicking on something traditionally does.

But anyway, doing so does NOTHING, other than replacing the medium-grey text
"Search all messages... <squiggle-F>" with blank text.  There is no
little pull-down menu triangle thingy as suggested in Comment 3.
And even if there were, I wouldn't expect to use that to hide a toolbar.

To add to the confusion (following from Comment 2) I have ABSOLUTELY NO IDEA what is happening when I press the escape key one or more times.  I didn't know pressing Escape would do anything, but now I accidentally do, I still don't understand what it going on.  The UI associated with this is opaque, inexplicable, and irritating.  I have no mental model of what it is doing, and it corresponds to nothing else in the program or on the platform (MacOS in my case.)

I only found out about pressing command-F (as with pressing Escape) by reading this bug report.  Do you ******REALLY****** expect users to have to search Bugzilla in order to manipulate/customize/hide/show UI elements?

This stuff is a nightmare!
(In reply to comment #4)
> But anyway, doing so does NOTHING, other than replacing the medium-grey text
> "Search all messages... <squiggle-F>" with blank text.  There is no
> little pull-down menu triangle thingy as suggested in Comment 3.
> And even if there were, I wouldn't expect to use that to hide a toolbar.

It sounds like you are talking about the icon in the search box, not the one in the tab bar. The attached image provides a little more visual context (it's the thing highlighted in red). There is a more thorough explanation of this available via the online help for Thunderbird: http://kb.mozillazine.org/Thunderbird_3.1_-_New_Features_and_Changes#Quick-Filter_Bar

> I only found out about pressing command-F (as with pressing Escape) by reading
> this bug report.  Do you ******REALLY****** expect users to have to search
> Bugzilla in order to manipulate/customize/hide/show UI elements?

No I don't, but that's why this behavior is documented in detail in the online help. Granted, the behavior of this bar can be confusing if the tab bar is hidden (the documentation above does address this case as well). However, that that option currently requires manually editing preferences, so there are bound to be a few speed bumps.
Note no pull-down-triangle-thingy associated with the magnifying-glass-thingy next to the text box of the (space-eating and unwanted) secondary toolbar.
Here are some bugs (not just problems with bad UI design, but actual implementation bugs) with this toolbar feature for me on MacOS 10.6.4:

1. If the toolbar is hidden -- which can only be accomplished by using the mouse menu Views / Toolbars / Quick Filter Bar -- then pressing command-F
first shwos the toolbar, then subsequently cycles between removing
keyboard focus from the filter bar text entry box and giving it focus.

It does *NOT* hide the toolbar, contrary to other suggestions/reports.

Note that when pulling down the menus using a mouse that command-F is
displayed by the menu UI as the keyboard shortcut for this sequence of
nested menus, and that when command-F is pressed the "View" label in
the MacOS application-level toolbar briefly flashes, as one expects when
using a keyboard equivalent of a mouse-y thing.  Yet we see that
the keyboard command DOES NOT do the same as invoking the menu item
using the mouse: the former will never hide the new toolbar (only removes
keyboard focus), while the latter will make the damned thing evaporate.
This hints to me that somebody is doing extra work to make it work wrongly!


2. The screen snapshots attached by others
https://bugzilla.mozilla.org/attachment.cgi?id=455361
https://bugzilla.mozilla.org/attachment.cgi?id=455368
do not resemble the UI on the MacOS platform;
see the screen shot attachment I just added
https://bugzilla.mozilla.org/attachment.cgi?id=456103
No pull-down menu associated with the toolbar, and no UI suggestion
that there is such a pull-down.


3. Even if there were little pull-down triangles associated with
the new search menubar, it still isn't what I want.

I just want the cheap and easy and non-screen-real-estate-stealing
filter business from 3.0: fits ****IN THE MAIN TOOLBAR**** and doesn't
steal space from the message subject summary pane.  And I never want
the new over-the-top yet glacial global search (command-K) thing
which is now the only search thing that can be placed in the main
toolbar.

So I've gone from something that worked 80% of the time to something
that never does what I want.  Progress!

So can somebody please come up with some way to make some sort of
quick filter UI gadget that can be placed in the toolbar that lives
at the top of window?  It can be done, as the presence of the
global-search UI gadget shows.  Thanks.
Im not sure if this is related, but i dont want or use the "Quick Filter" tool bar. I can click it to make it go away but it comes back on the next incoming email. This is ONLY ON A MAC. Using the PC version, once QF is disabled it stays away.
Clicking on 'View/Toolbars/Quick Filter Bar' turns it off but it returns after closing and then opening Mail & Newsgroups Window.

See also https://bugzilla.mozilla.org/show_bug.cgi?id=578377 
and https://bugzilla.mozilla.org/show_bug.cgi?id=579685
(In reply to comment #7)
> Here are some bugs...
> 1. ... pressing command-F...
> first shwos the toolbar, then subsequently cycles between removing
> keyboard focus from the filter bar text entry box and giving it focus.
> It does *NOT* hide the toolbar, contrary to other suggestions/reports.

The point is: Reporter (somewhat rightly) expects a shortcut on a toggle command to do the toggle on/off both ways, which doesn't work in this case. Ctrl+F (apart from being shared with "Find in this message") only toggles the qf toolbar ON. However, would you really expect the specific shortcut Ctrl+F to hide the toolbar? Ctrl+F is strongly and intuitively associated with "Find"... 
So there should be a "Filter these messages" command in Edit > Find menu (needs new bug) and there the shortcut can be shown on the menu without problem (and we could remove the shortcut from toggle command). It's a bit non-standard to show the one-way shortcut on a two-way command, but on the other hand it's certainly helpful for many users to see it there, so I'm still not sure if removing the shortcut from toogle command is really necessary and beneficial. Anyway, that would require a new bug, and much of the Ctrl+F problem is covered by other bugs (e.g. bug 564328, bug 571280, and bug 575018. So point 1 is covered.

> 2. The screen snapshots attached by others
> https://bugzilla.mozilla.org/attachment.cgi?id=455361
> https://bugzilla.mozilla.org/attachment.cgi?id=455368
> do not resemble the UI on the MacOS platform;
> see the screen shot attachment I just added
> https://bugzilla.mozilla.org/attachment.cgi?id=456103
> No pull-down menu associated with the toolbar, and no UI suggestion
> that there is such a pull-down.

Reporter (Richard) has mail.tabs.autoHide = true (see screenshot attachment 456103 [details]) and therefore does not usually see/have the quick filter bar toggle button tab shown in attachment 455361 [details] and attachment 455368 [details]. So most of point 2 of comment 7 is invalid.

As opposed to comment 5, documentation (as referenced in comment 5) does NOT sufficiently/explicitly explain the case of mail.tabs.autoHide = true and its consequences regarding the qfb toggle button. However, I think pressing ESC or using View > Toolbars > qfb is sufficient and sufficiently discoverable to consider that aspect of this bug "worksforme".

 
> 3. Even if there were little pull-down triangles associated with
> the new search menubar, it still isn't what I want.
> 
> I just want the cheap and easy and non-screen-real-estate-stealing
> filter business from 3.0: fits ****IN THE MAIN TOOLBAR**** ...
> So can somebody please come up with some way to make some sort of
> quick filter UI gadget that can be placed in the toolbar

I think that's the main intention of this bug, and it's currently being explored in bug 570815.

-> Resolving as duplicate of bug 570815
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: qfwidget
You need to log in before you can comment on or make changes to this bug.