Double-click on free space on tabbar doesn't open new tab when 'Tabs on top'

RESOLVED WONTFIX

Status

()

Firefox
Tabbed Browser
RESOLVED WONTFIX
8 years ago
6 years ago

People

(Reporter: JasnaPaka, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
When I double-click on free space on tabbar I see different behavior based on where tabbar is. 

* "Tabs on top" -> window change size
* "Tabs on bottom" -> new tab is opened

I think behavior should be the same in both situations and I think new tab should be opened.
dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=575248 ?
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 575248
Status: RESOLVED → VERIFIED
Uh, this is not a dupe. Bug 575248 is for tabs on bottom.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
Duplicate of this bug: 647613
Duplicate of this bug: 648686
I think we need UX feedback here.
Keywords: uiwanted
Duplicate of this bug: 657048
Alex, can you please check this bug? We get failures in our Mozmill tests and we would like to know which we want to go here. Thanks.
Blocks: 665898
See bug 575248 comment 12.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago7 years ago
Keywords: uiwanted
Resolution: --- → WONTFIX

Comment 10

6 years ago
Is this bug specific for Menu Bar being off? Because it makes much more sense to wontfix this for Menu Bar off, but not as much when the user enabled the Menu Bar and has already a title bar + menu bar above the tab strip.
I don't think this bug specifies which case it's addressing. Originally for bug 648686 I didn't specify, but should have incluced the fact that with the menu/titlebar off, clicking what should be the gutter still resizes the window without producing a new tab. Unless there's a bug which is specific for that case this bug still stands.
Duplicate of this bug: 738397
(In reply to Dão Gottwald [:dao] from comment #9)
> See bug 575248 comment 12.

I understand based on that comment you don't want to fix this. But at least can you then restore the new-tab button even though the '.tabs-newtab-button {display:none !important;}' exist in userChrome.css, only in case of tab-on-top is selected?

I have that line in my userChrome.css as I don't want the new-tab button clutter my toolbar, but in case of tab-on-top is selected, then I rather to have it back (but I don't want to keep changing the userChrome.css back and forth).
(In reply to Edoardo Tirtarahardja from comment #13)
> (In reply to Dão Gottwald [:dao] from comment #9)
> > See bug 575248 comment 12.
> 
> I understand based on that comment you don't want to fix this. But at least
> can you then restore the new-tab button even though the '.tabs-newtab-button
> {display:none !important;}' exist in userChrome.css, only in case of
> tab-on-top is selected?

No, you'll have to adjust your userChrome.css code.
Why not? Currently you're doing it anyway for tab-on-bottom mode when there are too many tab in such that there is no longer free space in the tab-bar (make sense as user don't have any place to double click on).

So the same logic should also apply for tab-on-top, or any other possible case, that in such the free space in the tab-bar is no longer available for user to double click on, the new-tab button should appear regardless the setting in userChrome.css.
You need to log in before you can comment on or make changes to this bug.