Closed Bug 577213 Opened 10 years ago Closed 10 years ago

firefox 4 beta 1 gives bad error message when run on Mac OS X 10.4

Categories

(Firefox Build System :: General, defect)

PowerPC
macOS
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: pfmoose, Assigned: timeless)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_4_11; en) AppleWebKit/533.16 (KHTML, like Gecko) Version/4.1 Safari/533.16
Build Identifier: http://www.mozilla.com/products/download.html?product=firefox-4.0b1&os=osx&lang=en-US

There was a similar report filed about the alpha prerelease, the answer to that was that the trunk was 10.5 and above only, however in the beta the min. System Requirements are 10.4 and above but Firefox still fails to launch.

Crash log:



Host Name:      [anonymous]
Date/Time:      2010-07-07 10:23:01.000 +0200
OS Version:     10.4.11 (Build 8S165)
Report Version: 4

Command: firefox-bin
Path:    ./firefox-bin
Parent:  bash [250]

Version: ??? (???)

PID:    251
Thread: Unknown

Link (dyld) error:

Symbol not found: _open$UNIX2003
  Referenced from: /Applications/Firefox.app/Contents/MacOS/./libnspr4.dylib
  Expected in: /usr/lib/libSystem.B.dylib


Reproducible: Always

Steps to Reproduce:
1. Download Firefox 4 beta 1
2. Copy to /Applications/
3. Launch


Expected Results:  
Launch succesfully.
We could set LSMinimumSystemVersion

http://developer.apple.com/iphone/library/documentation/CoreFoundation/Conceptual/CFBundles/BundleTypes/BundleTypes.html
Component: General → Build Config
QA Contact: general → build.config
Summary: firefox 4 beta 1 fails to launch under mac osx 10.4 → firefox 4 beta 1 gives bad error message when run on mac osx 10.4
Summary: firefox 4 beta 1 gives bad error message when run on mac osx 10.4 → firefox 4 beta 1 gives bad error message when run on Mac OS X 10.4
Attached patch proposalSplinter Review
Assignee: nobody → timeless
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #456242 - Flags: review?(ted.mielczarek)
Blocks: 577236
Blocks: 577237
Does this mean that the beta won't be compatible with 10.4? Or even that Firefox 4 won't be compatible?
(In reply to comment #3)
> Does this mean that the beta won't be compatible with 10.4? Or even that
> Firefox 4 won't be compatible?

You're out of luck, Firefox 4 / Gecko 2.0 requires 10.5 or higher

It is a bug on the download page that it says '10.4'.
Attachment #456242 - Flags: review?(ted.mielczarek)
Attachment #456242 - Flags: review?(joshmoz)
Attachment #456242 - Flags: review+
Depends on: 577258
Depends on: 577256
No longer depends on: 577258
Attachment #456242 - Flags: review?(joshmoz) → review+
http://hg.mozilla.org/mozilla-central/rev/f4841bfd718a
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Blocks: 587618
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.