Dragging an app tab to a new window should keep the tab as an app tab

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
8 years ago
6 years ago

People

(Reporter: kbrosnan, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [AppTabsTestday])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Create an app tab. Drag and drop it in a location that would create a new window. Currently a new window with a normal tab is created. It seems that it should stay an app tab.

Updated

8 years ago
Duplicate of this bug: 582566
(Reporter)

Updated

8 years ago
Duplicate of this bug: 582954

Updated

8 years ago
Blocks: 563730

Updated

8 years ago
Blocks: 551849
Shouldn't it be set "Blocking 2.0 ?" ?
Created attachment 497089 [details]
Google Web App in a stand alone window

For Comparison I think our App tabs in stand alone windows could also follow the Chrome model as shown here. 

Here is Gmail's chrome web app in stand alone mode.  

1) Go to your Gmail Account
2) Go to Chrome Tools
3) Go to Create application shortcuts
4) I selected all 3 checkboxes, see screenshot.
CC'ing a few people.

Alex - Alex, Could we get some direction on stand alone [window] app tabs?

Chrome's stand alone web applications kinda just look like popup windows with basic functionality as shown in the attachment in comment 4.  

If we implemented this our version of stand alone window for App-Tabs, I also don't see why we need a single tab at all, unless it is just show the tab title as a tab that is extended across the top like taking up the entire tabbar.  I imagine we might not have the Titlebar or App Menu showing either depending on how the window opens.

Jim, for implementation sake, here is my Chrome Gmail shortcut properties:
\Users\xxxxx\AppData\Local\Google\Chrome\Application\chrome.exe --app="http://mail.google.com/mail"

Seems easy enough for us to also do give if we could launch a URL from the command line, but its given itself the favicon as the shortcut icon.
Keywords: uiwanted
app tabs are meant to be global across all windows.  This isn't implemented yet, and will miss Firefox 4, but nonetheless we don't want users to start to rely on the ability to have different app tabs in different windows, since that isn't the long term plan.
(Reporter)

Updated

8 years ago
Duplicate of this bug: 628645
Blocks: 633223
Blocks: 590297
No longer blocks: 633223
Duplicate of this bug: 648820

Updated

8 years ago
Depends on: 455694

Comment 9

8 years ago
As Alex said, this isn't part of the long-term plan, and implementing it doesn't help in the short term either.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX

Comment 10

8 years ago
Bug 590297 is a special case of this that we do want to fix for now.
No longer blocks: 551849, 590297, 563730
No longer depends on: 455694

Updated

8 years ago
Keywords: uiwanted

Updated

6 years ago
Duplicate of this bug: 805978
You need to log in before you can comment on or make changes to this bug.