Last Comment Bug 590297 - Dropping a tab in another window should transform it into the same type as that of the drop region
: Dropping a tab in another window should transform it into the same type as th...
Status: REOPENED
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 633223 654907 706080 805978 (view as bug list)
Depends on: 674925 455694
Blocks: 886154
  Show dependency treegraph
 
Reported: 2010-08-24 14:20 PDT by Tony Chung [:tchung]
Modified: 2013-06-23 13:45 PDT (History)
17 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Tony Chung [:tchung] 2010-08-24 14:20:49 PDT
If you open two browser windows, where one has app tabs created, and the other has a normal browser tab, dragging the normal tab into the 2nd browser window-App tab row, will just keep it as a normal tab.  Instead of becoming an app tab.

Alternately, if within the same browser window, i can drag a normal tab into the app tab row and watch it turn into an App tab

Repro:
1) install Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b5pre) Gecko/20100824 Minefield/4.0b5pre
2) create two browser windows.  One should have a few app tabs already made.  The other should have normal tabs in it
3) Take a normal tab from browser window 2, and drag it to the App tab area in browser window 1
4) verify the normal tab sticks in window 2 as a "normal tab", instead of an "App tab"

Expected:
- dragging a normal tab into a app tab pane on another browser should stick as an App Tab

Actual:
- doing the above only generates a normal tab instead of an App tab
Comment 1 Michael Yoshitaka Erlewine [:mitcho] 2010-09-16 19:32:06 PDT
Punting to the future.
Comment 2 eyal gruss (eyaler) 2010-09-22 04:29:03 PDT
duplicate of bug 579482?
Comment 3 eyal gruss (eyaler) 2011-02-11 05:18:32 PST
*** Bug 633223 has been marked as a duplicate of this bug. ***
Comment 4 Henrik Skupin (:whimboo) 2011-02-11 05:36:02 PST
Why is that under TabCandy? Moving to the correct component.
Comment 5 eyal gruss (eyaler) 2011-05-05 00:53:51 PDT
*** Bug 654907 has been marked as a duplicate of this bug. ***
Comment 6 Frank Yan (:fryn) 2011-05-05 01:07:18 PDT
While app tabs will be global in the long-term plan, doing this makes the most sense in the interaction model for bug 455694 until they become global.

In fact, the behavior of the patch in bug 455694 fixes this bug.

However, this doesn't block bug 551849, because it wasn't part of the original plan, and it still isn't.
Comment 7 Frank Yan (:fryn) 2011-07-01 04:53:32 PDT
My patch for bug 455694 fixes this.
Comment 8 Frank Yan (:fryn) 2011-07-27 03:20:22 PDT
Fixed by patch in bug 455694.
Comment 9 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-09-30 15:41:01 PDT
Verified fixed in Firefox 8.0b1.
Comment 10 eyal gruss (eyaler) 2012-03-20 18:41:35 PDT
*** Bug 706080 has been marked as a duplicate of this bug. ***
Comment 11 eyal gruss (eyaler) 2012-03-20 18:44:32 PDT
this is broken in 12.0b1, probably due to 455694 backout
Comment 12 [:Aleksej] 2012-10-30 09:44:51 PDT
*** Bug 805978 has been marked as a duplicate of this bug. ***
Comment 13 eyal gruss (eyaler) 2012-10-30 10:45:26 PDT
*** Bug 805978 has been marked as a duplicate of this bug. ***
Comment 14 eyal gruss (eyaler) 2013-06-23 13:45:44 PDT
this is now wfm. however i think this should be retracted see bug 886154

Note You need to log in before you can comment on or make changes to this bug.