Remove "New Tab" from the tab context menu

VERIFIED FIXED in Firefox 4.0b3

Status

()

Firefox
Menus
VERIFIED FIXED
7 years ago
5 years ago

People

(Reporter: dao, Assigned: dao)

Tracking

({ux-minimalism})

Trunk
Firefox 4.0b3
ux-minimalism
Points:
---
Dependency tree / graph
Bug Flags:
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [killthem])

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Created attachment 458165 [details] [diff] [review]
patch

It's one of the few items that don't relate to the tab you've clicking on, and it became extra-redundant when we added the new-tab button to the tab strip. It's also present in the menu bar and app button menu.
Attachment #458165 - Flags: ui-review?(faaborg)
Attachment #458165 - Flags: review?(gavin.sharp)
(Assignee)

Comment 1

7 years ago
(In reply to comment #0)
> app button menu

Scratch that, we omitted it there because we have the button.
(Assignee)

Comment 2

7 years ago
(In reply to comment #1)
> (In reply to comment #0)
> > app button menu
> 
> Scratch that, we omitted it there because we have the button.

I.e. the new-tab button in the tab bar.
(In reply to comment #0)
> It's one of the few items that don't relate to the tab you've clicking on, and
> it became extra-redundant when we added the new-tab button to the tab strip.

For Reference: our Competitors keep said Extra-Redundancy (at least) until now. I wonder why.
Also with the same said Argument the "Close Tab" Entry can be removed (new Bug?).
(Assignee)

Comment 4

7 years ago
(In reply to comment #3)
> Also with the same said Argument the "Close Tab" Entry can be removed (new
> Bug?).

No, the close button isn't always available.
Attachment #458165 - Flags: review?(gavin.sharp) → review+
Attachment #458165 - Flags: ui-review?(faaborg) → ui-review+
(Assignee)

Updated

7 years ago
Attachment #458165 - Flags: approval2.0?
Comment on attachment 458165 [details] [diff] [review]
patch

a=beltzner
Attachment #458165 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 6

7 years ago
http://hg.mozilla.org/mozilla-central/rev/238e2486b6a0
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b3

Comment 7

7 years ago
I don't see how this was clutter and don't think it should've been removed. Based on the logic here, close tab should also be removed.
This might actually cause UX issues with having to move your mouse all the way to right to add a tab, and back again to the left to enter URLs if your mainly a mouse user like myself.
(Assignee)

Comment 9

7 years ago
(In reply to comment #7)
> I don't see how this was clutter and don't think it should've been removed.
> Based on the logic here, close tab should also be removed.

No, see comment 4.

(In reply to comment #8)
> This might actually cause UX issues with having to move your mouse all the way
> to right to add a tab, and back again to the left to enter URLs if your mainly
> a mouse user like myself.

You can move the "new tab" button right next to the location bar if that fits your work flow.
Dao, I assume you did a check on MXR which code uses this DTD entity. Can you please give us at least a note when changes will affect Mozmill tests? That wouldn't force us to search for the causing bug. Thanks.
Depends on: 581037
(Assignee)

Comment 11

7 years ago
(In reply to comment #10)
> Dao, I assume you did a check on MXR which code uses this DTD entity.

Yes, and MXR told me it was otherwise unused.
(In reply to comment #11)
> > Dao, I assume you did a check on MXR which code uses this DTD entity.
> 
> Yes, and MXR told me it was otherwise unused.

Seems like the version of the tests we have on m-c hasn't been updated for a longer time. Sorry, that wasn't your fault.
Verified fixed with Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b3pre) Gecko/20100723 Minefield/4.0b3pre

The following Litmus test has been disabled:
https://litmus.mozilla.org/show_test.cgi?id=10085
Status: RESOLVED → VERIFIED
Flags: in-litmus-

Comment 14

7 years ago
So now it's meant to be impossible to open a new tab if there is no new tab button on the interface, right?
(Assignee)

Comment 15

7 years ago
(In reply to comment #14)
> So now it's meant to be impossible to open a new tab if there is no new tab
> button on the interface, right?

If you remove the new tab button, you can still use the menu bar, double click on empty space in the tab bar or hit accel+t.

Comment 16

7 years ago
(In reply to comment #15)
> (In reply to comment #14)
> > So now it's meant to be impossible to open a new tab if there is no new tab
> > button on the interface, right?
> 
> If you remove the new tab button, you can still use the menu bar, double click
> on empty space in the tab bar or hit accel+t.

All of those are currently undoable with the menubar disabled.

Comment 17

7 years ago
Yeah, the double click is about bug #575248.

And the menu bar may be hidden. What will happen then? Couldn't we do a check if the new tab button is hidden and add "New tab" to the firefox menu?

Comment 18

7 years ago
(In reply to comment #15)
> (In reply to comment #14)
> > So now it's meant to be impossible to open a new tab if there is no new tab
> > button on the interface, right?
> 
> If you remove the new tab button, you can still use the menu bar, double click
> on empty space in the tab bar or hit accel+t.

Scenario:
1. New tab button removed
2. Menu bar hidden
3. Tab bar filled from end to end

Result:
1. Access to menu bar is a hassle
2. Double/middle clicking is impossible
3. Keyboard shortcut often does not work when focus is on an embedded Flash application
See also

http://hg.mozilla.org/mozilla-central/rev/54c9709c9ee9

which removes from browser.css (gnomestripe only) the styling which used to add the icon to the now-removed 'new tab' context menu item.

Comment 20

7 years ago
(In reply to comment #0)
> It's one of the few items that don't relate to the tab you've clicking on, and
> it became extra-redundant when we added the new-tab button to the tab strip.
> It's also present in the menu bar and app button menu.

Removing this entry in the tab context menu obviously breaks ie, chrome and opera parity. If fix for Bug 455722 ever gets into Firefox, users will again be able to open new, albeit not clean tabs from this context menu.

Comment 21

7 years ago
New tabs from the tab context menu should be added to the right of the parent instead

When the new tab behaviour was added it was said that 
http://beltzner.ca/mike/2009/01/11/a-small-change-to-tab-ordering-coming-soon-to-trunk/

- New tabs opened from a tab would be added to the right of the parent tab, unless there is already a child tab. In this case it would be added to the right of the last child tab.

- New tabs opened via the new tab button, File/New Tab… menu, Ctrl + T, etc. would still be opened to the end of the tab bar, as it is not possible to know if its contents is related to the current tab or not.

I believe that we are missing an opportunity here. If the user is opening a new tab from the context menu, in this particular case he is really actually trying to open it to the right of the parent tab.

Instead of removing the new tab entry in the context menu completely, we should make it conform to the other "New tabs opened from a tab" policy and add these new tabs opened from the context menu to the right of their parents.
(Assignee)

Updated

7 years ago
Blocks: 616795

Comment 22

6 years ago
Good day all.

I've been an FF user for a very long time, and i find the removal of the New Tab option from the tab context menu to be nearly deal breaking for me, at least at work.

I utilize tabs constantly and often need a new tab right next to the one i'm currently focused on.  I'm a left mouse user, and therefore to Ctrl-T, i have to move my hand off the mouse.  my other option is to move the mouse across the screen to the end of my 10+ tabs and click on the new tab button.

I have spent all day attempting to find a means of re-adding back the option in the context menu, to no avail.

Obviously, not a lot of people utilized this feature, but I seriously can not use FF4 at work efficiently, and am going to be forced to stick to FF3.6 if i can't find a solution.

The same thing goes with the status bar, though at least i was able to work around that with Status-4-Evar.

I've got not problem with you guys altering the interface, but for the love of all things, please do not remove functionality or options without providing a means or putting them back.

Comment 23

6 years ago
(In reply to comment #22)
> Good day all.
> 
> I've been an FF user for a very long time, and i find the removal of the New
> Tab option from the tab context menu to be nearly deal breaking for me, at
> least at work.

The new tab button provides an easier way to open a new tab.  One click versus right-click, move mouse to the menu, another click to select the entry.

Comment 24

6 years ago
No it does not provide an easier way, just a different way.  i have to run 10+ tabs at a time, mostly working with the left-most tabs.  moving my mouse all the way to the right of the tab options.  it will then open the new tab next to whichever one is highlighted, forcing me to move the mouse back.

Far easier is right-click on a tab, select "open new tab" and have it open right next to whichever tab i right-clicked on.  Much better UX.
(Assignee)

Comment 25

6 years ago
(In reply to comment #24)
> No it does not provide an easier way, just a different way.  i have to run 10+
> tabs at a time, mostly working with the left-most tabs.  moving my mouse all
> the way to the right of the tab options.  it will then open the new tab next to
> whichever one is highlighted, forcing me to move the mouse back.

No, the new tab button as well as the context menu item would open the tab on the right, unless you have an add-on changing this for you.

Comment 26

6 years ago
Yeah, you are right about the add-on being required.  Either way, i need the context menu back.  Is there a hack or hidden setting that will allow it?
(Assignee)

Comment 27

6 years ago
No, but an add-on could add the item easily.

Comment 28

6 years ago
With buttons being removed (feeds) or moved in the UI (reload&stop), they can be added back through the Customize menu. It would be sweet if this could also be the case for context menu items. With Firefox 4 and the "cleaning" / "dumbing down" / "simplifying" of the interface, and only with 3 party addons available for keeping the removed functionality I think that Mozilla is alienating powerusers.

Comment 29

6 years ago
Completely agree. Please stop removing functionality without a means of retaining or recovering it without the need of third party add ons.


(In reply to comment #28)
> With buttons being removed (feeds) or moved in the UI (reload&stop), they can
> be added back through the Customize menu. It would be sweet if this could also
> be the case for context menu items. With Firefox 4 and the "cleaning" /
> "dumbing down" / "simplifying" of the interface, and only with 3 party addons
> available for keeping the removed functionality I think that Mozilla is
> alienating powerusers.
Depends on: 623159

Comment 30

6 years ago
I agree with the person who said that this option should be changed back to the way it is in Firefox 3x -- I've stopped using Firefox 4 beta because of it and if Mozilla insists on making this a permanent change, I will use another browser as my primary browser. This totally sucks. I hate it and it upsets me.

Comment 31

6 years ago
As of Firefox 4.0b10 there is still no "New Tab" context menu, whether you click on a tab or the tab bar. CTRL+T will open a new tab (if the focus is not stuck in an embedded object such as Flash). Double clicking the tab bar in a maximized window fails to create a new tab ("restores" window size). Middle clicking the tab bar will create a new tab...but if our tab bar is full (no space to middle click) we're forced to use the main menu or that ugly "New Tab" button (that I've been removing since it defaulted its way into Fx3).

Firefox is supposed to represent our freedom to choose a browser that satisfies all of our needs. I've been been deprived that privilege ever since this "bug" fix.


Tested on WinXP

Comment 32

6 years ago
As of FireFox 4.0b12, there STILL is no "New Tab" in context menu and its driving me crazy. I twitch my hand real quick so removing this from right-click context menu is slowing me down way too much. Please allow us to regain this missing UI feature as I really liked FireFox 3.6 and this is just unusable as I always have a full bar of tabs and it takes too long to move to the right side of the page just to move back to the left to get to the URL bar.

Comment 33

6 years ago
I too find the use of the "new-tab button" in the tab bar cumbersome.

So even though the user community is asking to maintain this functionality, the issue is considered closed?  Maybe it is time to make the full transition to Chrome.

Comment 34

6 years ago
well... If this issue is considered closed, then that seals it. I am using Chrome most of the time anyway and Firefox fails the acid3 tests.

Comment 35

6 years ago
Jackie: which real world pages you are frequenting that are affected by the acid3 failures in Firefox?

How about reopening Bug 623159 and state the case for reintroducing this tab context menu entry?
You need to log in before you can comment on or make changes to this bug.