Vertical lines between non-tab tab bar elements look out of place in the tabs on top mode

RESOLVED FIXED in Firefox 4.0b9

Status

()

Firefox
Theme
--
minor
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: hsivonen, Assigned: mstange)

Tracking

Trunk
Firefox 4.0b9
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
Created attachment 459370 [details]
Screenshot of the lines that don't look quite right

Steps to reproduce:
 1) Use a Mac
 2) Update to nightly from around 2010-07-21
 3) Make sure "tabs on top" is enabled.

Actual results:
In the right, the three non-tab UI elements are bounded by vertical lines that end sharply at the title bar. The lines don't look right for unified windows, since unified windows generally don't have elements that end sharply at the title bar.

Expected results:
Expected these UI elements not to have the lines around them or, alternatively, expected the lines to fade gradually upwards to make the transition to the title bar look less sharp.
(Reporter)

Updated

8 years ago
Component: Toolbars → Theme
QA Contact: toolbars → theme

Updated

8 years ago
Duplicate of this bug: 594016

Updated

8 years ago
Blocks: 544821
(Assignee)

Comment 2

8 years ago
Stephen, did the summary change in bug 594016 mean that we should remove the separators in tabs-on-bottom mode, too?
(In reply to comment #2)
> Stephen, did the summary change in bug 594016 mean that we should remove the
> separators in tabs-on-bottom mode, too?

Yes, I think we can remove these in both configurations.
(Assignee)

Comment 4

8 years ago
Created attachment 494137 [details] [diff] [review]
v1
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Attachment #494137 - Flags: review?(dao)
(Assignee)

Comment 5

8 years ago
Created attachment 494138 [details]
screenshot, tabs on top
Attachment #494138 - Flags: ui-review?(shorlander)
(Assignee)

Comment 6

8 years ago
Created attachment 494139 [details]
screenshot, tabs on bottom
Attachment #494139 - Flags: ui-review?(shorlander)
Attachment #494138 - Flags: ui-review?(shorlander) → ui-review+
Comment on attachment 494139 [details]
screenshot, tabs on bottom

Looks good, thank you! We might want to reduce the space between them but if so I will file a follow-up.
Attachment #494139 - Flags: ui-review?(shorlander) → ui-review+

Updated

8 years ago
Attachment #494137 - Flags: review?(dao) → review+
(Assignee)

Updated

8 years ago
Attachment #494137 - Flags: approval2.0?

Updated

8 years ago
Attachment #494137 - Flags: approval2.0? → approval2.0+
Keywords: checkin-needed
(Assignee)

Comment 8

8 years ago
Created attachment 498328 [details] [diff] [review]
for checkin
Attachment #494137 - Attachment is obsolete: true
(Assignee)

Comment 9

8 years ago
http://hg.mozilla.org/mozilla-central/rev/49a1b2aa43c5
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b9

Comment 10

8 years ago
may I say that the new pressed/hover states for those elements now looks kind of strange…
(In reply to comment #10)
> may I say that the new pressed/hover states for those elements now looks kind
> of strange…

I agree it looks strange now. I will file a followup bug.
(Assignee)

Comment 12

8 years ago
The inner shadow in the pressed state wasn't an intentional change and is not from this bug; it's only there because of unintentional selector specificity change and will be fixed in bug 620059.
You need to log in before you can comment on or make changes to this bug.