Last Comment Bug 544821 - [OS X] UI Refresh
: [OS X] UI Refresh
Status: RESOLVED FIXED
: meta
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Mac OS X
: -- enhancement with 6 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 544815 544816 544817 544818 546874 547787 559033 559034 571970 574090 578422 580965 583510 589219 594503 595908
Blocks: 544823
  Show dependency treegraph
 
Reported: 2010-02-07 21:12 PST by Stephen Horlander [:shorlander]
Modified: 2011-11-28 05:48 PST (History)
39 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
[Mockup] New Mac Theme (390.81 KB, image/png)
2010-02-07 21:12 PST, Stephen Horlander [:shorlander]
no flags Details

Description Stephen Horlander [:shorlander] 2010-02-07 21:12:20 PST
Created attachment 425753 [details]
[Mockup] New Mac Theme

The Mac theme revamp has most of the same considerations as the Windows theme revamp (Bug #544820)

* Tabs above the navigation bar will be default (Bug #544815)
* The Home button will not be needed on the toolbar because of the addition of the Home Tab (Bug #544819)
* The Bookmarks Bar will be hidden by default for new profiles and profiles that have never modified the default contents (Bug #544817)
* A Bookmarks Widget that replicates the Bookmarks Menu will be placed to the right of the Search Bar (Bug #544817)
* The Refresh and Stop buttons will merge with the Go button attached to the Location Bar (Bug #544816)
* The Bookmarks Star will move to the left of the Location Bar
* Site Identity will move to an element inside the Location Bar (Details are still in progress)

There will be new artwork required for most of the interface. Mockups covering variations can be found on the Wiki: https://wiki.mozilla.org/Firefox/4.0_Mac_Theme_Mockups

Notable design considerations:
				
Nothing sticks out since there is really only one theme on OS X to design around.

See attachment for mockup.
Comment 1 Tan Wei Lin Jason [:Ryuji] 2010-02-22 18:20:09 PST
Stephen, I heard that Firefox in Mac OS X will retain the classic menu in the design by default. However, I don't see it here in the mockup. Is it still retained in the design by default, or is it removed by default?
Comment 2 d 2010-02-22 22:11:56 PST
(In reply to comment #1)
> Stephen, I heard that Firefox in Mac OS X will retain the classic menu in the
> design by default. However, I don't see it here in the mockup. Is it still
> retained in the design by default, or is it removed by default?

If you mean the equivalent of the Windows "menu bar", there isn't really any option. It's a native OS feature and we have no reason not to take advantage of it. I'm not even sure if an app can remove it.
Comment 3 Aaron Train [:aaronmt] 2010-02-23 12:24:07 PST
Will there be a refresh on the search box for mac? For example, in the screenshot this looks like a bug and or out of place. In small button mode, everything is squared in chrome. The search box is curved and looks out of place, a remnant from 3.0.

Will the search box adjust to a user's customization preference?

https://wiki.mozilla.org/images/2/2b/Firefox-4-Mockup-i05-%28OSX%29-%28TabsTop%29-%28Small-Icons%29-%28Default%29.png
Comment 4 philippe (part-time) 2010-02-23 15:40:35 PST
(In reply to comment #3)
> Will there be a refresh on the search box for mac? For example, in the
> screenshot this looks like a bug and or out of place. In small button mode,
> everything is squared in chrome. The search box is curved and looks out of
> place, a remnant from 3.0.
> 
> Will the search box adjust to a user's customization preference?

Search boxes everywhere on OS X have round corners. I hope it stays that way in Firefox.
(In reply to comment #2)
> (In reply to comment #1)
>... It's a native OS feature and we have no reason not to take advantage of
> it. I'm not even sure if an app can remove it.

The menubar is a required component by Apple's HIG.
http://developer.apple.com/Mac/library/documentation/UserExperience/Conceptual/AppleHIGuidelines/XHIGMenus/XHIGMenus.html#//apple_ref/doc/uid/TP30000356-TPXREF103
Comment 5 Maaren 2010-03-11 00:55:59 PST
(In reply to comment #0)
> Created an attachment (id=425753) [details]
> [Mockup] New Mac Theme
> 
> * The Bookmarks Bar will be hidden by default for new profiles and profiles
> that have never modified the default contents (Bug #544817)

Brrrrh, it feels something 'naked' without one-click page loading
But if it has to be, so be it. Not I (and some others) am happy with it

But luckily there still is the All in One Sidebar extension that helps
Comment 6 d 2010-03-11 09:13:46 PST
(In reply to comment #5)
> (In reply to comment #0)
> > Created an attachment (id=425753) [details] [details]
> > [Mockup] New Mac Theme
> > 
> > * The Bookmarks Bar will be hidden by default for new profiles and profiles
> > that have never modified the default contents (Bug #544817)
> 
> Brrrrh, it feels something 'naked' without one-click page loading
> But if it has to be, so be it. Not I (and some others) am happy with it
> 
> But luckily there still is the All in One Sidebar extension that helps

It's only the default setting that is getting changed. The bookmarks bar will still be easy to "activate"/add, and it will remain for all current users. Only new installations/profiles are affected.
Comment 7 Tan Wei Lin Jason [:Ryuji] 2010-09-11 09:01:59 PDT
Will the Firefox button be included in the Firefox 4 on OS X?

Note You need to log in before you can comment on or make changes to this bug.