If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Minimize/Maximize/Close buttons missing when Firefox is in TabView

RESOLVED FIXED in Firefox 4.0b4

Status

Firefox Graveyard
Panorama
P2
normal
RESOLVED FIXED
7 years ago
a year ago

People

(Reporter: Ryuji, Assigned: fryn)

Tracking

Trunk
Firefox 4.0b4
x86
Windows 7
Dependency tree / graph

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100725 Minefield/4.0b3pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100725 Minefield/4.0b3pre

Tab Candy integrated in Firefox causes a number of problems like the missing Firefox Button in the "Visual Tab Interface" which cause problems like inability to go to History. 

Reproducible: Always
(Reporter)

Updated

7 years ago
Blocks: 581748
(Reporter)

Updated

7 years ago
Component: General → TabCandy
Product: Firefox → Mozilla Labs
Summary: Tab Candy in Firefox causes Firefox Button to be missing when in "Visual Tab Interface" → Tab Candy in Firefox causes Firefox Button to be missing when Firefox is in "Visual Tab Interface"
Target Milestone: --- → --
(Reporter)

Comment 1

7 years ago
Created attachment 460156 [details]
Missing Firefox button and Minimize, Restore Down and Close Buttons
(Reporter)

Updated

7 years ago
Summary: Tab Candy in Firefox causes Firefox Button to be missing when Firefox is in "Visual Tab Interface" → Tab Candy in Firefox causes The Entire Title Bar including Firefox Button to be missing when Firefox is in "Visual Tab Interface"
(Reporter)

Updated

7 years ago
Summary: Tab Candy in Firefox causes The Entire Title Bar including Firefox Button to be missing when Firefox is in "Visual Tab Interface" → Firefox with Tab Candy causes The Title Bar including Firefox Button to be missing when Firefox is in "Visual Tab Interface"
QA Contact: general → tabcandy

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

7 years ago
Duplicate of this bug: 586943

Updated

7 years ago
Blocks: 586788

Comment 3

7 years ago
This is only on Windows.
Assignee: nobody → fyan
Priority: -- → P2
Mass moving all Tab Candy bugs from Mozilla Labs to Firefox::Tab Candy.  Filter the bugmail spam with "tabcandymassmove".
Component: TabCandy → TabCandy
Product: Mozilla Labs → Firefox
Target Milestone: -- → ---
Version: unspecified → Trunk
(Assignee)

Comment 5

7 years ago
Making the Firefox button reappear is more complex, so moving that to a separate bug.
Summary: Firefox with Tab Candy causes The Title Bar including Firefox Button to be missing when Firefox is in "Visual Tab Interface" → Minimize/Maximize/Close buttons missing when Firefox is in TabView
(Assignee)

Comment 6

7 years ago
Created attachment 465927 [details] [diff] [review]
patch (leave space for the min/max/close buttons)

Simple patch to leave space for those buttons.

In the followup, which I soon will file, we'll bring back the Firefox button and menu in a non-hackish way.
Attachment #460156 - Attachment is obsolete: true
Attachment #465927 - Flags: review?(dolske)
Attachment #465927 - Flags: approval2.0?
Comment on attachment 465927 [details] [diff] [review]
patch (leave space for the min/max/close buttons)

Boo for hacks, yay for a tiny fix to make nightlies more pleasant. Please refer to the followup here when it's filed?
Attachment #465927 - Flags: review?(dolske)
Attachment #465927 - Flags: review+
Attachment #465927 - Flags: approval2.0?
Attachment #465927 - Flags: approval2.0+
(Assignee)

Comment 8

7 years ago
Followup for the Firefox button: https://bugzilla.mozilla.org/show_bug.cgi?id=587267
See Also: → bug 587267

Comment 9

7 years ago
http://hg.mozilla.org/mozilla-central/rev/6281bc7f1bbf
Give some margin to show the buttons even when in TabView.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b4

Updated

7 years ago
Blocks: 587267
See Also: bug 587267
(Assignee)

Comment 10

7 years ago
http://hg.mozilla.org/mozilla-central/rev/c14d91f2d939
Backed out as part of a large back out due to unrelated problems.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

7 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 11

7 years ago
http://hg.mozilla.org/mozilla-central/rev/5a8ef7a3fe86
Landed again. :)
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED

Comment 12

7 years ago
I checked if buttons show when uncheck menu bar in View>>Toolbars. Initially the minimize/restore/close buttons showed, then after using scrollbar  on page they disappeared. Bug 581820 is NOT RESOLVED.
(Assignee)

Comment 13

7 years ago
(In reply to comment #12)
> I checked if buttons show when uncheck menu bar in View>>Toolbars. Initially
> the minimize/restore/close buttons showed, then after using scrollbar  on page
> they disappeared. Bug 581820 is NOT RESOLVED.

I'll look into it.
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.