Last Comment Bug 582710 - Remove references to nonexistent IDs
: Remove references to nonexistent IDs
Status: RESOLVED FIXED
[good first bug]
:
Product: SeaMonkey
Classification: Client Software
Component: Help Documentation (show other bugs)
: Trunk
: All All
: -- minor (vote)
: seamonkey2.1a3
Assigned To: Edmund Wong (:ewong)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-28 12:37 PDT by Jens Hatlak (:InvisibleSmiley)
Modified: 2010-08-04 13:52 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
link check script (1.71 KB, text/plain)
2010-07-28 12:37 PDT, Jens Hatlak (:InvisibleSmiley)
no flags Details
Removed unused reference ids from help. [Checkin: comment 8] (6.66 KB, patch)
2010-08-04 07:06 PDT, Edmund Wong (:ewong)
jh: review+
Details | Diff | Review

Description Jens Hatlak (:InvisibleSmiley) 2010-07-28 12:37:55 PDT
Created attachment 460970 [details]
link check script

Help contains some references to IDs that do not exist (anymore):

cs_nav_prefs_navigator.xhtml:
  glossary.xhtml#live_bookmark
customize_help.xhtml
  using_priv_help.xhtml#cookie_notification
help-index1.rdf:
  using_priv_help.xhtml#cookie_notification
  cs_nav_prefs_navigator.xhtml#smart_browsing
help-win.rdf:
  cs_nav_prefs_advanced.xhtml#system
mail_help.xhtml:
  #disk_space_settings_blog
nav_help.xhtml:
  cs_nav_prefs_advanced.xhtml#system
suite-toc.rdf:
  using_priv_help.xhtml#cookie_notification
  using_priv_help.xhtml#level_of_privacy
  using_priv_help.xhtml#cookie_acceptance_policy
using_priv_help.xhtml:
  #cookie_notification

I'm attaching the PHP script that I used to find the above (it also found the intermittent regressions from mail_help.xhtml split bug 246405).
Comment 1 Edmund Wong (:ewong) 2010-08-01 19:32:33 PDT
(In reply to comment #0)
> customize_help.xhtml
>   using_priv_help.xhtml#cookie_notification


> help-index1.rdf:
>   using_priv_help.xhtml#cookie_notification
>   cs_nav_prefs_navigator.xhtml#smart_browsing
> help-win.rdf:
>   cs_nav_prefs_advanced.xhtml#system
> mail_help.xhtml:
>   #disk_space_settings_blog
> nav_help.xhtml:
>   cs_nav_prefs_advanced.xhtml#system
> suite-toc.rdf:
>   using_priv_help.xhtml#cookie_notification
>   using_priv_help.xhtml#level_of_privacy
>   using_priv_help.xhtml#cookie_acceptance_policy
> using_priv_help.xhtml:
>   #cookie_notification
> 
> I'm attaching the PHP script that I used to find the above (it also found the
> intermittent regressions from mail_help.xhtml split bug 246405).
Comment 2 Edmund Wong (:ewong) 2010-08-01 20:08:34 PDT
(Clicked save to fast.  Forgot to finish my commenting.)

> cs_nav_prefs_navigator.xhtml:
>   glossary.xhtml#live_bookmark

Since this is commented out in the actual xhtml file, 
I'm assuming it's no longer required/used?

> customize_help.xhtml
>   using_priv_help.xhtml#cookie_notification
> help-index1.rdf:
>   using_priv_help.xhtml#cookie_notification
> suite-toc.rdf:
>   using_priv_help.xhtml#cookie_notification
> using_priv_help.xhtml:
>   #cookie_notification

Wouldn't this help new users if a "Cookie Notification"
help text was included, instead of removing the reference?

> mail_help.xhtml:
>   #disk_space_settings_blog

s/blog/blogs/

> help-index1.rdf:
>   cs_nav_prefs_navigator.xhtml#smart_browsing

I can't find this in the current Seamonkey help(even though
I do recall seeing it somewhere).  Possible clarification
on its existence is appreciated.

> help-win.rdf:
>   cs_nav_prefs_advanced.xhtml#system
> nav_help.xhtml:
>   cs_nav_prefs_advanced.xhtml#system

I'm not exactly sure what this id #system refers to.
Is it "System integration" or something else?

> suite-toc.rdf:
>   using_priv_help.xhtml#level_of_privacy
>   using_priv_help.xhtml#cookie_acceptance_policy

I can't find these two references so I'm assuming these
two can be safely removed?  (Although I also recollect
seeing 'Cookie Acceptance Policy' somewhere.  Or has
it been renamed?)
Comment 3 Jens Hatlak (:InvisibleSmiley) 2010-08-02 13:04:32 PDT
(In reply to comment #2)
> > cs_nav_prefs_navigator.xhtml:
> >   glossary.xhtml#live_bookmark
>
> Since this is commented out in the actual xhtml file,

Ever since KaiRo introduced it in bug 421084.

> I'm assuming it's no longer required/used?

Effectively it's a TODO. We have almost complete feed support nowadays but Live Bookmarks are still missing since they depend on Places-based bookmarks. We should just file a follow-up Help bug for this (if none exists yet) and make it depend on Places-based bookmarks (bug 580660). This single thing should not block the rest of this bug.

> > customize_help.xhtml
> >   using_priv_help.xhtml#cookie_notification
> > help-index1.rdf:
> >   using_priv_help.xhtml#cookie_notification
> > suite-toc.rdf:
> >   using_priv_help.xhtml#cookie_notification
> > using_priv_help.xhtml:
> >   #cookie_notification
>
> Wouldn't this help new users if a "Cookie Notification"
> help text was included, instead of removing the reference?

This was actually removed by fault (or at least without correcting the references) in bug 459607. See the following link for what was there before:

http://hg.mozilla.org/comm-central/diff/128427913295/suite/locales/en-US/chrome/common/help/using_priv_help.xhtml

You can use that as a base but need to check how the notification works today. I think it's a notification bar, but maybe not in all cases. The icon might still be there. If you think it gets too complex you may file a new bug for this, including the above explanation.

> > mail_help.xhtml:
> >   #disk_space_settings_blog
>
> s/blog/blogs/

Good catch, but it actually needs to be mailnews_account_settings.xhtml#disk_space_settings_blogs now. Cf. bug 246405 (you might want to watch that one / CC yourself to it).

> > help-index1.rdf:
> >   cs_nav_prefs_navigator.xhtml#smart_browsing
>
> I can't find this in the current Seamonkey help(even though
> I do recall seeing it somewhere).  Possible clarification
> on its existence is appreciated.

Left over from bug 411226 which replaced the Smart Browsing preferences panel by the Location Bar one. The changes were:

http://bonsai.mozilla.org/cvsview2.cgi?command=DIFF&subdir=mozilla%2Fsuite%2Flocales%2Fen-US%2Fchrome%2Fcommon%2Fhelp&file=cs_nav_prefs_navigator.xhtml&rev1=1.42&rev2=1.43&whitespace_mode=show&diff_mode=context

> > help-win.rdf:
> >   cs_nav_prefs_advanced.xhtml#system
> > nav_help.xhtml:
> >   cs_nav_prefs_advanced.xhtml#system
>
> I'm not exactly sure what this id #system refers to.
> Is it "System integration" or something else?

That was referring to the Advanced/System preferences panel that was removed as part of bug 364168:

http://hg.mozilla.org/comm-central/rev/94c0142a32ac

Just kill it.

> > suite-toc.rdf:
> >   using_priv_help.xhtml#level_of_privacy
> >   using_priv_help.xhtml#cookie_acceptance_policy
>
> I can't find these two references so I'm assuming these
> two can be safely removed?  (Although I also recollect
> seeing 'Cookie Acceptance Policy' somewhere.  Or has
> it been renamed?)

See above, was removed as part of P3P Privacy Settings bug 459607.

Just kill it.

FYI: It took even me, who knows how to use MXR and what has been going on with SeaMonkey, two hours to gather the above information. As you can see the relevant information is scattered around different places, due to the history of the project (Mozilla1.8 for SeaMonkey 1.x, Seamonkey for CVS-based SeaMonkey 1.5 trunk, and comm-central for SeaMonkey 2.x). You can also see that some things are left behind when reviews are done quickly as part of broader bugs (e.g. changing UI / preferences panels). That's why I prefer separate Help bugs and reviewers taking the time to check carefully (which doesn't mean it actually needs to take much time!).

Once you have a patch ready, feel free to request review from me. Thanks for looking into this!
Comment 4 Edmund Wong (:ewong) 2010-08-03 07:09:51 PDT
(In reply to comment #3)

> > I'm assuming it's no longer required/used?
> 
> Effectively it's a TODO. We have almost complete feed support nowadays but Live
> Bookmarks are still missing since they depend on Places-based bookmarks. We
> should just file a follow-up Help bug for this (if none exists yet) and make it
> depend on Places-based bookmarks (bug 580660). This single thing should not
> block the rest of this bug.

I filed bug # 584037.

> 
> > > customize_help.xhtml
> > >   using_priv_help.xhtml#cookie_notification
> > > help-index1.rdf:
> > >   using_priv_help.xhtml#cookie_notification
> > > suite-toc.rdf:
> > >   using_priv_help.xhtml#cookie_notification
> > > using_priv_help.xhtml:
> > >   #cookie_notification
> >
> > Wouldn't this help new users if a "Cookie Notification"
> > help text was included, instead of removing the reference?
> 
> This was actually removed by fault (or at least without correcting the
> references) in bug 459607. See the following link for what was there before:
> 
> http://hg.mozilla.org/comm-central/diff/128427913295/suite/locales/en-US/chrome/common/help/using_priv_help.xhtml
> 
> You can use that as a base but need to check how the notification works today.
> I think it's a notification bar, but maybe not in all cases. The icon might
> still be there. If you think it gets too complex you may file a new bug for
> this, including the above explanation.

Not too sure of the complexity here.  It looks ok, just needs to be 
updated.   I'm a bit hazy on the privacy notification bar.

> 
> > > mail_help.xhtml:
> > >   #disk_space_settings_blog
> >
> > s/blog/blogs/
> 
> Good catch, but it actually needs to be
> mailnews_account_settings.xhtml#disk_space_settings_blogs now. Cf. bug 246405
> (you might want to watch that one / CC yourself to it).

Ah, didn't catch the whole thing.  

> 
> Left over from bug 411226 which replaced the Smart Browsing preferences panel
> by the Location Bar one. The changes were:
> 
> http://bonsai.mozilla.org/cvsview2.cgi?command=DIFF&subdir=mozilla%2Fsuite%2Flocales%2Fen-US%2Fchrome%2Fcommon%2Fhelp&file=cs_nav_prefs_navigator.xhtml&rev1=1.42&rev2=1.43&whitespace_mode=show&diff_mode=context

So I'm taking this means it's to be removed.

> 
> > > help-win.rdf:
> > >   cs_nav_prefs_advanced.xhtml#system
> > > nav_help.xhtml:
> > >   cs_nav_prefs_advanced.xhtml#system
> >
> > I'm not exactly sure what this id #system refers to.
> > Is it "System integration" or something else?
> 
> That was referring to the Advanced/System preferences panel that was removed as
> part of bug 364168:
> 
> http://hg.mozilla.org/comm-central/rev/94c0142a32ac
> 
> Just kill it.
> 
> > > suite-toc.rdf:
> > >   using_priv_help.xhtml#level_of_privacy
> > >   using_priv_help.xhtml#cookie_acceptance_policy
> >
> > I can't find these two references so I'm assuming these
> > two can be safely removed?  (Although I also recollect
> > seeing 'Cookie Acceptance Policy' somewhere.  Or has
> > it been renamed?)
> 
> See above, was removed as part of P3P Privacy Settings bug 459607.
> 
> Just kill it.

These will be removed in the patch.

> 
> FYI: It took even me, who knows how to use MXR and what has been going on with
> SeaMonkey, two hours to gather the above information. As you can see the
> relevant information is scattered around different places, due to the history
> of the project (Mozilla1.8 for SeaMonkey 1.x, Seamonkey for CVS-based SeaMonkey
> 1.5 trunk, and comm-central for SeaMonkey 2.x). You can also see that some
> things are left behind when reviews are done quickly as part of broader bugs
> (e.g. changing UI / preferences panels). That's why I prefer separate Help bugs
> and reviewers taking the time to check carefully (which doesn't mean it
> actually needs to take much time!).

When I look at the amount of information and the way things are linked,
I'm reminded of the oft used term 'spaghetti code'.  The twists and turns
confused me a bit.
Comment 5 Edmund Wong (:ewong) 2010-08-04 07:04:05 PDT
(In reply to comment #3)
> > > customize_help.xhtml
> > >   using_priv_help.xhtml#cookie_notification
> > > help-index1.rdf:
> > >   using_priv_help.xhtml#cookie_notification
> > > suite-toc.rdf:
> > >   using_priv_help.xhtml#cookie_notification
> > > using_priv_help.xhtml:
> > >   #cookie_notification
> >
> > Wouldn't this help new users if a "Cookie Notification"
> > help text was included, instead of removing the reference?
> 
> This was actually removed by fault (or at least without correcting the
> references) in bug 459607. See the following link for what was there before:
> 
> http://hg.mozilla.org/comm-central/diff/128427913295/suite/locales/en-US/chrome/common/help/using_priv_help.xhtml
> 
> You can use that as a base but need to check how the notification works today.
> I think it's a notification bar, but maybe not in all cases. The icon might
> still be there. If you think it gets too complex you may file a new bug for
> this, including the above explanation.
> 

I'm a little over my head with this.  Separating this to a new bug
(bug# 584352) to make it easier to sort out.
Comment 6 Edmund Wong (:ewong) 2010-08-04 07:06:19 PDT
Created attachment 462763 [details] [diff] [review]
Removed unused reference ids from help. [Checkin: comment 8]
Comment 7 Edmund Wong (:ewong) 2010-08-04 07:08:34 PDT
Comment on attachment 462763 [details] [diff] [review]
Removed unused reference ids from help. [Checkin: comment 8]

Also changed the mail_help's reference of #disk_space_settings_blog to
"mailnews_account_settings.xhtml#disk_space_settings_blogs.
Comment 8 Jens Hatlak (:InvisibleSmiley) 2010-08-04 10:54:10 PDT
Comment on attachment 462763 [details] [diff] [review]
Removed unused reference ids from help. [Checkin: comment 8]

http://hg.mozilla.org/comm-central/rev/e2afe65879f6

Thanks!
Comment 9 Vlado Valastiak [:wladow] @ Mozilla.sk 2010-08-04 13:07:51 PDT
Comment on attachment 462763 [details] [diff] [review]
Removed unused reference ids from help. [Checkin: comment 8]

>--- a/suite/locales/en-US/chrome/common/help/nav_help.xhtml
>+++ b/suite/locales/en-US/chrome/common/help/nav_help.xhtml
>@@ -1468,21 +1468,16 @@
>       settings in Preferences. To learn how to set &brandShortName; as the
>       default browser through &brandShortName; preferences, see
>       <a href="cs_nav_prefs_navigator.xhtml#navigator">Browser Preferences -
>       Browser</a>.</p>
> 
>     <h3 id="customizing_default_browser_settings">Customizing Default Browser
>       Settings</h3>
> 
>-    <p>You can manually customize how &brandShortName; handles various file
>-      formats and protocols. For more information, see
>-      <a href="cs_nav_prefs_advanced.xhtml#system">Advanced Preferences -
>-      System</a>.</p>
>-
>     <p>[<a href="#improving_speed_and_efficiency">Return to beginning of
>       section</a>]</p>
> </div>

You probably should remove the h3 above as well.
Comment 10 Jens Hatlak (:InvisibleSmiley) 2010-08-04 13:52:18 PDT
(In reply to comment #9)
> >     <h3 id="customizing_default_browser_settings">Customizing Default Browser
> >       Settings</h3>
> > 
> >-    <p>You can manually customize how &brandShortName; handles various file
> >-      formats and protocols. For more information, see
> >-      <a href="cs_nav_prefs_advanced.xhtml#system">Advanced Preferences -
> >-      System</a>.</p>
> >-
> >     <p>[<a href="#improving_speed_and_efficiency">Return to beginning of
> >       section</a>]</p>
> > </div>
> 
> You probably should remove the h3 above as well.

Err, yes. The ID is not used elsewhere so I just fixed it directly:

http://hg.mozilla.org/comm-central/rev/c1a641be960d

Thanks!

Note You need to log in before you can comment on or make changes to this bug.