Status

()

defect
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: zpao, Assigned: mconnor)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 beta4+)

Details

Attachments

(1 attachment)

Assignee: nobody → paul
blocking2.0: --- → beta3+
Comment on attachment 461660 [details] [diff] [review]
Patch v0.1

Ted - not sure if you're the one or if Dolske can do it, but you were my best guess.
Attachment #461660 - Flags: review?(ted.mielczarek)
Comment on attachment 461660 [details] [diff] [review]
Patch v0.1

r+, with the (obvious) caveat that this only lands once we've finished our sanity testing tomorrow.
Attachment #461660 - Flags: review?(ted.mielczarek) → review+
The mobile guys are seeing assertions fail in nsURLHelper.cpp when MOZ_SERVICES_SYNC=1 is turned on (bug 580508). Not a hard blocker I guess but would be good to fix before we land.
Depends on: 580508
(In reply to comment #3)
> The mobile guys are seeing assertions fail in nsURLHelper.cpp when
> MOZ_SERVICES_SYNC=1 is turned on (bug 580508). Not a hard blocker I guess but
> would be good to fix before we land.

Ah yes. I had seen that but everything worked so I forgot to file it. Looks like we could poke biesi to review that ASAP.
Depends on: 583846
Depends on: 583885
Depends on: 583949
Landed http://hg.mozilla.org/mozilla-central/rev/029f8bd8d06a

Fingers crossed that it sticks.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Sadtimes, backed out (disabled).

The debug builders ("Bd") were orange due to Rlk > 0, looks like we missed this from the try pushes with everything else going on. There are some other oranges that may or may not be related, we'll look in the morning.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Not actually backed out, because hg is broken and the push failed. See bug 584001. We've killed the nightlies while this gets sorted out.)
Reenabled this morning for in-tree debugging with http://hg.mozilla.org/mozilla-central/rev/f6a4fd52d468

Disabled now, again, in http://hg.mozilla.org/mozilla-central/rev/b35930e655d5, to ensure availability of  a checkpoint (plus some other, unrealated, bugs to land after) for a no-Sync Beta 3.
I don't think we can switch Sync on for Beta 3 with the number and size of performance regressions. Can we get a summary of those regressions listed here and bugs filed on fixing them?
blocking2.0: beta3+ → beta4+
Is there a status update on this? Also, as this bug seems to be *the* sync-on bug, are the dependencies set up correctly?
(In reply to comment #11)
> Is there a status update on this?

We're working on plugging the leaks and are investigating the talos regressions.

> Also, as this bug seems to be *the* sync-on bug, are the dependencies set up correctly?

I'm tracking dependencies for the next merge in bug 584481 which in turn is a dependency of this bug.
Assignee: paul → mconnor
Just down to the front-end fix for the Ts regressions.
Status: REOPENED → ASSIGNED
Depends on: 586094
http://hg.mozilla.org/mozilla-central/rev/8b618223ad69
Status: ASSIGNED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.