Closed Bug 583435 Opened 13 years ago Closed 10 years ago

Control/Command Click in Tabcandy should select multiple tabs (shift-click should select a range)

Categories

(Firefox Graveyard :: Panorama, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: athomps, Unassigned)

References

Details

(Whiteboard: [aza])

User-Agent:       Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b3pre) Gecko/20100729 Minefield/4.0b3pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b3pre) Gecko/20100729 Minefield/4.0b3pre

Tabcandy should allow you to select multiple tabs in its overview mode for further manipulation (I'm thinking of dragging into new tab groups but there might be other things to do with multiple selected tab groups).

This should happen in the same intuitive manner as click-selecting on a desktop or file manager - control/command-click should select an additional item and add it to the select group, and shift-click should select the range from the last-selected item to the just-shift-clicked item.

Reproducible: Always

Steps to Reproduce:
1. Click on the tabcandy icon ("Open a visual tab interface")
2. Control- or command-click one tab

Actual Results:  
The tab expands to be the current page.

Expected Results:  
Expected the tab to change color or something to indicate that it was part of a selection group, at which point I was going to control/command/shift click to add one or more tabs to the selection group and then drag them off into a new tab group.
Assigning to aza for the desired behaviours.
Assignee: nobody → aza
OS: Windows XP → All
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mass moving all Tab Candy bugs from Mozilla Labs to Firefox::Tab Candy.  Filter the bugmail spam with "tabcandymassmove".
Product: Mozilla Labs → Firefox
Target Milestone: -- → ---
Version: unspecified → Trunk
QA Contact: tabcandy → tabcandy
Punting to the future.
Severity: normal → enhancement
Hardware: x86 → All
Target Milestone: --- → Future
How far is the future? I thought Panorama was made with people with "tab guilt" in mind, and these are the exact people that have dozens of tabs open. Right now the only way to move those dozens of tabs between groups is one by one, which is uhmm.... inaccessible?
Rimas, hopefully in a dot release after Firefox 4.
Assignee: aza → nobody
Whiteboard: [aza]
bugspam

(Fx7 was branched, removing open bugs from Fx7 meta bug, we won't create new meta bugs for upcoming Fx versions)
No longer blocks: 660175
I'm voting for this enhancement, but I'd also like to propose the ability to select multiple tabs by click-and-dragging a rectangle around it like in Windows Explorer etc. (there must be a better term for this functionality...).
(In reply to Caitlin from comment #10)
> I'm voting for this enhancement, but I'd also like to propose the ability to
> select multiple tabs by click-and-dragging a rectangle around it like in
> Windows Explorer etc. (there must be a better term for this
> functionality...).

I completely agree on both points.  
(I've always called it "multi-select", but "drag-select" may be a more descriptive / specific term (I think the former is a superset of the latter)).  

IMO, functionality like this is required for Tab Candy (or Panorama / Tab Groups ) to be useful as a feature.  While the ability to visually organize your tabs spatially is great, not having the ability to select multiple tabs kind of defeats the purpose of this tool IMO (this is a tool to make it *easier* to organize a *large* # of tabs, is it not?).  This makes it only marginally better than just using Tab Mix Plus (TMP) + Session Manager, and dragging-and-dropping unrelated tabs into a new window to save off as a separate window session.  

On a side note, I notice there's another bug currently open (https://bugzilla.mozilla.org/show_bug.cgi?id=566510) that seems to be pretty similar to this one but I don't think it specifically deals with Tab Groups though.
I'm voting too for this enhancement, it's a basic need to reorganise multiple tabs and we're stock to the one-by-one drag-and-drop, imagine doing the same in your files explorer : we need the same behavior.
Very important IMO, and surprised it's not already there. It is not only important to move multiple tabs from one group to another, but even to reposition in one group. Many times, I want to multi-select all the 'entertainment tabs' at once, and drag them to the beginning of the group (so that my Ctrl+1, Ctrl+2 work on them) and all the work tabs are open towards the end. 

Also, it will be a lot easier to just close multiple tabs by selecting them from the tab group display together, than clicking those small close buttons and waiting for the tabs to rearrange themselves before closing the next one.
Agreed, Tab Groups are fundamentally flawed without tab multi-select.  I'm surprised the Tab Groups feature was introduced at all without it.
Panorama was introduced with FF 4, now we're in FF 20; is this feature still only a forlorn wishlist item? Why can FF Showcase (the addon) do what FF itself (currently still) cannot?
They're removing it: bug_836758
Since in two months they only reached as far, as "we have to remove it somehow that automatically installs the addon version to those who have it enabled", it might take a while.
(In reply to avada from comment #16)
> They're removing it: bug_836758
> Since in two months they only reached as far, as "we have to remove it
> somehow that automatically installs the addon version to those who have it
> enabled", it might take a while.

True, it's not a big priority at the moment.
We're going to remove Panorama in bug 836758 and might reconsider this feature after the transition has finished.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.