Add .<Lanka> and .<Ilangai> to IDN whitelist

RESOLVED FIXED

Status

()

Core
Networking: Domain Lists
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: gerv, Assigned: gerv)

Tracking

({verified1.9.2})

Trunk
verified1.9.2
Points:
---

Firefox Tracking Flags

(firefox5?, status2.0 .x-fixed, status1.9.2 .18-fixed, status1.9.1 .20-fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Hello,

This is Sarves from LKNIC, Sri Lanka.

ICANN has approved our .ලංකා and .இலங்கை IDNs and now we have started issues these domains.

For your information : http://www.icann.org/en/announcements/announcement-4-23mar10-en.htm
Our NIC site - www.nic.lk

Could you please enable .ලංකා and .இலங்கை TLDs in Firefox and other Mozilla products.

We also have localised versions of Firefox in Sinhala and Tamil (Sri Lanka). Please enable these IDNs in those localised versions too.

Thanks
Sarves


-- 

K. Sarveswaran
Systems Engineer
LK Domain Registry

c/o Department of Computer Science and Engineering
University of Moratuwa
Sri Lanka

Mob   : +94-77-224-4192
Office : +94-11-421-6061
Fax     : +94-11-265-0912
Web   : http://www.nic.lk 


Gerv's note: These are .xn--fzc2c9e2c and .xn--xkc2al3hye2a.

The first step in meeting this request is checking their character lists and homograph policy.

Gerv

Comment 1

7 years ago
I haven't found a document on http://www.nic.lk that explains what characters are allowed in domain names (.lk, .ලංකා and .இலங்கை) and what are not.

Comment 2

7 years ago
I will reach out to Gihan (admin) about Sarves' request and see if they have their list of allowed characters defined yet, and let them know to provide it.

Comment 3

7 years ago
Yes we have a allowed character list. without defining that we would not have passed ICANN's string evaluation phase.
I will post the list tomorrow after getting the consent from Prof. Gihan Dias. 

fyi :
http://www.icann.org/en/minutes/resolutions-05aug10-en.htm#2.c.i
(Assignee)

Updated

7 years ago
Depends on: 576508
(Assignee)

Updated

7 years ago
No longer depends on: 576508
(Assignee)

Comment 4

7 years ago
Sarves: are you able to show us a public copy of the character list?

Gerv
(Assignee)

Comment 5

7 years ago
Sarves: this bug is waiting for input from you; no progress can be made without an answer to the question in comment #4.

Gerv
(Assignee)

Comment 6

7 years ago
Resolved INCOMPLETE due to no input from registry. Please reopen when the character list is available.

Gerv
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
Duplicate of this bug: 633165
Reopening per bug 633165.
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
(Assignee)

Comment 9

6 years ago
Here's their policy: http://www.nic.lk/index.php/en/idn-policy . Looks good to me; I don't see significant homographs, and they bundle ZWJ.

Gerv
(Assignee)

Comment 10

6 years ago
Created attachment 519699 [details] [diff] [review]
Patch v.1
Assignee: nobody → gerv
Status: REOPENED → ASSIGNED
(Assignee)

Comment 11

6 years ago
http://hg.mozilla.org/mozilla-central/rev/fbb3643ddf68

Gerv
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Attachment #519699 - Flags: approval2.0?
Attachment #519699 - Flags: approval1.9.2.18?
Attachment #519699 - Flags: approval1.9.1.20?

Comment 12

6 years ago
Many thanks to the team!

Comment 13

6 years ago
Just a further note:
We still need to update the IDN Enabled list
http://www.mozilla.org/projects/security/tld-idn-policy-list.html
with two entries,  .xn--fzc2c9e2c and .xn--xkc2al3hye2a.

The Registry URL is: http://nic.lk
The Policy URL is: http://www.nic.lk/index.php/en/idn-policy

I am on an IDN Panel with Sarves at the upcoming ICANN meeting in Singapore, and I'd like to make the changes to the web page so that they are included there as well.
Comment on attachment 519699 [details] [diff] [review]
Patch v.1

Approved for 1.9.2.18 and 1.9.1.20, a=dveditz for release-drivers
Approved for the mozilla2.0 repository, a=dveditz for release-drivers
Attachment #519699 - Flags: approval2.0?
Attachment #519699 - Flags: approval2.0+
Attachment #519699 - Flags: approval1.9.2.18?
Attachment #519699 - Flags: approval1.9.2.18+
Attachment #519699 - Flags: approval1.9.1.20?
Attachment #519699 - Flags: approval1.9.1.20+
Blocks: 661291
Filed bug 661291 on the website task in comment 13 so it's not forgotten.
(Assignee)

Comment 16

6 years ago
http://hg.mozilla.org/releases/mozilla-2.0/rev/2428433c7d4f
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/da591258bd0d
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/7424b1e94070

Gerv
status1.9.1: --- → .20-fixed
status1.9.2: --- → .18-fixed
status2.0: --- → .x-fixed
Verified for 1.9.2.18 by verifying checkin in source.
Keywords: verified1.9.2

Comment 18

6 years ago
Today I tried with Firefox 5. Still I see that both IDNs are not white-listed. 
I installed the Firefox 5 Tamil version. Will that be an issue?

Sarves
(Assignee)

Comment 19

6 years ago
Sarves: can you give a link to an example domain which doesn't work? I can't find any registered domains under either TLD using Google's site-specific search.

Gerv

Comment 20

6 years ago
Gerv : We have many government sites and cooperate sites with IDN. Please see some of them :

தளம்.அரசு.இலங்கை
தளம்.ஆள்களமையம்.இலங்கை
தளம்.லக்செயலிகள்.இலங்கை
தளம்.லக்செயலிகள்.இலங்கை
தளம்.தகவல்.அரசு.இலங்கை
தளம்.பாராளுமன்றம்.இலங்கை

වෙබ්.රජය.ලංකා
වෙබ්.ලක්වසම.ලංකා
වෙබ්.ලක්යෙදුම්.ලංකා
වෙබ්.තොරතුරු.රජය.ලංකා
වෙබ්.පාර්ලිමේන්තුව.ලංකා
I am not sure why Google does not point to any of these. 
I checked about:config on Firefox 5, however I do not see that .lanka (.xn--fzc2c9e2c) and .ilangai (.xn--xkc2al3hye2a) are whitelisted.
Thanks, Sarves
(Assignee)

Comment 21

6 years ago
Hmm. Yes, I missed a branch :-( I checked it in on trunk, 4.0, 3.6 and 3.5 but missed 5.0.

I'm not totally sure how to nominate it now, and whether there is any follow-up release planned on the 5.0 branch, but let's try setting this flag.

Gerv
tracking-firefox5: --- → ?

Comment 22

6 years ago
leaving this nominated for tracking 5 until we know if we're doing a 5 respin/chemspill. if we don't do a chemspill 5.0.x, we'll minus this when we ship 6.
(Assignee)

Comment 23

6 years ago
Asa: dveditz policy with older branches is to permit checkins of bugs like this, and if it turns out that we never ship, then no harm done. See comment 14 for an example - we have no plans to ship again off 1.9.1. 

Is the policy different for more recent branches?

Gerv

Comment 24

6 years ago
Gerv, yeah. New policy because we've got an entirely different build set-up for the new channels system.
You need to log in before you can comment on or make changes to this bug.