Last Comment Bug 576508 - PSL update rollup
: PSL update rollup
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking: Domain Lists (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Gervase Markham [:gerv]
:
: Patrick McManus [:mcmanus]
Mentors:
: 589751 (view as bug list)
Depends on: 598911 608362 614565
Blocks: 428944 570692 571433 576827 579195 580132 580152 584992 593818
  Show dependency treegraph
 
Reported: 2010-07-02 06:39 PDT by Gervase Markham [:gerv]
Modified: 2010-12-09 15:40 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.11-fixed
.14-fixed


Attachments
Captures all IDN ccTLD approved by ICANN Board to date; Updates a number of ccTLDs and stubs, adds contributor (4.48 KB, patch)
2010-08-11 23:35 PDT, Jothan Frakes
gerv: review+
Details | Diff | Splinter Review
all.js / IDNTLD Updates - Captures all IDN ccTLD approved by ICANN Board to date; Updates a number of ccTLDs and stubs, adds contributor (2.40 KB, patch)
2010-08-11 23:39 PDT, Jothan Frakes
no flags Details | Diff | Splinter Review
Patch v.2 (11.73 KB, patch)
2010-09-13 07:38 PDT, Gervase Markham [:gerv]
mbeltzner: approval2.0+
dveditz: approval1.9.2.11+
dveditz: approval1.9.1.14+
Details | Diff | Splinter Review

Description Gervase Markham [:gerv] 2010-07-02 06:39:09 PDT
There are a load which ICANN has approved here:
http://www.icann.org/en/topics/idn/fast-track/string-evaluation-completion-en.htm

They all need to be added to the PSL, so Chrome can navigate to them (isn't that right?), even if they don't have any substructure.

Gerv
Comment 1 Jothan Frakes 2010-08-11 23:35:14 PDT
Created attachment 465139 [details] [diff] [review]
Captures all IDN ccTLD approved by ICANN Board to date; Updates a number of ccTLDs and stubs, adds contributor

Patch covers bugs 580147, 580148, 580152, 564213, 575610, 576508, 576827, 580132, 580161, 580162, 584989, 584991, 584992
Comment 2 Jothan Frakes 2010-08-11 23:39:18 PDT
Created attachment 465142 [details] [diff] [review]
all.js / IDNTLD Updates - Captures all IDN ccTLD approved by ICANN Board to date; Updates a number of ccTLDs and stubs, adds contributor

This updates the IDN TLD list to catch it up to date with the Currently Approved By Board List of IDN TLDs.  It also adds .CC which follows exactly the .COM/NET IDN.

Addresses bugs: 580147, 580148, 580152, 564213, 575610, 576508
576827, 580132, 580161, 580162, 584989, 584991, 584992
Comment 3 Gervase Markham [:gerv] 2010-08-12 03:29:42 PDT
Hi Jothan, 

This is great work! 

One tip: if you put the word "bug" in front of every bug number in a comment, Bugzilla will autolinkify them all, which makes looking at them much easier. I've now added them to the Blocks list, so there will also be links to them at the top.

For the IDN TLD whitelist updates, we need documentation of the registry character list and anti-spoofing policy for each. I know you are working on obtaining this information. It would probably be easiest if you did this documentation by also providing a patch to this page:
http://www.mozilla.org/projects/security/tld-idn-policy-list.html
giving the relevant URLs.
That page is stored in a Mozilla Subversion repository.
http://viewvc.svn.mozilla.org/vc/projects/mozilla.org/trunk/

Gerv
Comment 4 Gervase Markham [:gerv] 2010-08-12 03:34:29 PDT
Comment on attachment 465139 [details] [diff] [review]
Captures all IDN ccTLD approved by ICANN Board to date; Updates a number of ccTLDs and stubs, adds contributor

r=gerv with the exception of the addition of com.lu, which doesn't seem to have either a bug number or an explanation.

Gerv
Comment 5 Jo Hermans 2010-08-23 02:26:51 PDT
*** Bug 589751 has been marked as a duplicate of this bug. ***
Comment 6 Gervase Markham [:gerv] 2010-09-06 08:31:29 PDT
Hey chaps,

What's the status here? For the PSL, we need a new patch without the change I review minused. For the all.js, we need the docs I mentioned.

Gerv
Comment 7 Gervase Markham [:gerv] 2010-09-13 07:04:19 PDT
Comment on attachment 465142 [details] [diff] [review]
all.js / IDNTLD Updates - Captures all IDN ccTLD approved by ICANN Board to date; Updates a number of ccTLDs and stubs, adds contributor

Let's just focus on PSL stuff in this bug.

Gerv
Comment 8 Gervase Markham [:gerv] 2010-09-13 07:38:32 PDT
Created attachment 474690 [details] [diff] [review]
Patch v.2

Roll-up of all current PSL entry bugs (as in the dependencies).

Gerv
Comment 9 Gervase Markham [:gerv] 2010-09-13 07:41:03 PDT
Comment on attachment 474690 [details] [diff] [review]
Patch v.2

Requesting approval-2.0, as the tree is currently metered. This patch is a rollup of all the pending changes to the Public Suffix List over the past few months.

Gerv
Comment 10 Mike Beltzner [:beltzner, not reading bugmail] 2010-09-14 07:43:05 PDT
Comment on attachment 474690 [details] [diff] [review]
Patch v.2

a=beltzner
Comment 11 Gervase Markham [:gerv] 2010-09-15 09:10:58 PDT
Fixed on trunk.
http://hg.mozilla.org/mozilla-central/rev/14dc66dd53c1

Gerv
Comment 12 Gervase Markham [:gerv] 2010-09-16 02:23:57 PDT
This got backed out due to a failing test.

Gerv
Comment 13 Gervase Markham [:gerv] 2010-09-17 02:50:21 PDT
Really fixed this time.
http://hg.mozilla.org/mozilla-central/rev/248ea690d671

Gerv
Comment 14 Gervase Markham [:gerv] 2010-09-20 05:50:48 PDT
Comment on attachment 474690 [details] [diff] [review]
Patch v.2

Requesting branch approvals.

Gerv
Comment 15 Daniel Veditz [:dveditz] 2010-09-24 10:55:53 PDT
Comment on attachment 474690 [details] [diff] [review]
Patch v.2

Approved for 1.9.2.11 and 1.9.1.14, a=dveditz
Comment 16 Jo Hermans 2010-09-24 13:48:00 PDT
Eh ... part of this patch (blogspot.com) was invalidated by bug 598911
Comment 18 Gervase Markham [:gerv] 2010-09-28 03:58:25 PDT
(And yes, I removed blogspot.com before committing.)

Gerv
Comment 19 Daniel Veditz [:dveditz] 2010-11-29 15:12:59 PST
Broke the Hawaii DOE, bug 614565

Note You need to log in before you can comment on or make changes to this bug.