Closed Bug 589864 Opened 10 years ago Closed 10 years ago

Silverlight flickering when scrolling and hide popup

Categories

(Core :: Plug-ins, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- beta5+

People

(Reporter: alice0775, Assigned: cjones)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre)
Gecko/20100823 Minefield/4.0b5pre ID:20100823055515
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre)
Gecko/20100823 Minefield/4.0b5pre ID:20100823055515

Silverlight flickering when scrolling and hide popup

Looks like Bug 589437, but it is flash player.


Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open URL ( http://www.microsoft.com/japan/silverlight/default.aspx )
3. Click star icon and hide popup or Click App button and hide popup. OR Scroll page

Actual Results:
 Silverlight flickering 

Expected Results:
 Should not.

Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/4192ba38ebee
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100819
Minefield/4.0b5pre ID:20100820130619
Fails:
http://hg.mozilla.org/mozilla-central/rev/95a39e236cc4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100820
Minefield/4.0b5pre ID:20100820131417
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4192ba38ebee&tochange=95a39e236cc4
Candidate bug:
Bug 582057 - Replace platforms widgets in content processes with cross-platform
fake widgets
jimm, I remember a bug we fixed like this a while back. Do remember what caused it or how cjones regressed here?
Assignee: nobody → jones.chris.g
If it's bug 582057 that caused this, it's likely something dumb like a virtual call going to the wrong target or an if going to the wrong branch; those patches were supposed to be only refactorings.
Probably a dupe of the same for flash (bug 589437).

Silverlight oopp drawing bugs: bug 558434, bug 542897
Bisection says the culprit is http://hg.mozilla.org/mozilla-central/rev/7852880685f8.  (I'm testing with flash, but it's got to be the same bug.)
The problem was that clipChildren/clipSiblings aren't default in nsWidgetInitData, and a middle refactoring patch lost setting those to non-default.
Attachment #468572 - Flags: review?(roc)
Bad regression, we want this ASAP.
Hm, missed flipping the <select>.
blocking2.0: --- → ?
blocking2.0: ? → beta5+
http://hg.mozilla.org/mozilla-central/rev/1d3d0dd88f0d
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Duplicate of this bug: 589437
Duplicate of this bug: 589966
Followup for test failure
http://hg.mozilla.org/mozilla-central/rev/9a623cc1c5e7

(Didn't tryserver the original patch because it wouldn't have made tomorrow's nightly if I did.  Sorry.)
Blocks: 589966
Duplicate of this bug: 590087
You need to log in before you can comment on or make changes to this bug.