Closed Bug 590342 Opened 13 years ago Closed 12 years ago

[D2D] Some drivers make text unusually blurry

Categories

(Core :: Graphics, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
blocking2.0 --- -

People

(Reporter: joe, Unassigned)

References

()

Details

Attachments

(2 files)

Some drivers make all text blurry - see bug 587953 comment 15. We think that the hotfix that Microsoft forces on users with IE9 platform preview 4, linked in the URL field, will help with this, because it changes the way text is rasterized.
I don't think this hotfix applies to BUG: 587953, as the only thing with the blurry text is Minefield.
This issue is similar to what Visual Studio 2010 betas were experiencing. Although the platform is WPF, they use direct write APIs to control rendering.

Some WPF related technical details (including the workarounds implemented) are available in the following links:

http://stackoverflow.com/questions/2659700/visual-studio-2010-blurry-font

http://windowsclient.net/wpf/white-papers/wpftextclarity.aspx
(In reply to comment #2)

Here also is interesting, particularly 'Dennis's comment: http://blogs.msdn.com/b/llobo/archive/2009/10/21/new-wpf-features-textformattingmode-for-clear-text.aspx

He seems to describe them switching to DWRITE_MEASURING_MODE_GDI_NATURAL for 'smaller' fonts (I assume 15pt and less like in the article) with DWRITE_MEASURING_MODE_NATURAL still used in other cases. His wording is basically the same as the msdn docs http://msdn.microsoft.com/en-us/library/dd368133%28v=VS.85%29.aspx

In light of this, and the fact that this patch doesn't appear to have made any obvious changes, I still see the same issues in Firefox, IE9 preview, Steam e.t.c., I would speculate that IE might well be planning these same changes.

So is this achievable for firefox?
Blocks: 594325
I definitely see this too.
blocking2.0: --- → ?
I'd like to know if this is NVidia only, or is anyone also seeing this with ATI?
gfx.direct2d.disabled is a g-d send for this issue. With that set the text is no longer blurry (obviously). I am using NVidia though...
This has no relationship to the "aliasing" issue; this is drivers totally screwing over text.

Natch, can you attach screenshots as to what you're seeing to aid in determining the blocking status?
No longer blocks: 594325
Notice also that some text is out of place (I see this on drudge right now as well) because of font size differences, although I don't think that's this bug.
Oh, and make sure the images are full-size when viewing them, otherwise the blurriness isn't as obvious.
OK, that's not this bug. This bug is not subtle; what you're seeing is just DirectWrite rasterizing differences.
blocking2.0: ? → -
(In reply to comment #7)
> I'd like to know if this is NVidia only, or is anyone also seeing this with
> ATI?

When I had an ATI 5870 in this machine, text was very blurry until I turned down the anisotropic filtering to the lowest setting.
@Joe Drew: Are you saying that this is not a bug? This definitely is a usability issue. If I view my webpage (which uses Trebuchet MS 16px) I hardly can read the "w"s, because they are so blurred. This should actually block 2.0. If a browser can't render text, that's a serious problem.
I have not had to set Anisotropic Filtering in the NVCP to disabled or per app for Firefox, Steam, GameSpy Comrade or IE9 since NVD Release 197.

The Anisotropic filtering setting no longer has a negative effect on any of these applications since Release 197 Drivers.

There is no obvious setting in the nvidia profiles database that disables Af automatically that i can see, but something has changed in the driver in how it applies settings to DirectWrite/Direct2D.
Not true, it still happens on Win7 64bit with newest 266.44 drivers.

Use hardware acceleration when available = DISABLED
http://img577.imageshack.us/img577/829/offv.png

Use hardware acceleration when available = ENABLED with anisotropic filtering set to OFF
http://img689.imageshack.us/img689/6909/onanizooff.png

Use hardware acceleration when available = ENABLED with anisotropic filtering set to x2
http://img291.imageshack.us/img291/2374/onanizo2x.png

Use hardware acceleration when available = ENABLED with anisotropic filtering set to x16
http://img156.imageshack.us/img156/5602/onanizo16x.png



Also this like dupe of bug #549419
thats not blur, its the result of no cleartype colour bleeding.
Hmm, but still this looks like dupe of bug #549419...
And didn't this should block Fx4, because drivers have enabled AF by default ?
Can we close this ?
D2D & D3D is disabled when you have old version of drivers.
Sounds good to me.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.