Hide menu-bar persona drawing when in Panorama

RESOLVED INVALID

Status

defect
P3
trivial
RESOLVED INVALID
9 years ago
3 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

unspecified
Future
All
macOS
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [visual][polish][good first bug])

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b5pre) Gecko/20100824 Minefield/4.0b5pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b5pre) Gecko/20100824 Minefield/4.0b5pre

since in panorama only the top-bar is visible(mac only?), the lightweight-theme looks rather strange, therefore hide it, when entering panorama, on exit show it again.

Reproducible: Always

Comment 1

9 years ago
Additional information:
On Windows XP SP3 only the Titlebar is visible, and the new firefox button on the left and the persona does not change anything there (no strange look).
(Reporter)

Comment 2

9 years ago
afaik. it's not possible to draw in the titlebar in XP. so this might only be an osx-issue.

added a partial-screenshot to illustrate the point.
(Reporter)

Comment 3

9 years ago
Posted image partial-screenshot

Comment 4

9 years ago
Ok, will try that with windows 7 and post results here.

Comment 5

9 years ago
On Windows 7 there is the same issue, though i do not think that it's ugly.
Priority: -- → P4

Updated

9 years ago
Priority: P4 → P2
Target Milestone: --- → Firefox 4.0

Updated

9 years ago
Hardware: x86 → All
Summary: hide persona in panorama → Hide menu-bar persona drawing when in Panorama
Assignee: nobody → raymond
Priority: P2 → P3
Blocks: 585689
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: raymond → anant
This patch disables a persona (if selected) when switching to panorama mode, and also setting it back to what it was before when the user exits.

The reason we use the LightweightThemeManager instead of just saying:

documentElement.removeAttribute("drawintitlebar");

is because: a) that will not work on Windows 7, and b) we want to be future-proof and it's best not to make any assumptions about how the theme manager paints a persona on the window.
Attachment #487744 - Flags: feedback?(ian)
Status: NEW → ASSIGNED
Comment on attachment 487744 [details] [diff] [review]
Disable persona when in panorama

Looks good to me!
Attachment #487744 - Flags: feedback?(ian) → feedback+
Comment on attachment 487744 [details] [diff] [review]
Disable persona when in panorama

If there are multiple Firefox windows, this will affect all of them. Also if you exit Firefox during that time, this looks like the theme won't be reactivated.

Comment 10

9 years ago
Continuing to reassign all Anant's bugs to Raymond.
Assignee: anant → raymond
Status: ASSIGNED → NEW
Moving to beta 10, but unless someone takes this up soon, we most likely will punt.
Blocks: 627096
No longer blocks: 585689
Whiteboard: [visual][polish][good first bug]
Target Milestone: Firefox 4.0 → ---
(In reply to comment #11)
> Moving to beta 10, but unless someone takes this up soon, we most likely will
> punt.

Er, beta 11, is what I meant.
Alex, Stephen: should we be continuing on this bug (hiding the menu bar persona drawing on Mac) or instead should we pursue some persona support for Panorama as we did for Windows in bug 591652?
[bugspam: mitcho's late-night betaN triage; feel free to comment or reverse]
Assignee: raymond → nobody
Blocks: 603789
No longer blocks: 627096
Keywords: uiwanted
Target Milestone: --- → Future
>or instead should we pursue some persona support for Panorama
>as we did for Windows in bug 591652?

yeah, I think we should try the windows approach here, and also push on getting personas updated to be as full screen as possible.
Keywords: uiwanted
(In reply to comment #15)
> >or instead should we pursue some persona support for Panorama
> >as we did for Windows in bug 591652?
> 
> yeah, I think we should try the windows approach here, and also push on getting
> personas updated to be as full screen as possible.

The Windows fix in bug 591652 assumes some constant height, if I recall. It won't just be a matter of getting people to make their panoramas full screen. Some thought will have to go into this, imho.

Going to file a couple follow ups and close this bug.
Filed followups: bug 593388, bug 633392.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.