Closed Bug 590470 Opened 12 years ago Closed 7 years ago

show "tabs from other computers" in Panorama

Categories

(Firefox Graveyard :: Panorama, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: GeekShadow, Unassigned)

References

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b4) Gecko/20100818 Firefox/4.0b4
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b4) Gecko/20100818 Firefox/4.0b4

Ability to see group of tabs openened in other Firefox synced (tabs from Firefox Mobile for example).

Reproducible: Always
The idea is to show tabs from about:sync-tabs in the panorama view.
Ian, will the new groups.js work provide APIs for injecting groups from external sources?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Integrate TabCandy with Sync → Integrate "tabs from other computers" into Panorama
Version: unspecified → Trunk
Summary: Integrate "tabs from other computers" into Panorama → show "tabs from other computers" in Panorama
Punting to the future. This would also be a good place for an add-on to step in.
Target Milestone: --- → Future
Attached patch v1, WIPSplinter Review
Hey, I created a 'small' patch for this feature. It's working quite nice for me with two mobile devices. But there's still some room for improvement and we should discuss the behaviour of these weave-synced groups (I call them WeaveGroups for now :).

1) WeaveGroups should be closeable/hideable. But once they're closed we must keep track of them and they should not popup again on every sync (as they do now). But there must be a way to get them back, too.

2) Should tabs be closeable? The group as a whole should be immutable since afaik Weave is readonly. What happens if we drag tabs to another group? Should it be possible to create new tabs in WeaveGroups? There are several ways via Strg+T, clicking on 'New Tab' button at the bottom or dragging and droppping a tab from another group.

3) What must be done when Weave devices disappear or the WeaveGroup goes empty? Shall tabs be removed when they're closed on the device? These tabs could be in use and should not just be closed.


There are many more questions left. I do really like and want this feature and was quite wondered that this has not been implemented, yet. I'm looking forward to any feedback :)
Assignee: nobody → tim.taubert
Attachment #500511 - Flags: feedback?(ian)
Comment on attachment 500511 [details] [diff] [review]
v1, WIP

The approach looks good (though I'm not familiar with sync). This seems too risky a feature for this close to release, however; it opens up a whole new realm of potential bugs, and we're not solid yet with the features we do support. I propose we shelve this until after ff4.0.
Attachment #500511 - Flags: feedback?(ian) → feedback-
I'm totally ok with this and agree with you. This feature just sounded really interesting and I wanted to know how hard it can be to implement this. Thanks for your feedback and I'm looking forward to when we can address this issue (probably some months from now).
Looks like all the APIs are available to do this as an add-on. That would be a great way to prove out the concept and get the code in place.
Assignee: tim.taubert → nobody
Blocks: 603789
No longer blocks: 603789
anyone want this on ff5 ?
will this be implemented?
This is currently not a priority and won't be implemented in the near future. This could definitely be done as an add-on to prototype this kind of functionality.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.