Open Bug 593471 Opened 9 years ago Updated 8 years ago

Properly handle eTransparencyTransparent windows with D3D9

Categories

(Core :: Graphics, defect)

x86
Windows 7
defect
Not set

Tracking

()

People

(Reporter: jrmuizel, Unassigned)

References

Details

Attachments

(1 obsolete file)

Currently we just use the BasicLayerManager for windows of this type. We need to figure out what the right thing to do here is and do it.
Attachment #471965 - Flags: review?(vladimir)
Comment on attachment 471965 [details] [diff] [review]
Don't use D3D9 for transparent windows

r=me with explicit mUseAcceleratedRendering = PR_FALSE, since otherwise we may end up picking up the GL layer manager.
Attachment #471965 - Flags: review?(vladimir) → review+
No longer blocks: d3d9-layers
http://hg.mozilla.org/mozilla-central/rev/aefc9fe57f22
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 593534
No longer blocks: 593534
Whoops - the patch here was uploaded to the wrong bug initially. That patch actually fixed bug 593438.
Attachment #471965 - Attachment is obsolete: true
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → NEW
Jeff still thinks we should do this.
You need to log in before you can comment on or make changes to this bug.