Closed Bug 593634 Opened 11 years ago Closed 6 years ago

Sort collections in 'Add to Collection' dropdown alphabetically

Categories

(addons.mozilla.org Graveyard :: Collections, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
2015-09-10

People

(Reporter: aryx, Assigned: zuzel.vp, Mentored)

Details

(Whiteboard: [good first bug])

Attachments

(2 files)

Sort collections in 'Add to Collection' dropdown alphabetically. With >20 collections, it's a pain to find the one you need.
Update: At the moment, it seems as the collections created after the zamboni switch are sorted alphabetically (and below 'My Favorites') while the older ones are unsorted above.
I'm marking this as a good first bug because I think it's a 1 line change to a template.
Whiteboard: [good first bug]
Target Milestone: --- → 4.x (triaged)
The problem is that the collections are listed alphabetically based on the URL, NOT the collection name.
The problem is that the collections are listed alphabetically based on the URL, NOT the collection name.
This STOPPED Working altogether and now seem to list seemingly randomly.
PLEASE FIX! Still present!

Was fixed before but now broken again. I think it should be a VERY easy fix.
The following was opened in Oct 2013 to deal with this as it is NOT tied to FF v4 as above. This applies to ALL versions as it is a addons.mozilla.org website issue. 

https://bugzilla.mozilla.org/show_bug.cgi?id=931131

This stopped working in 2011, was fixed in 2011, then stopped working again in 2013. 

Without this fix, it is very cumbersome to work with collections. Please fix. (see attachments for examples)
Hi. I would like to start working on this bug as a part of my assignment at school. I have already downloaded and built source code, but now I have a problem with finding the source code realted to this bug. Can please someone help me where to find it? :-) Thank you.
I am interested in this bug as being my first bug while I am in the Ascend Project.  I have found the code at https://github.com/mozilla/olympia and the installation instructions here: http://olympia.readthedocs.org/en/latest/topics/install-olympia/index.html (thank you for linking to it!) and will set up a development environment to be able to test sorting the collections in the dropdown.  Am I on the right track?
(In reply to HeartSongPurple from comment #12)
> I am interested in this bug as being my first bug while I am in the Ascend
> Project.  I have found the code at https://github.com/mozilla/olympia and
> the installation instructions here:
> http://olympia.readthedocs.org/en/latest/topics/install-olympia/index.html
> (thank you for linking to it!) and will set up a development environment to
> be able to test sorting the collections in the dropdown.  Am I on the right
> track?

You're doing great.  Come join us in #amo on irc.mozilla.org to chat.  Cheers.
Other Bug identical/related to this with lots of details:
https://bugzilla.mozilla.org/show_bug.cgi?id=931131


BTW, if you are so inclined, there are a few other areas dealing with sorting that need attention. Here is the breakdown:

Sorting "Collections I've Made" & "Collections I'm Following"
https://bugzilla.mozilla.org/show_bug.cgi?id=931136
See sorting options already available in "About This Collection" view. 

Sorting in the Edit Collection view under the tab "Add-ons"
https://bugzilla.mozilla.org/show_bug.cgi?id=507331
https://bugzilla.mozilla.org/show_bug.cgi?id=857318
https://bugzilla.mozilla.org/show_bug.cgi?id=546002
https://bugzilla.mozilla.org/show_bug.cgi?id=706166


Sorting search results when Searching Collections
https://bugzilla.mozilla.org/show_bug.cgi?id=598694
https://bugzilla.mozilla.org/show_bug.cgi?id=685562
It would be nice if the sort options in all Collection views were synced. See sorting options already available in "About This Collection" view. Also synced with Extensions view.
Assigning this to Carmen while she works on it during the Ascend Project. She's actively working on a patch this week and next.
Assignee: nobody → carmencordis
Mathieu:

I followed the instructions on http://olympia.readthedocs.org/en/latest/topics/install-olympia/installation.html to set up my local virtual environment for Olympia, and I just got clarification from the Ascend Project teachers that it is currently working!  We set up a local server for Ascend, so the Olympia server is only the second time I have ever set up a server.

Originally, my Celery in RabbitMQ was failing, so I wanted to try the docker setup.

As I was going through your docker instructions for the Quickstart version, when I ran `fig run web make initialize_db` in my Terminal (inside the virtual environment) I got the error “could not find fig.yml.  Are you in the right directory?”  I wasn't sure what to do from here.

Then it occurred to me that I might have been following multiple sets of instructions for getting the server to work.

Nevertheless, eventually running `./manage.py runserver` made the server work!

However, my current issue is that, after I created the first super-user in my Terminal, I could not grant myself administrator privileges.

Running `./manage.py activate_user --set-admin <my email address>` with my email inside the brackets returns a very long error mentioning Raven and “Celery Fail”, as well as many other things I do not understand.

Since I can't activate my admin user on the local server to start collecting Add-Ons on the Mozilla Add-Ons site, I cannot yet move forward with fixing my bug and testing the patch.

Do you have any suggestions for things I can check to make the super-user work?  Thank you!
Flags: needinfo?(mathieu)
hi HeartSongPurple,

It would be very helpful to have the traceback (the long error) pasted somewhere for me to have a look (you can use https://dpaste.de for example). This should help me understand what the issue is. Also, if you could paste your settings.py file and local_settings.py file, that would help!

The issue you have with docker is, from what I can see, fixed by moving to the folder containing the fig.yml file, which is in the root folder of olympia. If it's not there at all in your virtual environment, it could be because there's some issues with "mounting" (sharing) folders with boot2docker from what I understand. I'm sorry I can't help much with that as I don't have windows nor mac, and so don't use boot2docker.
Flags: needinfo?(mathieu)
Thank you, Mathieu!  I will try to run the environment without using boot2docker at the moment.

It's taken some time but I have identified the traceback errors for making my database, making my super-user, and trying to activate the super-user.

The error messages, my settings.py file, and my local_settings.py file are all pasted to this link:

https://dpaste.de/wG7r

On my local version of Add-Ons, whenever I try to log in with my user, I get an error that says, "Oops!  Not allowed.  You tried to do something you weren't allowed to."  I'm not sure what to do when I see an error like this.
Ah, I see the error: you don't have an elasticsearch installed (or it's not started): https://dpaste.de/wG7r#L257

Elasticsearch shouldn't be too hard to install: http://olympia.readthedocs.org/en/latest/topics/install-olympia/elasticsearch.html

There isn't a detailed installation breakdown in this doc, so here it is:
1/ download https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.2.deb
2/ install it: "sudo dpkg -i elasticsearch-1.3.2.deb"
3/ it should now be installed, you can check by going to http://localhost:9200

Note that you also need "memcached" installed (so that would be "sudo apt install memcached").


Once it's installed, you could maybe run "initialize_db" again, and see if it's better?


When you try to log in, or go on any page, if you  have a "oops! not allowed" kind of error, please check the console for the logs, as they may provide some information on what's happening.


I'm really sorry all this is such a pain at the moment, I hope that boot2docker will work better very soon, and that we'll have a docker based install that works in a few commands.
Carmen, are you still working on that bug or should I reset the assignee?
I suppose we can reset the assignee.

magopian, would you want to mentor this?
Assignee: carmencordis → nobody
It seems :arch could mentor this as well.

First come, first serve!
Hey guys
 I'm interested in working on this bug.  Just let me know what I have to do and I'll get to it.
Travus, sorry for the delay.

Aryx or magopian, could one of you step up and guide Travus for this bug? Thanks!
Flags: needinfo?(mathieu)
Flags: needinfo?(archaeopteryx)
Hi,

I'm at a work week at the moment, so I won't be very responsive until next week, but still, I think I could help out whenever you have questions.

I'd advise starting of by installing olympia locally to be able to reproduce the issue, and then test the fix: http://olympia.readthedocs.org/en/latest/#quickstart

Once you have that running, I would start looking at the following line: https://github.com/mozilla/olympia/blob/master/apps/bandwagon/views.py#L373

This is the view that's used by the ajax request that is done when you click on the "add to collection" link, to fill in the full list of collections. I believe that if you manage to order the collections here, it should fix your issue.

Let me know if you have any questions!
Mentor: mathieu
Flags: needinfo?(mathieu)
Flags: needinfo?(aryx.bugmail)
Thanks for your contribution!
Assignee: nobody → zuzel.vp
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: 4.x (triaged) → 2015-09-10
Verified as fixed on AMO-dev FF40(Win 7).
Postfix screenshot: http://screencast.com/t/kntIBXI0S
Closing bug.
Status: RESOLVED → VERIFIED
I just checked using FF 16.0.2 and Chrome 44.0.2403.157 on Mac everything still looks as before and the problem still persists  :-(
(In reply to smayer97 from comment #29)
> I just checked using FF 16.0.2 and Chrome 44.0.2403.157 on Mac everything
> still looks as before and the problem still persists  :-(

Did you check on AMO-dev or AMO-prod? Because the fix did not land on production yet.
I've checked on MAC, too, using latest Chrome and Safari, and all seems fixed. (http://screencast.com/t/YFxz86UUT)
Sorry, no I did not...thought it was moved to production already. cheers
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.