Last Comment Bug 594299 - (d3d9-layers)inFlasher doesn't flash
: (d3d9-layers)inFlasher doesn't flash
Status: RESOLVED INVALID
: regression
Product: Other Applications
Classification: Client Software
Component: DOM Inspector (show other bugs)
: Trunk
: x86 Windows 7
: -- normal with 1 vote (vote)
: mozilla2.0
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 670893 740355 (view as bug list)
Depends on:
Blocks: d3d9-layers
  Show dependency treegraph
 
Reported: 2010-09-08 02:20 PDT by Alice0775 White
Modified: 2014-06-11 13:36 PDT (History)
18 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
-


Attachments

Description Alice0775 White 2010-09-08 02:20:51 PDT
Build Identifier: Mozilla/5.0 (Windows torNT 6.1; WOW64; rv:2.0b6pre)
Gecko/20100907 Firefox/4.0b6pre ID:20100907041859

inIFlasher doesn't flash.
If I set layers.accelerate-all to false, it works.


Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Install DOM inspector ( https://addons.mozilla.org/ja/firefox/addon/6622/ )
3. Inspect any element

Actual Results:
 inIFlasher doesn't flash

Graphics

Adapter Description: ATI Radeon HD 4300/4500 Series
Vendor ID: 1002
Device ID: 954f
Adapter RAM: 512
Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag
atidxx32 atiumdva atiumd6a atitmm64
Driver Version: 8.762.0.0
Driver Date: 8-3-2010
Direct2D Enabled: true
DirectWrite Enabled: true
GPU Accelerated Layers Enabled: 1/1  Direct3D 9
Comment 1 Alice0775 White 2010-09-09 10:08:18 PDT
According to https://wiki.mozilla.org/Platform/2010-09-07#Firefox_Development,
Implement of Inspector was dropped from Firefox 4.

So, I think this should be fixed before release of Firefox4.
Comment 2 Colby Russell :crussell (no longer Mozilla-ing) 2010-09-09 10:55:29 PDT
Eh?  Two things:
a) The devtools inspector (https://wiki.mozilla.org/Firefox/Projects/Inspector) uses a different method for its highlighter; it's not inFlasher.
b) Even if it were the case that the devtools inspector did use inFlasher, the fact that it was dropped from Firefox 4 would imply that this shouldn't be blocking, *not* that it should be...

*** This bug has been marked as a duplicate of bug 368608 ***
Comment 3 Shawn Wilsher :sdwilsh 2010-09-09 10:57:00 PDT
(In reply to comment #2)
> Eh?  Two things:
> a) The devtools inspector (https://wiki.mozilla.org/Firefox/Projects/Inspector)
> uses a different method for its highlighter; it's not inFlasher.
> b) Even if it were the case that the devtools inspector did use inFlasher, the
> fact that it was dropped from Firefox 4 would imply that this shouldn't be
> blocking, *not* that it should be...
Note that this is new breakage on a platform that inIFlasher actually worked on - windows.  This isn't really the same as bug 368608.
Comment 4 Colby Russell :crussell (no longer Mozilla-ing) 2010-09-09 10:58:57 PDT
(In reply to comment #3)
> Note that this is new breakage on a platform that inIFlasher actually worked on
> - windows.  This isn't really the same as bug 368608.

The effect is the same though, right?  "Rewrite DOM Inspector's flasher"?  The platform fields for that bug are already All/All.
Comment 5 Shawn Wilsher :sdwilsh 2010-09-09 11:02:21 PDT
(In reply to comment #4)
> The effect is the same though, right?  "Rewrite DOM Inspector's flasher"?  The
> platform fields for that bug are already All/All.
It's not clear to me that that is the case.
Comment 6 Alice0775 White 2010-09-09 11:14:37 PDT
This is about Extention DOMi's  blinking feature.

I think this is not bug 368608 completely.
Because, Blinking of DOMi works before enabling D3D9.
And It still works if I disabled D3D9.
Comment 7 Alice0775 White 2010-10-15 06:37:48 PDT
This is regression, 
is this block 2.0?
Comment 8 Andrew 2011-07-12 10:47:20 PDT
*** Bug 670893 has been marked as a duplicate of this bug. ***
Comment 9 Phillip 2011-08-05 07:01:57 PDT
Has this been fixed in nightly builds or preview releases?

I can confirm that unchecking "User hardware acceleration when available" is a workaround if blinking is not working. My video card is NVIDIA GeForce 9500 GS. I am developing a web application that heavily utilizes Canvas and SVG so I would much prefer not to have to disable hardware acceleration. Is there are less drastic workaround?
Comment 10 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-07-31 14:19:14 PDT
*** Bug 740355 has been marked as a duplicate of this bug. ***
Comment 11 Alice0775 White 2014-06-11 13:36:17 PDT
Flasher in DOMi was rewrited in Nightly 33.0a1

So, this bug is obsoleted.
Comment 12 Alice0775 White 2014-06-11 13:36:57 PDT
s/rewrited/rewritten/

Note You need to log in before you can comment on or make changes to this bug.