Closed Bug 595533 Opened 9 years ago Closed 9 years ago

Characters are sometimes ignored when typing a filter search very fast

Categories

(Firefox Graveyard :: Panorama, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 4.0

People

(Reporter: sylvain.pasche, Assigned: raymondlee)

References

Details

Attachments

(1 file, 1 obsolete file)

If you open Panorama and type two or more characters very quickly, the second typed character is sometimes ignored. So if you type "abc", you may end up with a search for "ac". I'm seeing this on Windows and I couldn't reproduce in my Linux vm.
Priority: -- → P2
Duplicate of this bug: 594971
OS: Windows 7 → All
Hardware: x86 → All
Assignee: nobody → seanedunn
My guess is that this is because the input box hasn't received focus yet.
Priority: P2 → P3
Target Milestone: --- → Firefox 4.0
This is a data-loss issue (although not a very bad one). I'm bumping it up to beta 8 because I think it is a quick win.
Blocks: 597043
No longer blocks: 592045
Assigning to Anant, assuming Sean hasn't started work on it.
Assignee: seanedunn → anant
This works for me on my windows 7 with latest nightly build.  Sylvain: do you still see the issue?
No, works for me too now (Windows 7).

Can anyone test on Linux?
I spoke too soon. I can still reproduce the issue on my laptop (Windows 7 too). There might be something hardware/driver related that makes it reproducible or not.
I am unable to reproduce the issue either on Windows 7 or Mac OS X. I tried typing as fast as I could! Likely to be a driver / hardware specific issue.
Yes, it has to do with the CPU speed of your machine. Grab a crappy netbook and you should be able to repro it no problem.
Another way to reproduce (even if you have a fast machine) is to open a lot of tabs. With 50 open tabs I can see the issue easily.
Note that the patch for bug 597399 changes from using keydown to using keypress... perhaps this will allow us to get rid of the setTimeout in ensureSearchShown, which is probably what's causing this bug.
Duplicate of this bug: 611385
I can confirm that the setTimeout in ensureSearchShown is causing the issue. Do you remember why it's needed? I tried to remove it and it seems to still work fine on Windows and Linux. The attached extension patches ensureSearchShown to remove the setTimout.
Moving over to Raymond
Assignee: anant → raymond
Attached patch v1Splinter Review
Attachment #490121 - Attachment is obsolete: true
Attachment #496739 - Flags: review?(ian)
Status: NEW → ASSIGNED
Moving to b9
Blocks: 598154
No longer blocks: 597043
Comment on attachment 496739 [details] [diff] [review]
v1

Raymond, the patch looks fine, but it's going to conflict with bug 610821 (specifically "Patch for tabview v1.0"); let's hold off on this until that one lands.
Attachment #496739 - Flags: review?(ian) → review-
Depends on: 610821
(In reply to comment #17)
> Comment on attachment 496739 [details] [diff] [review]
> v1
> 
> Raymond, the patch looks fine, but it's going to conflict with bug 610821
> (specifically "Patch for tabview v1.0"); let's hold off on this until that one
> lands.

It looks like the "Patch for tabview v1.0" would also fix this because it removes the setTimeout() in the  ensureSearchShown().
bugspam (moving b9 to b10)
Blocks: 608028
bugspam (removing b9)
No longer blocks: 598154
Bug 610821 also fixes this.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
verified with nightly build of minefield.
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.