Last Comment Bug 595723 - If Thunderbird is the default client for e-mail, newsgroups and feeds, the dialog only shows that Thunderbird is the default client for e-mail
: If Thunderbird is the default client for e-mail, newsgroups and feeds, the di...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Preferences (show other bugs)
: 3.1
: All All
: -- minor (vote)
: Thunderbird 18.0
Assigned To: :aceman
:
Mentors:
Depends on:
Blocks: 804001
  Show dependency treegraph
 
Reported: 2010-09-12 15:20 PDT by Chas Belov
Modified: 2012-10-21 11:09 PDT (History)
7 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch (3.21 KB, patch)
2012-09-27 11:26 PDT, :aceman
mconley: review+
bwinton: ui‑review+
Details | Diff | Review

Description Chas Belov 2010-09-12 15:20:11 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9
Build Identifier: Thunderbird/3.1.3

If I go to Thunderbird > Preferences > Advanced > General, and click Check Now:

If Thunderbird is the default client for e-mail, newsgroups and feeds:

Actual behavior: I get a message that Thunderbird is the default client for e-mail.

Expected behavior: I get the dialog that shows that Thunderbird is the default client for e-mail, newsgroups and feeds.

Reproducible: Always

Steps to Reproduce:
1. (Mac OS X) Thunderbird > Preferences > Advanced > General
2. Click Check Now.
3. If you get a dialog that shows one or more  unchecked, clickable checkboxes for e-mail, newsgroups or feeds, check those boxes and click OK; otherwise, skip to results.
4. Click Check Now.
Actual Results:  
Get the message Thunderbird is already set as your default e-mail client.

Expected Results:  
(given Thunderbird 3.1.3): Get the dialog with the three check boxes for e-mail, newsgroups and feeds.
Comment 1 Javi Rueda 2012-09-25 12:16:58 PDT
Confirming on Linux also.

When Thunderbird is instructed to become the default application to manage e-mail, newsgroups and RSS feeds, when retrying to check that, an alert is shown that shows that thunderbird is the default "email client".

I flag it as "minor" because there is more code needed to improve the string. There could be some kind of UI change also, something like showing just a tick near the "Check now" button.
Comment 2 :aceman 2012-09-27 02:19:34 PDT
OK, this should be easy.
It only needs a decision:

1. The string shown is defined here: http://mxr.mozilla.org/comm-central/source/mail/locales/en-US/chrome/messenger/preferences/preferences.properties#66, it only mentions "mail" but is really shown only when TB is set for all of mail,news and rss. Should the string be updated?

2. OR, drop the redundant string and just show the integration dialog where the user will see that all of mail, news and rss is checked. This is more future-proof I think.
Comment 3 Blake Winton (:bwinton) (:☕️) (PTO 'til London. Find me there for quick answers!) 2012-09-27 07:57:10 PDT
I like the future-proof-ness of #2, can you whip up a patch, or a mockup, so that I can see how it'll look?  (And mark it "f? :bwinton"…)
Comment 4 :aceman 2012-09-27 08:22:41 PDT
#2 is even better in case unsetting the default client gets implemented in the far future (bug 254262), then showing the integration dialog will become necessary.
Comment 5 :aceman 2012-09-27 11:26:48 PDT
Created attachment 665560 [details] [diff] [review]
patch

This is variant 2.
Comment 6 Blake Winton (:bwinton) (:☕️) (PTO 'til London. Find me there for quick answers!) 2012-10-01 10:25:10 PDT
Comment on attachment 665560 [details] [diff] [review]
patch

Yeah, I think this is better.  ui-r=me.

(My only final request would be some way to let the user know why the checkboxes are disabled, perhaps a tooltip, or a popup on click, or something…)

Thanks,
Blake.
Comment 7 :aceman 2012-10-01 11:07:06 PDT
Bwinton, the "WHY" is bug 360809 and I don't think you accepted any of those options yet ;)
Comment 8 Blake Winton (:bwinton) (:☕️) (PTO 'til London. Find me there for quick answers!) 2012-10-01 11:26:51 PDT
aceman: Fixed.  ;)
Comment 9 Mike Conley (:mconley) - (Away until June 29th) 2012-10-03 12:52:22 PDT
Comment on attachment 665560 [details] [diff] [review]
patch

Review of attachment 665560 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good! Thanks aceman!
Comment 10 Ryan VanderMeulen [:RyanVM] 2012-10-03 14:59:36 PDT
https://hg.mozilla.org/comm-central/rev/015c837754c7

Note You need to log in before you can comment on or make changes to this bug.