Closed Bug 597404 Opened 9 years ago Closed 9 years ago

History sync: Null id for anno! (invalid uri)

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: philikon, Assigned: philikon)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

There have been reports of history sync failing because of this exception, thrown by Utils.anno() when the URI that was passed is null. It looks like there's an edge case where places provides an invalid or null URI and we don't handle it gracefully. If anything we could do better error reporting here.
Duplicate of this bug: 602461
Duplicate of this bug: 602619
Hello I join this bug. (Installed 1.5). I'd like a lot to use Sync well.  Hoping to get a good fix soon. Just as a last trial I deleted Firefox history and now sync works.
Duplicate of this bug: 602414
Duplicate of this bug: 602933
Duplicate of this bug: 603439
i do not understand the explanation? what to do? what does this mean? please clarify what to do about fixing the problem? I unchecked history in sync and it seems to work, but that doesn't seem to be mentioned here? again what to do about fixing this? is it a bug that can be fixed ?
Attached patch wallpaper v1Splinter Review
Here's a wallpaper patch that makes the history engine handle invalid URIs in the places DB gracefully. Wallpaper because this doesn't fix the root cause, though I'm not even sure Sync could do anything about the root cause. Hopefully with the logging in place we'll be able to collect some data on these URIs.
Assignee: nobody → philipp
Attachment #482928 - Flags: review?(mconnor)
Comment on attachment 482928 [details] [diff] [review]
wallpaper v1

r=me, please land on branch and trunk.
Attachment #482928 - Flags: review?(mconnor) → review+
default: http://hg.mozilla.org/services/fx-sync/rev/34a11e14b033
1.5.x: http://hg.mozilla.org/services/fx-sync/rev/81dc17f317ad
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Blocks: 603388
Whiteboard: [qa-]
Duplicate of this bug: 608530
Flags: in-testsuite?
Hopefully this is the right place to put this:  Sync still does not work on one of my computers.

Works on P4 Win XP 32 bit. 3.6.12
Does not work on AMD 4-core Win7 64 bit.  3.6.12

Tried disconnect, connect. sync now.  Tray message says "Error While Syncing".  Does not show "Last Update:..." on mouse-over like the XP machine.

My background is in midrange database systems, so I won't be much help in debugging on my own.  But, I can usually follow instructions with only minor casualties.
This may look like the same error. Latest sync 1.6.1

Could not create URI: Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsIIOService.newURI] Stack trace: Weave_makeURI()@util.js:1000 < HistStore_update()@history.js:359 < HistStore_create()@history.js:340 < Store_applyIncoming()@stores.js:66 < anonymous()@engines.js:486 < innerBind()@util.js:1381 < anonymous()@collection.js:154 < Channel_onDataAvail()@resource.js:451
(In reply to comment #15)
> This may look like the same error. Latest sync 1.6.1
> 
> Could not create URI: Component returned failure code: 0x804b000a
> (NS_ERROR_MALFORMED_URI) [nsIIOService.newURI] Stack trace:
> Weave_makeURI()@util.js:1000 < HistStore_update()@history.js:359 <
> HistStore_create()@history.js:340 < Store_applyIncoming()@stores.js:66 <
> anonymous()@engines.js:486 < innerBind()@util.js:1381 <
> anonymous()@collection.js:154 < Channel_onDataAvail()@resource.js:451

This looks like a different issue, please file a new bug.
Guys,

I'm having the same issue.  Firefox 3.6.13; Sync Version 1.6.2
Cannot sync History...from about:sync-log

5000 outgoing items pre-reconciliation
2011-01-28 15:11:58	Store.History        WARN	Attempted to process invalid URI, skipping
2011-01-28 15:11:58	Engine.History       DEBUG	Total (ms): sync 22432, processIncoming 21223, syncStartup 1198, findDupe 197, createRecord 4012, isEqual 4042, deleteId 18, handleDupe 60, reconcile 13152, syncCleanup 6
2011-01-28 15:11:58	Service.Main         DEBUG	history failed: NS_ERROR_XPC_JS_THREW_STRING JS Stack trace: Channel_onStopRequest([object XPCWrappedNative_NoHelper],null,2153185310)@resource.js:444 < Res__request(...)@resource.js:357 < Res_get()@resource.js:376 < SyncEngine__processIncoming()@engines.js:511 < ()@engines.js:203 < SyncEngine__sync()@engines.js:768 < wrappedSync(null)@util.js:168 < runInBatchMode([object Object],null)@:0 < batchedSync()@util.js:174 < ()@engines.js:203 < WrappedNotify()@util.js:147 < Engine_sync()@engines.js:213 < WeaveSvc__syncEngine([object Object])@service.js:1739 < ()@service.js:1625 < WrappedNotify()@util.js:147 < WrappedLock()@util.js:119 < WrappedCatch()@util.js:97 < sync()@service.js:1530 < (0)@sync.js:380
2011-01-28 15:11:58	Engine.Passwords     INFO	1 outgoing items pre-reconciliation
(In reply to comment #17)
> I'm having the same issue.  Firefox 3.6.13; Sync Version 1.6.2
> Cannot sync History...from about:sync-log

This is not the same issue. Please file a *new* bug and attach your whole Sync log. Thanks!
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.