[advanced search] Add the remaining contact fields for use in the advanced search

RESOLVED DUPLICATE of bug 184483

Status

Thunderbird
Address Book
--
enhancement
RESOLVED DUPLICATE of bug 184483
8 years ago
5 years ago

People

(Reporter: Davide Mirtillo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; it; rv:1.9.2.9) Gecko/20100915 Thunderbird/3.1.4

The advanced search window avaible in the address book does not permit the user to set search conditions on all of the fields avaible in a contact, thus rendering the "advanced search" an incomplete function. I recognize there are lots of fields that can be set on a contact, but i currently have no other way of listing contacts by, say, region or state.

Reproducible: Always
Whiteboard: dupeme

Comment 1

8 years ago
Yes, every field should be searchable.
The default search from the search bar, should look in every field.

This other request is related:
https://bugzilla.mozilla.org/show_bug.cgi?id=467183
Bug 467183 - Address book search view: Want greater configurability & editability

Please remember to add your vote following the link next to the "Importance"
field above !
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 184483
(In reply to Davide Mirtillo from comment #0)
> The advanced search window avaible in the address book does not permit the
> user to set search conditions on all of the fields avaible in a contact,
> thus rendering the "advanced search" an incomplete function. I recognize
> there are lots of fields that can be set on a contact, but i currently have
> no other way of listing contacts by, say, region or state.

+1. Davide and Edgardo from comment 1, thanks for your RFE, which is obviously valid and useful.
I'm trying to consolidate duplicate requests in bug 184483.

Unfortunately, not too much hope for the current Address book (with a new one in the pipe but not seen yet), but if we're lucky we might find a volunteer to code up fix for bug 184483.
Whiteboard: dupeme
OS: Windows 7 → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.